summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-09-17 10:12:51 +0000
committerPeter Volkov <pva@gentoo.org>2008-09-17 10:12:51 +0000
commit9b4e8af0edccc4267835e3046e514fd03bf99f72 (patch)
treebe97b24d2e945eb70c40b16671679fa90a1ddd8d /app-misc
parentx86emu is the only backend available for amd64 (bug #224987) (diff)
downloadgentoo-2-9b4e8af0edccc4267835e3046e514fd03bf99f72.tar.gz
gentoo-2-9b4e8af0edccc4267835e3046e514fd03bf99f72.tar.bz2
gentoo-2-9b4e8af0edccc4267835e3046e514fd03bf99f72.zip
Fixed glibc-2.8 build issue, bug #227121, thank Evil Compile Person for report.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gcal/ChangeLog6
-rw-r--r--app-misc/gcal/gcal-3.01-r2.ebuild24
2 files changed, 19 insertions, 11 deletions
diff --git a/app-misc/gcal/ChangeLog b/app-misc/gcal/ChangeLog
index 7b45a1165ddf..94b0204a8e58 100644
--- a/app-misc/gcal/ChangeLog
+++ b/app-misc/gcal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/gcal
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/ChangeLog,v 1.22 2008/02/03 15:25:43 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/ChangeLog,v 1.23 2008/09/17 10:12:51 pva Exp $
+
+ 17 Sep 2008; Peter Volkov <pva@gentoo.org> gcal-3.01-r2.ebuild:
+ Fixed glibc-2.8 build issue, bug #227121, thank Evil Compile Person for
+ report.
03 Feb 2008; Fabian Groffen <grobian@gentoo.org> gcal-3.01-r2.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/app-misc/gcal/gcal-3.01-r2.ebuild b/app-misc/gcal/gcal-3.01-r2.ebuild
index 6c63b0e60c93..99824f4e3c89 100644
--- a/app-misc/gcal/gcal-3.01-r2.ebuild
+++ b/app-misc/gcal/gcal-3.01-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/gcal-3.01-r2.ebuild,v 1.12 2008/02/03 17:40:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/gcal-3.01-r2.ebuild,v 1.13 2008/09/17 10:12:51 pva Exp $
-inherit eutils
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="The GNU Calendar - a replacement for cal"
HOMEPAGE="http://www.gnu.org/software/gcal/gcal.html"
@@ -17,27 +17,31 @@ DEPEND="nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-mandir.diff
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-mandir.diff
+ find -name Makefile.in -print0 | \
+ xargs -0 -n1 sed -i "s:\(^CC = \).*:\1$(tc-getCC):"
}
src_compile() {
- econf $(use_enable nls) $(use_enable ncurses) || die
+ append-flags -D_GNU_SOURCE
+ econf $(use_enable nls) $(use_enable ncurses)
emake || die
}
src_install() {
einstall || die
- rm -f ${D}/usr/share/locale/locale.alias
+ rm -f "${D}"/usr/share/locale/locale.alias
- dodoc ABOUT-NLS ATTENTION BUGS DISCLAIM HISTORY \
- INSTALL LIMITATIONS MANIFEST NEWS README SYMBOLS THANKS TODO
+ dodoc ATTENTION BUGS DISCLAIM HISTORY LIMITATIONS MANIFEST NEWS README \
+ SYMBOLS THANKS TODO
# Need to fix up paths for scripts in misc directory
# that are automatically created by the makefile
- for miscfile in ${D}/usr/share/gcal/misc/*/*
+ for miscfile in "${D}"/usr/share/gcal/misc/*/*
do
- dosed "s:${D%/}::g" ${miscfile/${D}}
+ dosed "s:${D%/}::g" "${miscfile/${D}}"
done
# Rebuild the symlinks that makefile created into the image /usr/bin