summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-30 17:09:52 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-30 17:09:52 +0000
commit86a1b171bd5c196ca68acc019b98fea47c80a10d (patch)
treecee6ad8a1cc0959f18eccffdd0c67550fdd359be /app-misc
parentVersion bump <http://my.opera.com/desktopteam/blog/2010/04/30/fixing-crash-bu... (diff)
downloadgentoo-2-86a1b171bd5c196ca68acc019b98fea47c80a10d.tar.gz
gentoo-2-86a1b171bd5c196ca68acc019b98fea47c80a10d.tar.bz2
gentoo-2-86a1b171bd5c196ca68acc019b98fea47c80a10d.zip
Fix for #300657, thanks Gianluigi Tiesi for providing the patches
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/realpath/ChangeLog8
-rw-r--r--app-misc/realpath/files/realpath-1.15-nonls.patch25
-rw-r--r--app-misc/realpath/realpath-1.15-r1.ebuild60
3 files changed, 92 insertions, 1 deletions
diff --git a/app-misc/realpath/ChangeLog b/app-misc/realpath/ChangeLog
index 0d804e5c1408..2562908b8bff 100644
--- a/app-misc/realpath/ChangeLog
+++ b/app-misc/realpath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/realpath
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.2 2010/04/01 17:14:14 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.3 2010/04/30 17:09:52 jlec Exp $
+
+*realpath-1.15-r1 (30 Apr 2010)
+
+ 30 Apr 2010; Justin Lecher <jlec@gentoo.org> +realpath-1.15-r1.ebuild,
+ +files/realpath-1.15-nonls.patch:
+ Fix for #300657, thanks Gianluigi Tiesi for providing the patches
01 Apr 2010; Raúl Porcel <armin76@gentoo.org> realpath-1.15.ebuild:
m68k/s390/sh stable
diff --git a/app-misc/realpath/files/realpath-1.15-nonls.patch b/app-misc/realpath/files/realpath-1.15-nonls.patch
new file mode 100644
index 000000000000..1a6c0d6d376c
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.15-nonls.patch
@@ -0,0 +1,25 @@
+--- realpath-1.15/src/realpath.c.orig 2010-01-12 03:20:42 +0000
++++ realpath-1.15/src/realpath.c 2010-01-12 03:20:59 +0000
+@@ -23,9 +23,8 @@
+ #include <errno.h>
+ #include <getopt.h>
+ #include <stdarg.h>
+-#include <libintl.h>
+
+-#define _(String) gettext (String)
++#define _(String) (String)
+
+ static char *stripdir(char * dir, char *buf, int maxlen);
+
+@@ -115,11 +114,6 @@
+
+ myname = ( p = strchr(argv[0], '/') ) ? p+1 : argv[0];
+
+- setlocale(LC_ALL, "");
+- bindtextdomain(PACKAGE, LOCALEDIR);
+- textdomain(PACKAGE);
+-
+-
+ parse_options(argc, argv);
+
+ while (optind < argc) {
diff --git a/app-misc/realpath/realpath-1.15-r1.ebuild b/app-misc/realpath/realpath-1.15-r1.ebuild
new file mode 100644
index 000000000000..25381f20a36d
--- /dev/null
+++ b/app-misc/realpath/realpath-1.15-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/realpath-1.15-r1.ebuild,v 1.1 2010/04/30 17:09:52 jlec Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Return the canonicalized absolute pathname"
+HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
+SRC_URI="mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz
+ nls? ( mirror://debian/pool/main/r/${PN}/${PN}_${PV}_i386.deb )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="!sys-freebsd/freebsd-bin"
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+
+ if use nls; then
+ # Unpack the .deb file, in order to get the preprocessed man page
+ # translations. This way we avoid a dependency on app-text/po4a.
+ mkdir deb
+ cd deb
+ unpack ${PN}_${PV}_i386.deb
+ unpack ./data.tar.gz
+ gunzip -r usr/share/man || die "gunzip failed"
+ else
+ epatch "${FILESDIR}"/${PN}-1.15-nonls.patch
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.14-build.patch
+ epatch "${FILESDIR}"/${PN}-1.14-no-po4a.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" \
+ DESTDIR="${D}" install || die "emake install failed"
+ newdoc debian/changelog ChangeLog.debian
+
+ if use nls; then
+ local dir
+ for dir in "${WORKDIR}"/deb/usr/share/man/*; do
+ [ -f "${dir}"/man1/realpath.1 ] || continue
+ newman "${dir}"/man1/realpath.1 realpath.${dir##*/}.1 \
+ || die "newman failed"
+ done
+ fi
+}