summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2015-08-07 02:11:26 +0000
committerChris Reffett <creffett@gentoo.org>2015-08-07 02:11:26 +0000
commit724f46b1d49e0a1c426da252c7b233c9d12a3218 (patch)
treec0f14e799239a0b0808711702337f17266bc7ffe /app-misc
parentFix bugs #549140 and #552942. (diff)
downloadgentoo-2-724f46b1d49e0a1c426da252c7b233c9d12a3218.tar.gz
gentoo-2-724f46b1d49e0a1c426da252c7b233c9d12a3218.tar.bz2
gentoo-2-724f46b1d49e0a1c426da252c7b233c9d12a3218.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xD1BAB6B528DB029C)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/xmind/ChangeLog8
-rw-r--r--app-misc/xmind/xmind-3.5.3.201506180105.ebuild89
2 files changed, 96 insertions, 1 deletions
diff --git a/app-misc/xmind/ChangeLog b/app-misc/xmind/ChangeLog
index a21877676cbf..b4ac46a8c77a 100644
--- a/app-misc/xmind/ChangeLog
+++ b/app-misc/xmind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/xmind
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xmind/ChangeLog,v 1.13 2015/02/17 22:45:13 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xmind/ChangeLog,v 1.14 2015/08/07 02:11:26 creffett Exp $
+
+*xmind-3.5.3.201506180105 (07 Aug 2015)
+
+ 07 Aug 2015; Chris Reffett <creffett@gentoo.org>
+ +xmind-3.5.3.201506180105.ebuild:
+ Version bump
*xmind-3.5.1.201411201906 (17 Feb 2015)
diff --git a/app-misc/xmind/xmind-3.5.3.201506180105.ebuild b/app-misc/xmind/xmind-3.5.3.201506180105.ebuild
new file mode 100644
index 000000000000..84dd30158d78
--- /dev/null
+++ b/app-misc/xmind/xmind-3.5.3.201506180105.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xmind/xmind-3.5.3.201506180105.ebuild,v 1.1 2015/08/07 02:11:26 creffett Exp $
+
+EAPI=5
+
+inherit eutils multilib gnome2-utils
+
+MY_PN="${PN}-portable"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A brainstorming and mind mapping software tool"
+HOMEPAGE="http://www.xmind.net"
+SRC_URI="http://dl2.xmind.net/xmind-downloads/${MY_P}.zip
+ http://dev.gentoo.org/~creffett/distfiles/xmind-icons.tar.xz"
+LICENSE="EPL-1.0 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5
+ x11-libs/gtk+:2
+"
+
+S=${WORKDIR}
+
+QA_PRESTRIPPED="opt/xmind/XMind/libcairo-swt.so"
+QA_FLAGS_IGNORED="
+ opt/xmind/Commons/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20120522-1813/eclipse_1502.so
+ opt/xmind/Commons/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.200.v20120522-1813/eclipse_1502.so
+ opt/xmind/XMind/libcairo-swt.so
+ opt/xmind/XMind/XMind
+"
+
+src_configure() {
+ if use amd64; then
+ XDIR="XMind_Linux_64bit"
+ else
+ XDIR="XMind_Linux"
+ fi
+ mv "$XDIR" XMind || die
+ mv XMind/.eclipseproduct Commons || die
+ cp "${FILESDIR}"/${PN}-3.4.0-config.ini Commons/configuration || die #Combined common+linux config.ini
+ # force data instance & config area to be at home/.xmind directory
+ sed -i -e '/-configuration/d' \
+ -e '/\.\/configuration/d' \
+ -e '/-data/d' \
+ -e '/\.\.\/Commons\/data\/workspace-cathy/d' \
+ -e 's/\.\.\/Commons/\/opt\/xmind\/Commons/g' XMind/XMind.ini || die
+ echo '-Dosgi.instance.area=@user.home/.xmind/workspace-cathy' >> XMind/XMind.ini || die
+ echo '-Dosgi.configuration.area=@user.home/.xmind/configuration-cathy' >> XMind/XMind.ini || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /opt/xmind
+ doins -r Commons XMind || die
+ fperms a+rx "/opt/xmind/XMind/XMind"
+
+ dodir /opt/bin
+ exeinto /opt/bin
+ newexe "${FILESDIR}/xmind-wrapper" xmind
+
+ # install icons
+ local res
+ for res in 16 32 48; do
+ newicon -s ${res} "${WORKDIR}/xmind-icons/xmind.${res}.png" xmind.png
+ done
+
+ # make desktop entry
+ make_desktop_entry "xmind %F" XMind xmind Office "MimeType=application/x-xmind;"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ elog "For audio notes support, install media-sound/lame"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}