summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-02-23 14:51:03 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-02-23 14:51:03 +0000
commit63962068d51c6bef509d4aca3e99daa37132903e (patch)
tree7fe00749c38774461960722083675d92f826b6ef /app-misc
parentStable for alpha, wrt bug #458188 (diff)
downloadgentoo-2-63962068d51c6bef509d4aca3e99daa37132903e.tar.gz
gentoo-2-63962068d51c6bef509d4aca3e99daa37132903e.tar.bz2
gentoo-2-63962068d51c6bef509d4aca3e99daa37132903e.zip
Don't install libtool archives by default (bug #457754). Ported ebuild to EAPI-5. Small cleanups
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/uptimed/ChangeLog6
-rw-r--r--app-misc/uptimed/uptimed-0.3.17-r1.ebuild20
2 files changed, 17 insertions, 9 deletions
diff --git a/app-misc/uptimed/ChangeLog b/app-misc/uptimed/ChangeLog
index 4d84438c7876..c79f309875da 100644
--- a/app-misc/uptimed/ChangeLog
+++ b/app-misc/uptimed/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/uptimed
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/uptimed/ChangeLog,v 1.93 2013/02/19 16:33:12 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/uptimed/ChangeLog,v 1.94 2013/02/23 14:51:03 polynomial-c Exp $
+
+ 23 Feb 2013; Lars Wendler <polynomial-c@gentoo.org> uptimed-0.3.17-r1.ebuild:
+ Don't install libtool archives by default (bug #457754). Ported ebuild to
+ EAPI-5. Small cleanups.
19 Feb 2013; Agostino Sarubbo <ago@gentoo.org> uptimed-0.3.17-r1.ebuild:
Stable for alpha, wrt bug #457250
diff --git a/app-misc/uptimed/uptimed-0.3.17-r1.ebuild b/app-misc/uptimed/uptimed-0.3.17-r1.ebuild
index 32450630440e..c9994ab0ebde 100644
--- a/app-misc/uptimed/uptimed-0.3.17-r1.ebuild
+++ b/app-misc/uptimed/uptimed-0.3.17-r1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/uptimed/uptimed-0.3.17-r1.ebuild,v 1.7 2013/02/19 16:33:12 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/uptimed/uptimed-0.3.17-r1.ebuild,v 1.8 2013/02/23 14:51:03 polynomial-c Exp $
-inherit autotools user
+EAPI=5
+
+inherit autotools eutils user
DESCRIPTION="System uptime record daemon that keeps track of your highest uptimes"
HOMEPAGE="http://podgorny.cz/uptimed"
@@ -11,17 +13,14 @@ SRC_URI="http://podgorny.cz/uptimed/releases/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~arm ~hppa ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
+IUSE="static-libs"
pkg_setup() {
enewgroup uptimed
enewuser uptimed -1 -1 -1 uptimed
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# respect DESTDIR
sed -i -e 's|-d \(/var/spool.*\)$|-d $(DESTDIR)\1|' Makefile.am || \
die "sed failed."
@@ -29,8 +28,13 @@ src_unpack() {
eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ default
+ prune_libtool_files --all
keepdir /var/spool/uptimed
fowners uptimed:uptimed /var/spool/uptimed
dodoc ChangeLog README TODO AUTHORS CREDITS INSTALL.cgi sample-cgi/*