summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-10-16 07:31:30 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-10-16 07:31:30 +0000
commit5fd8e5da4bbe1e7dcb983fae7de92832eb0bd14f (patch)
tree0194cc8ed863c88484dcbca4f409351ea3024bd4 /app-misc
parentVersion bump. (diff)
downloadgentoo-2-5fd8e5da4bbe1e7dcb983fae7de92832eb0bd14f.tar.gz
gentoo-2-5fd8e5da4bbe1e7dcb983fae7de92832eb0bd14f.tar.bz2
gentoo-2-5fd8e5da4bbe1e7dcb983fae7de92832eb0bd14f.zip
Porting some patches from ubuntu
(Portage version: 2.1.2_pre3-r1)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tomboy/ChangeLog9
-rw-r--r--app-misc/tomboy/files/digest-tomboy-0.4.1-r13
-rw-r--r--app-misc/tomboy/files/tomboy-0.4.1-init-some-stuff.patch62
-rw-r--r--app-misc/tomboy/files/tomboy-0.4.1-verbs.patch33
-rw-r--r--app-misc/tomboy/tomboy-0.4.1-r1.ebuild53
5 files changed, 159 insertions, 1 deletions
diff --git a/app-misc/tomboy/ChangeLog b/app-misc/tomboy/ChangeLog
index 7e2ad0f99849..559906a0dd70 100644
--- a/app-misc/tomboy/ChangeLog
+++ b/app-misc/tomboy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/tomboy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tomboy/ChangeLog,v 1.27 2006/09/16 10:22:14 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tomboy/ChangeLog,v 1.28 2006/10/16 07:31:30 compnerd Exp $
+
+*tomboy-0.4.1-r1 (16 Oct 2006)
+
+ 16 Oct 2006; <compnerd@gentoo.org>
+ +files/tomboy-0.4.1-init-some-stuff.patch,
+ +files/tomboy-0.4.1-verbs.patch, +tomboy-0.4.1-r1.ebuild:
+ add some patches from ubuntu
16 Sep 2006; Tobias Scherbaum <dertobi123@gentoo.org> tomboy-0.4.1.ebuild:
re-added ~ppc, bug #147751
diff --git a/app-misc/tomboy/files/digest-tomboy-0.4.1-r1 b/app-misc/tomboy/files/digest-tomboy-0.4.1-r1
new file mode 100644
index 000000000000..2a09b218b86e
--- /dev/null
+++ b/app-misc/tomboy/files/digest-tomboy-0.4.1-r1
@@ -0,0 +1,3 @@
+MD5 7e9ab15b8c799d265676173f8a8de7ce tomboy-0.4.1.tar.gz 937041
+RMD160 8837330b651ad1fee5952ef4b7c66072b661f417 tomboy-0.4.1.tar.gz 937041
+SHA256 a2d0690b8fe37c5e8179dabb70832fca07bc2b09c3013dbb252dc507e1c3d900 tomboy-0.4.1.tar.gz 937041
diff --git a/app-misc/tomboy/files/tomboy-0.4.1-init-some-stuff.patch b/app-misc/tomboy/files/tomboy-0.4.1-init-some-stuff.patch
new file mode 100644
index 000000000000..17e8b7e16617
--- /dev/null
+++ b/app-misc/tomboy/files/tomboy-0.4.1-init-some-stuff.patch
@@ -0,0 +1,62 @@
+--- Tomboy/Tray.cs.orig 2006-10-03 14:58:21.000000000 -0500
++++ Tomboy/Tray.cs 2006-10-03 15:01:31.000000000 -0500
+@@ -50,8 +50,6 @@
+ tips.Sink ();
+
+ SetupDragAndDrop ();
+-
+- InitSomeStuff ();
+ }
+
+ void ButtonPress (object sender, Gtk.ButtonPressEventArgs args)
+@@ -398,49 +396,9 @@
+ int icon_size = Math.Min (rect.Height, rect.Width);
+ if (icon_size_last != icon_size) {
+ icon_size_last = icon_size;
+- image.Pixbuf = GuiUtils.GetIcon (GetIconName (), icon_size);
+- }
+- }
+-
+- void ReloadIcon ()
+- {
+- icon_size_last = -1;
+- QueueResize ();
++ image.Pixbuf = GuiUtils.GetIcon ("tomboy", icon_size);
+ }
+-
+- // NOTHING TO SEE HERE
+- void InitSomeStuff ()
+- {
+- manager.NoteDeleted += OnNoteDeletedUpdateIcon;
+- manager.NoteAdded += OnNoteAddedUpdateIcon;
+- manager.NoteRenamed += OnNoteRenamedUpdateIcon;
+- }
+-
+- void OnNoteDeletedUpdateIcon (object sender, Note changed)
+- {
+- if (changed.Title == "Tintin")
+- ReloadIcon ();
+- }
+-
+- void OnNoteAddedUpdateIcon (object sender, Note changed)
+- {
+- if (changed.Title == "Tintin")
+- ReloadIcon ();
+- }
+-
+- void OnNoteRenamedUpdateIcon (Note note, string old_title)
+- {
+- if (note.Title == "Tintin" || old_title == "Tintin")
+- ReloadIcon ();
+- }
+-
+- string GetIconName ()
+- {
+- if (manager.Find ("Tintin") != null)
+- return "tintin";
+- return "tomboy";
+ }
+- // GO ABOUT YOUR BUSINESS
+ }
+
+ //
diff --git a/app-misc/tomboy/files/tomboy-0.4.1-verbs.patch b/app-misc/tomboy/files/tomboy-0.4.1-verbs.patch
new file mode 100644
index 000000000000..3fc5ec8d00db
--- /dev/null
+++ b/app-misc/tomboy/files/tomboy-0.4.1-verbs.patch
@@ -0,0 +1,33 @@
+--- Tomboy/Applet.cs 2006-10-03 15:36:22.000000000 -0500
++++ Tomboy/Applet.cs 2006-10-03 15:45:51.000000000 -0500
+@@ -17,7 +17,8 @@
+ TomboyTray tray;
+ TomboyGConfXKeybinder keybinder;
+
+- BonoboUIVerb [] menu_verbs;
++ // Keep referenced so our callbacks don't get reaped
++ static BonoboUIVerb[] menu_verbs;
+
+ public TomboyApplet (IntPtr raw)
+ : base (raw)
+@@ -49,14 +50,13 @@
+ ShowAll ();
+
+ // Keep referenced so our callbacks don't get reaped.
+- menu_verbs = new BonoboUIVerb [] {
+- new BonoboUIVerb (
+- "Props", new ContextMenuItemCallback (ShowPreferencesVerb)),
+- new BonoboUIVerb (
+- "Plugins", new ContextMenuItemCallback (ShowPluginsVerb)),
+- new BonoboUIVerb (
+- "About", new ContextMenuItemCallback (ShowAboutVerb))
++ if (menu_verbs == null) {
++ menu_verbs = new BonoboUIVerb[] {
++ new BonoboUIVerb("Props", ShowPreferencesVerb),
++ new BonoboUIVerb("Plugins", ShowPluginsVerb),
++ new BonoboUIVerb("About", ShowAboutVerb)
+ };
++ }
+
+ SetupMenuFromResource (null, "GNOME_TomboyApplet.xml", menu_verbs);
+ }
diff --git a/app-misc/tomboy/tomboy-0.4.1-r1.ebuild b/app-misc/tomboy/tomboy-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..f6b1cd94194d
--- /dev/null
+++ b/app-misc/tomboy/tomboy-0.4.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tomboy/tomboy-0.4.1-r1.ebuild,v 1.1 2006/10/16 07:31:30 compnerd Exp $
+
+inherit gnome2 mono eutils
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://www.beatniksoftware.com/tomboy/"
+SRC_URI="http://www.beatniksoftware.com/tomboy/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc eds galago"
+
+RDEPEND=">=dev-lang/mono-1.1
+ >=dev-dotnet/gtk-sharp-2
+ >=dev-dotnet/gconf-sharp-2
+ >=dev-dotnet/gnome-sharp-2
+ >=sys-apps/dbus-0.60
+ >=x11-libs/gtk+-2.6.0
+ >=dev-libs/atk-1.2.4
+ >=gnome-base/gconf-2
+ >=app-text/gtkspell-2.0.9
+ >=gnome-base/gnome-panel-2.8.2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ eds? ( dev-libs/gmime )
+ galago? ( =dev-dotnet/galago-sharp-0.5* )
+ >=app-text/aspell-0.60.2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.25"
+
+DOCS="AUTHORS Changelog INSTALL NEWS README"
+
+pkg_setup() {
+ if use eds && ! built_with_use 'dev-libs/gmime' mono ; then
+ eerror "Please build gmime with the mono USE-flag"
+ die "gmime without mono support detected"
+ fi
+
+ G2CONF="${G2CONF} $(use_enable galago) $(use_enable eds evolution)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Apply patches taken from ubuntu
+ epatch ${FILESDIR}/${PN}-0.4.1-init-some-stuff.patch
+ epatch ${FILESDIR}/${PN}-0.4.1-verbs.patch
+}