summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-12-25 14:47:53 +0000
committerSamuli Suominen <drac@gentoo.org>2007-12-25 14:47:53 +0000
commit5dd4a5238f2cb00caed746572bcb4d3b8439793e (patch)
tree0f5b089a91ce002d4d1d53455da117913694422e /app-misc
parentAdd 169.07. (diff)
downloadgentoo-2-5dd4a5238f2cb00caed746572bcb4d3b8439793e.tar.gz
gentoo-2-5dd4a5238f2cb00caed746572bcb4d3b8439793e.tar.bz2
gentoo-2-5dd4a5238f2cb00caed746572bcb4d3b8439793e.zip
Applied includes patch from Debian project, fixing asm/io.h vs. sys/io.h problem with sanitized linux headers but most likely also building on Alpha and FreeBSD.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/rio/ChangeLog8
-rw-r--r--app-misc/rio/files/rio-1.0.7-includes.patch65
-rw-r--r--app-misc/rio/rio-1.0.7-r1.ebuild22
3 files changed, 84 insertions, 11 deletions
diff --git a/app-misc/rio/ChangeLog b/app-misc/rio/ChangeLog
index a7cf66914fbe..4d68174eca96 100644
--- a/app-misc/rio/ChangeLog
+++ b/app-misc/rio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/rio
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/ChangeLog,v 1.7 2007/05/14 16:47:40 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/ChangeLog,v 1.8 2007/12/25 14:47:53 drac Exp $
+
+ 25 Dec 2007; Samuli Suominen <drac@gentoo.org>
+ +files/rio-1.0.7-includes.patch, rio-1.0.7-r1.ebuild:
+ Applied includes patch from Debian project, fixing asm/io.h vs. sys/io.h
+ problem with sanitized linux headers but most likely also building on Alpha
+ and FreeBSD.
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/app-misc/rio/files/rio-1.0.7-includes.patch b/app-misc/rio/files/rio-1.0.7-includes.patch
new file mode 100644
index 000000000000..040505f7e267
--- /dev/null
+++ b/app-misc/rio/files/rio-1.0.7-includes.patch
@@ -0,0 +1,65 @@
+diff -ur rio107.orig/app.cpp rio107/app.cpp
+--- rio107.orig/app.cpp 1999-06-11 19:26:46.000000000 +0300
++++ rio107/app.cpp 2007-12-25 16:34:39.000000000 +0200
+@@ -43,7 +43,7 @@
+ #endif
+ #define DELETEARRAY delete[]
+
+-#elif defined(__FreeBSD__)
++#elif defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
+ // FreeBSD g++
+ #include <unistd.h>
+ #include <sys/syslimits.h>
+diff -ur rio107.orig/rio.cpp rio107/rio.cpp
+--- rio107.orig/rio.cpp 1999-06-11 19:26:46.000000000 +0300
++++ rio107/rio.cpp 2007-12-25 16:34:39.000000000 +0200
+@@ -63,18 +63,36 @@
+ #elif defined(__linux__)
+ // linux g++
+ #include <unistd.h>
+- #if defined(__alpha)
+- #include <sys/io.h>
++
++ // Changed per Debian bug 50938
++ //#if defined(__alpha)
++ // #include <sys/io.h>
++ //#else
++ // #include <sys/perm.h>
++ //#endif
++
++ // Changes per Debian bug 50938
++ #if !defined(__i386__)
++ #include <sys/io.h>
+ #else
+- #include <sys/perm.h>
++ #include <sys/perm.h>
+ #endif
++
++ // Changed per bug Debian bug 88779
++ #if !defined(__alpha__)
++ #if __GLIBC__
++ #include <sys/io.h>
++ #else
+ #include <asm/io.h>
++ #endif
++ #endif
++
+ #define OUTPORT(p,v) outb( v, p )
+ #define INPORT(p) inb( p )
+ #define CLOCK_SECOND CLOCKS_PER_SEC
+ #define DELETEARRAY delete[]
+
+-#elif defined(__FreeBSD__)
++#elif defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
+ // FreeBSD g++
+ #include <fcntl.h>
+ #include <unistd.h>
+@@ -236,7 +254,7 @@
+ #endif
+
+ // if FreeBSD
+- #if defined(__FreeBSD__)
++ #if defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
+ // request direct access to memory addresses
+ if ( open("/dev/io", O_RDONLY) == -1 )
+ {
diff --git a/app-misc/rio/rio-1.0.7-r1.ebuild b/app-misc/rio/rio-1.0.7-r1.ebuild
index 63662ccd70f3..469277bab711 100644
--- a/app-misc/rio/rio-1.0.7-r1.ebuild
+++ b/app-misc/rio/rio-1.0.7-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/rio-1.0.7-r1.ebuild,v 1.1 2005/08/20 03:07:11 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/rio-1.0.7-r1.ebuild,v 1.2 2007/12/25 14:47:53 drac Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Utility for the Diamond Rio 300 portable MP3 player"
HOMEPAGE="http://www.world.co.uk/sba/rio.html"
SRC_URI="http://www.world.co.uk/sba/${PN}007.tgz"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
SLOT="0"
LICENSE="GPL-2"
IUSE=""
@@ -19,16 +19,18 @@ RDEPEND=""
S="${WORKDIR}/${PN}${PV//./}"
src_unpack() {
- unpack ${A}; cd ${S}
- epatch ${FILESDIR}/${P}-makefile.patch
- epatch ${FILESDIR}/${P}-gentoo.patch
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-includes.patch
}
src_compile() {
- emake || die "compile failed"
+ emake CXX="$(tc-getCXX)" || die "emake failed."
}
src_install() {
- dobin rio || die
- dodoc CREDITS README gpl.txt playlist.txt rio.txt
+ dobin rio
+ dodoc CREDITS README playlist.txt rio.txt
}