summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-03-25 10:37:40 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-03-25 10:37:40 +0000
commit572b2c4296e32fa0fce2f1e0d77893a19b9be12e (patch)
tree94bb79c4c3a75ee7cbeb76e5c1031e09d3938663 /app-misc
parentNew application, bug 408051. Ebuild by Pavlos Ratis. (diff)
downloadgentoo-2-572b2c4296e32fa0fce2f1e0d77893a19b9be12e.tar.gz
gentoo-2-572b2c4296e32fa0fce2f1e0d77893a19b9be12e.tar.bz2
gentoo-2-572b2c4296e32fa0fce2f1e0d77893a19b9be12e.zip
Bump to 1.3.5, fix autoreconf invocation in 1.3.2-r1. Thanks to slepnoga
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/hivex/ChangeLog11
-rw-r--r--app-misc/hivex/files/1.3.5/0001-add_ocaml_triplet_in_configure.ac.patch17
-rw-r--r--app-misc/hivex/files/1.3.5/0002-add_per_triplet_in_configure.ac.patch36
-rw-r--r--app-misc/hivex/files/1.3.5/0003-fix_python_defenition_configure.ac.patch16
-rw-r--r--app-misc/hivex/hivex-1.3.2-r1.ebuild6
-rw-r--r--app-misc/hivex/hivex-1.3.5.ebuild82
6 files changed, 164 insertions, 4 deletions
diff --git a/app-misc/hivex/ChangeLog b/app-misc/hivex/ChangeLog
index c1260b2a0c47..eebcc46bfc05 100644
--- a/app-misc/hivex/ChangeLog
+++ b/app-misc/hivex/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/hivex
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.12 2012/02/26 19:56:32 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.13 2012/03/25 10:37:40 maksbotan Exp $
+
+*hivex-1.3.5 (25 Mar 2012)
+
+ 25 Mar 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/1.3.5/0001-add_ocaml_triplet_in_configure.ac.patch,
+ +files/1.3.5/0002-add_per_triplet_in_configure.ac.patch,
+ +files/1.3.5/0003-fix_python_defenition_configure.ac.patch,
+ +hivex-1.3.5.ebuild, hivex-1.3.2-r1.ebuild:
+ Bump to 1.3.5, fix autoreconf invocation in 1.3.2-r1. Thanks to slepnoga
*hivex-1.3.3 (26 Feb 2012)
diff --git a/app-misc/hivex/files/1.3.5/0001-add_ocaml_triplet_in_configure.ac.patch b/app-misc/hivex/files/1.3.5/0001-add_ocaml_triplet_in_configure.ac.patch
new file mode 100644
index 000000000000..d82db8a1aff3
--- /dev/null
+++ b/app-misc/hivex/files/1.3.5/0001-add_ocaml_triplet_in_configure.ac.patch
@@ -0,0 +1,17 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -187,10 +187,12 @@
+ AM_CONDITIONAL([HAVE_HIVEXSH],[test "x$ac_cv_func_open_memstream" = "xyes"])
+
+ dnl Check for OCaml (optional, for OCaml bindings).
++AC_ARG_ENABLE([ocaml],
++ AS_HELP_STRING([--with-ocaml],[build Ocaml binding]))
+ AC_PROG_OCAML
+ AC_PROG_FINDLIB
+ AM_CONDITIONAL([HAVE_OCAML],
+- [test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno"])
++ [test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno" -a "x$enable_ocaml" = "xyes"]])
+ AM_CONDITIONAL([HAVE_OCAMLOPT],
+ [test "x$OCAMLOPT" != "xno" && test "x$OCAMLFIND" != "xno"])
+
diff --git a/app-misc/hivex/files/1.3.5/0002-add_per_triplet_in_configure.ac.patch b/app-misc/hivex/files/1.3.5/0002-add_per_triplet_in_configure.ac.patch
new file mode 100644
index 000000000000..f3339d2bd9f4
--- /dev/null
+++ b/app-misc/hivex/files/1.3.5/0002-add_per_triplet_in_configure.ac.patch
@@ -0,0 +1,36 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -245,8 +245,31 @@
+ AC_MSG_WARN([some Perl modules required to compile or test the Perl bindings are missing])
+ fi
+
++AC_ARG_ENABLE([perl],
++ AS_HELP_STRING([--with-perl],[build Perl binding]))
++
++
++PERL=
++AS_IF([test "x$enable_perl" != "xno" ],[
++ AC_CHECK_PROG([PERL],[perl],[yes],[no])
++
++ for pm in Test::More ExtUtils::MakeMaker IO::Stringy; do
++ AC_MSG_CHECKING([for $pm])
++ if ! perl -M$pm -e1 >/dev/null 2>&1; then
++ AC_MSG_RESULT([no])
++ missing_perl_modules=yes
++ else
++ AC_MSG_RESULT([yes])
++ fi
++ done
++
++ AS_IF([test "x$missing_perl_modules" = "xyes"],
++ [AC_MSG_FAILURE([some Perl modules required to compile or test the Perl bindings are missing])],
++ )
++])
++
+ AM_CONDITIONAL([HAVE_PERL],
+- [test "x$PERL" != "xno" && test "x$missing_perl_modules" != "xyes"])
++ [test "x$PERL" != "xno" && test "x$missing_perl_modules" != "xyes" -a "x$enable_perl" = "xyes"])
+
+ dnl Check for Python (optional, for Python bindings).
+ PYTHON_PREFIX=
diff --git a/app-misc/hivex/files/1.3.5/0003-fix_python_defenition_configure.ac.patch b/app-misc/hivex/files/1.3.5/0003-fix_python_defenition_configure.ac.patch
new file mode 100644
index 000000000000..d74b17c1e7c5
--- /dev/null
+++ b/app-misc/hivex/files/1.3.5/0003-fix_python_defenition_configure.ac.patch
@@ -0,0 +1,16 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -336,8 +336,11 @@
+ AC_SUBST(PYTHON_INCLUDEDIR)
+ AC_SUBST(PYTHON_INSTALLDIR)
+
++AC_ARG_ENABLE([python],
++ AS_HELP_STRING([--with-python],[build Python binding]))
++
+ AM_CONDITIONAL([HAVE_PYTHON],
+- [test "x$PYTHON" != "xno" && test "x$PYTHON_INCLUDEDIR" != "x" && test "x$PYTHON_INSTALLDIR" != "x"])
++ [test "x$PYTHON_INCLUDEDIR" != "x" -a "x$PYTHON_SITE_PACKAGES" != "x" -a "x$enable_python" = "xyes"])
+
+ dnl Check for Ruby and rake (optional, for Ruby bindings).
+ AC_ARG_ENABLE([ruby],
diff --git a/app-misc/hivex/hivex-1.3.2-r1.ebuild b/app-misc/hivex/hivex-1.3.2-r1.ebuild
index 1b56b5461c24..1811354e28c8 100644
--- a/app-misc/hivex/hivex-1.3.2-r1.ebuild
+++ b/app-misc/hivex/hivex-1.3.2-r1.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.2-r1.ebuild,v 1.1 2011/12/01 17:26:53 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.2-r1.ebuild,v 1.2 2012/03/25 10:37:40 maksbotan Exp $
EAPI=4
WANT_AUTOMAKE="1.11"
AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
PYTHON_DEPEND="python? 2:2.6"
inherit base autotools-utils perl-app python
@@ -50,7 +51,6 @@ pkg_setup() {
src_prepare() {
autotools-utils_src_prepare
- eautoreconf
}
src_configure() {
diff --git a/app-misc/hivex/hivex-1.3.5.ebuild b/app-misc/hivex/hivex-1.3.5.ebuild
new file mode 100644
index 000000000000..75278a3eed23
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.5.ebuild,v 1.1 2012/03/25 10:37:40 maksbotan Exp $
+
+EAPI=4
+
+WANT_AUTOMAKE="1.11"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+USE_RUBY="ruby18"
+RUBY_OPTIONAL=yes
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit base autotools-utils perl-app python
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline perl python test static-libs ruby"
+
+RDEPEND="virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline )
+ perl? ( dev-perl/IO-stringy )
+ "
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage ) )
+ ruby? ( dev-ruby/rake )
+ "
+PATCHES=("${FILESDIR}"/"${PV}")
+DOCS=(README)
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ python_need_rebuild
+ fi
+}
+
+src_prepare() {
+ EPATCH_SUFFIX=patch EPATCH_FORCE=yes base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ $(use_enable python)
+ $(use_enable ruby)
+ --disable-rpath )
+
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_compile check
+}
+
+src_install() {
+ strip-linguas -i po
+
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ if use perl; then
+ fixlocalpod
+ fi
+}