summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-05-10 09:06:14 +0000
committerMichael Weber <xmw@gentoo.org>2011-05-10 09:06:14 +0000
commit44530a61854a300e0c1f676094569f0eebde3c43 (patch)
treedb9f5ae664c359602ac4cb5d1f85a298758556c7 /app-misc
parentVersion bump (diff)
downloadgentoo-2-44530a61854a300e0c1f676094569f0eebde3c43.tar.gz
gentoo-2-44530a61854a300e0c1f676094569f0eebde3c43.tar.bz2
gentoo-2-44530a61854a300e0c1f676094569f0eebde3c43.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/wipe/ChangeLog11
-rw-r--r--app-misc/wipe/files/wipe-2.3.1-LDFLAGS.patch19
-rw-r--r--app-misc/wipe/metadata.xml4
-rw-r--r--app-misc/wipe/wipe-2.3.1.ebuild40
4 files changed, 70 insertions, 4 deletions
diff --git a/app-misc/wipe/ChangeLog b/app-misc/wipe/ChangeLog
index 186dee6979d1..7b9f4d4ba2cc 100644
--- a/app-misc/wipe/ChangeLog
+++ b/app-misc/wipe/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/wipe
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/ChangeLog,v 1.24 2010/09/19 03:56:16 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/ChangeLog,v 1.25 2011/05/10 09:06:14 xmw Exp $
+
+*wipe-2.3.1 (10 May 2011)
+
+ 10 May 2011; Michael Weber <xmw@gentoo.org> +wipe-2.3.1.ebuild,
+ +files/wipe-2.3.1-LDFLAGS.patch, metadata.xml:
+ Taking care of this one, version bump (thanks to AwoL, bug 365741), ebuild
+ update
*wipe-2.2.20050509-r1 (19 Sep 2010)
diff --git a/app-misc/wipe/files/wipe-2.3.1-LDFLAGS.patch b/app-misc/wipe/files/wipe-2.3.1-LDFLAGS.patch
new file mode 100644
index 000000000000..23a5d19d1cd7
--- /dev/null
+++ b/app-misc/wipe/files/wipe-2.3.1-LDFLAGS.patch
@@ -0,0 +1,19 @@
+--- wipe-2.3.1/Makefile.in
++++ wipe-2.3.1/Makefile.in
+@@ -5,6 +5,7 @@
+
+ CC=@CC@
+ CFLAGS=@CFLAGS@ -I@srcdir@ -D@OSTYPE@ $(DEFINES)
++LDFLAGS=@LDFLAGS@
+ DEBUG=@DEBUG@ -I@srcdir@ -D@OSTYPE@ $(DEFINES)
+
+ LIBS=@LIBS@
+@@ -31,7 +32,7 @@
+ all: $(REQ) $(BIN)
+
+ $(BIN): main.o wipe.o rand.o dir.o file.o blkdev.o lock.o text.o str.o percent.o prompt.o io.o mt.o
+- $(CC) $(LIBS) *.o -o $@
++ $(CC) $(LIBS) *.o -o $@ $(LDFLAGS)
+
+
+ # restores everything to a pre-configured state
diff --git a/app-misc/wipe/metadata.xml b/app-misc/wipe/metadata.xml
index b17012b02b48..5355a5e8f3e7 100644
--- a/app-misc/wipe/metadata.xml
+++ b/app-misc/wipe/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
- <description>This package lacks a primary herd or maintainer.</description>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
</maintainer>
</pkgmetadata>
diff --git a/app-misc/wipe/wipe-2.3.1.ebuild b/app-misc/wipe/wipe-2.3.1.ebuild
new file mode 100644
index 000000000000..4feb8dccd77d
--- /dev/null
+++ b/app-misc/wipe/wipe-2.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.3.1.ebuild,v 1.1 2011/05/10 09:06:14 xmw Exp $
+
+EAPI=3
+
+inherit autotools eutils
+
+DESCRIPTION="Secure file wiping utility based on Peter Gutman's patterns"
+HOMEPAGE="http://wipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wipe/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="!sys-cluster/lam-mpi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-LDFLAGS.patch
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin wipe || die
+ doman wipe.1 || die
+ dodoc CHANGES README TODO TESTING || die
+}
+
+pkg_postinst() {
+ elog "Note that wipe is useless on journaling filesystems,"
+ elog "such as reiserfs, XFS, or ext3."
+ elog "See documentation for more info."
+}