summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-02 09:50:16 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-02 09:50:16 +0000
commit43c672423020ef4b08d721099daa19a7b081d212 (patch)
tree36773524a0d20eb6dc50c9872f24667925331e5d /app-misc
parentVersion bump, reverting to earlier patchset as suggested by Oliver Jaksch in ... (diff)
downloadgentoo-2-43c672423020ef4b08d721099daa19a7b081d212.tar.gz
gentoo-2-43c672423020ef4b08d721099daa19a7b081d212.tar.bz2
gentoo-2-43c672423020ef4b08d721099daa19a7b081d212.zip
Version bump.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/pax-utils/ChangeLog9
-rw-r--r--app-misc/pax-utils/pax-utils-1.0.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/app-misc/pax-utils/ChangeLog b/app-misc/pax-utils/ChangeLog
index 6985f2c080cd..01cb00ee156d 100644
--- a/app-misc/pax-utils/ChangeLog
+++ b/app-misc/pax-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/pax-utils
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.169 2014/11/20 01:36:28 vapier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.170 2015/03/02 09:50:16 vapier Exp $
+
+*pax-utils-1.0 (02 Mar 2015)
+
+ 02 Mar 2015; Mike Frysinger <vapier@gentoo.org> +pax-utils-1.0.ebuild:
+ Version bump.
*pax-utils-0.9.2 (20 Nov 2014)
diff --git a/app-misc/pax-utils/pax-utils-1.0.ebuild b/app-misc/pax-utils/pax-utils-1.0.ebuild
new file mode 100644
index 000000000000..222cae11dcf0
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-1.0.ebuild,v 1.1 2015/03/02 09:50:16 vapier Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs unpacker
+
+DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
+HOMEPAGE="http://hardened.gentoo.org/pax-utils.xml"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.xz
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="caps python"
+
+RDEPEND="caps? ( sys-libs/libcap )
+ python? ( dev-python/pyelftools )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+_emake() {
+ emake \
+ USE_CAP=$(usex caps) \
+ USE_PYTHON=$(usex python) \
+ "$@"
+}
+
+src_configure() {
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux || \
+ has_version '<sys-libs/glibc-2.10'
+ then
+ econf $(use_with caps) $(use_with python)
+ else
+ tc-export CC
+ fi
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" PKGDOCDIR='$(DOCDIR)'/${PF} install
+}