summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-13 18:28:58 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-13 18:28:58 +0000
commit339047efec82e3e2afaa89d178d1e338a472e524 (patch)
tree6be8b2305bd5b96351012419c95f2aa3da8b7da9 /app-misc
parentAdd new ebuild for www-misc/reflector-2011.05.13.1 fixing bug 317831. (diff)
downloadgentoo-2-339047efec82e3e2afaa89d178d1e338a472e524.tar.gz
gentoo-2-339047efec82e3e2afaa89d178d1e338a472e524.tar.bz2
gentoo-2-339047efec82e3e2afaa89d178d1e338a472e524.zip
Version bump. Drop darwin patches since the related code has changed and I can't verify the patches. Bug 364761.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/sphinx/ChangeLog8
-rw-r--r--app-misc/sphinx/sphinx-2.0.1_beta.ebuild94
2 files changed, 101 insertions, 1 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index 6f5f45119379..110196cfd845 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/sphinx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.34 2011/05/09 18:52:04 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.35 2011/05/13 18:28:58 graaff Exp $
+
+*sphinx-2.0.1_beta (13 May 2011)
+
+ 13 May 2011; Hans de Graaff <graaff@gentoo.org> +sphinx-2.0.1_beta.ebuild:
+ Version bump. Drop darwin patches since the related code has changed and I
+ can't verify the patches. Bug 364761.
09 May 2011; Hans de Graaff <graaff@gentoo.org> -sphinx-0.9.9-r1.ebuild,
-sphinx-1.10_beta.ebuild:
diff --git a/app-misc/sphinx/sphinx-2.0.1_beta.ebuild b/app-misc/sphinx/sphinx-2.0.1_beta.ebuild
new file mode 100644
index 000000000000..e06c936f09a4
--- /dev/null
+++ b/app-misc/sphinx/sphinx-2.0.1_beta.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-2.0.1_beta.ebuild,v 1.1 2011/05/13 18:28:58 graaff Exp $
+
+EAPI=3
+inherit eutils autotools
+
+MY_P=${P/_/-}
+
+# This has been added by Gentoo, to explicitly version libstemmer.
+# It is the date that http://snowball.tartarus.org/dist/libstemmer_c.tgz was
+# fetched.
+STEMMER_PV="20091122"
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/files/${MY_P}.tar.gz
+ stemmer? ( mirror://gentoo/libstemmer_c-${STEMMER_PV}.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="debug id64 mysql odbc postgres stemmer test"
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ odbc? ( dev-db/unixODBC )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ test? ( dev-lang/php )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if use stemmer; then
+ cd "${S}"
+ unpack libstemmer_c-${STEMMER_PV}.tgz
+ fi
+}
+
+src_prepare() {
+ # drop nasty hardcoded search path breaking Prefix
+ sed -i -e '/\/usr\/local\//d' configure.ac || die
+ eautoreconf
+
+ cd api/libsphinxclient || die
+ eautoreconf
+}
+
+src_configure() {
+ # fix libiconv detection
+ use !elibc_glibc && export ac_cv_search_iconv=-liconv
+
+ econf \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ $(use_enable id64) \
+ $(use_with debug) \
+ $(use_with mysql) \
+ $(use_with odbc unixodbc) \
+ $(use_with postgres pgsql) \
+ $(use_with stemmer libstemmer)
+
+ cd api/libsphinxclient || die
+ econf STRIP=:
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ emake -j 1 -C api/libsphinxclient || die "emake libsphinxclient failed"
+}
+
+src_test() {
+ elog "Tests require access to a live MySQL database and may require configuration."
+ elog "You will find them in /usr/share/${PN}/test and they require dev-lang/php"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" -C api/libsphinxclient install || die "install libsphinxclient failed"
+
+ dodoc doc/*
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+ dodir /var/run/sphinx
+
+ newinitd "${FILESDIR}"/searchd.rc searchd
+
+ if use test; then
+ insinto /usr/share/${PN}
+ doins -r test || die "install of test files failed."
+ fi
+}