summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-01-13 02:59:05 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-01-13 02:59:05 +0000
commit27dc0f56ed90a59084f3697ccfb5ce663d865b45 (patch)
tree052c8e51ac64580f488471ee613333c5b94ae499 /app-misc
parentChanged from emake to make (diff)
downloadgentoo-2-27dc0f56ed90a59084f3697ccfb5ce663d865b45.tar.gz
gentoo-2-27dc0f56ed90a59084f3697ccfb5ce663d865b45.tar.bz2
gentoo-2-27dc0f56ed90a59084f3697ccfb5ce663d865b45.zip
new version (keymasked). Fixes some gcc-3.2 issues.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/celestia/ChangeLog11
-rw-r--r--app-misc/celestia/celestia-1.2.5.ebuild61
-rw-r--r--app-misc/celestia/files/digest-celestia-1.2.51
3 files changed, 72 insertions, 1 deletions
diff --git a/app-misc/celestia/ChangeLog b/app-misc/celestia/ChangeLog
index 420a1123658a..abb97ed7c82f 100644
--- a/app-misc/celestia/ChangeLog
+++ b/app-misc/celestia/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/celestia
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/celestia/ChangeLog,v 1.5 2002/11/10 10:15:16 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/celestia/ChangeLog,v 1.6 2003/01/13 02:59:05 george Exp $
+
+*celestia-1.2.5 (12 Jan 2003)
+
+ 12 Jan 2003l George Shapovalov <george@gentoo.org> celestia-1.2.5.ebuild :
+
+ new version. Looks like gcc-3.x issue were fixed.
+ Also problems were reported when compiling celestia with nvidia drivers
+ The fix is to opengl-update xfree && emerge celestia && opengl-update nvidia.
+ See also #6417
*celestia-1.2.4 (4 May 2002)
diff --git a/app-misc/celestia/celestia-1.2.5.ebuild b/app-misc/celestia/celestia-1.2.5.ebuild
new file mode 100644
index 000000000000..a815ce8c92d6
--- /dev/null
+++ b/app-misc/celestia/celestia-1.2.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/celestia/celestia-1.2.5.ebuild,v 1.1 2003/01/13 02:59:05 george Exp $
+
+inherit flag-o-matic
+
+IUSE="gtk gnome"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Celestia is a free real-time space simulation that lets you experience our universe in three dimensions"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.shatters.net/celestia"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="gtk? ( =x11-libs/gtk+-1.2*
+ <x11-libs/gtkglarea-1.99.0 )
+ gnome? ( =gnome-base/gnome-libs-1.4* )
+ >=media-libs/glut-3.7-r2
+ virtual/glu
+ media-libs/jpeg
+ media-libs/libpng"
+
+#src_unpack() {
+# unpack ${A}
+# cd ${S}
+#
+# patch -p1 < ${FILESDIR}/celestia-gcc3.patch
+#}
+
+pkg_setup() {
+ einfo "Please note:"
+ einfo "if you experience problems building celestia with nvidia drivers,"
+ einfo "you can try:"
+ einfo "opengl-update xfree"
+ einfo "emerge celestia"
+ einfo "opengl-update nvidia"
+}
+
+src_compile() {
+ local myconf
+
+ filter-flags "-funroll-loops -frerun-loop-opt"
+
+ # currently celestia's "gtk support" requires gnome
+ use gtk || myconf="--without-gtk"
+ use gnome || myconf="--without-gtk"
+
+ ./configure --prefix=/usr ${myconf} || die
+
+ emake all || die
+}
+
+src_install() {
+ make install prefix=${D}/usr
+
+ dodoc AUTHORS COPYING NEWS README TODO controls.txt
+ dohtml manual/*.html manual/*.css
+}
diff --git a/app-misc/celestia/files/digest-celestia-1.2.5 b/app-misc/celestia/files/digest-celestia-1.2.5
new file mode 100644
index 000000000000..72c6de893718
--- /dev/null
+++ b/app-misc/celestia/files/digest-celestia-1.2.5
@@ -0,0 +1 @@
+MD5 23b525a431cf9be66f4f943c131a47bb celestia-1.2.5.tar.gz 13921719