summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-10-26 16:38:04 +0000
committerThomas Kahle <tomka@gentoo.org>2012-10-26 16:38:04 +0000
commit2005fe365def9465cc0f29a67bfa77df7c1d42d5 (patch)
tree74b6442037c2776d1c1dd0a1e2945e6bf7937581 /app-misc
parentAdd spanish (es) description (diff)
downloadgentoo-2-2005fe365def9465cc0f29a67bfa77df7c1d42d5.tar.gz
gentoo-2-2005fe365def9465cc0f29a67bfa77df7c1d42d5.tar.bz2
gentoo-2-2005fe365def9465cc0f29a67bfa77df7c1d42d5.zip
Remove duplicate desktop entry. Thanks Karl-Robert Ernst in bug 439726
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/anki/ChangeLog7
-rw-r--r--app-misc/anki/anki-2.0.0-r1.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/app-misc/anki/ChangeLog b/app-misc/anki/ChangeLog
index ead0b6f34477..182a03c6517b 100644
--- a/app-misc/anki/ChangeLog
+++ b/app-misc/anki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/anki
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.43 2012/10/23 17:02:25 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.44 2012/10/26 16:38:04 tomka Exp $
+
+*anki-2.0.0-r1 (26 Oct 2012)
+
+ 26 Oct 2012; Thomas Kahle <tomka@gentoo.org> +anki-2.0.0-r1.ebuild:
+ Remove duplicate desktop entry. Thanks Karl-Robert Ernst in bug 439726
*anki-2.0.0 (23 Oct 2012)
diff --git a/app-misc/anki/anki-2.0.0-r1.ebuild b/app-misc/anki/anki-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..fe7bf5535e7d
--- /dev/null
+++ b/app-misc/anki/anki-2.0.0-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/anki-2.0.0-r1.ebuild,v 1.1 2012/10/26 16:38:04 tomka Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6"
+
+inherit eutils python
+
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="http://ichi2.net/anki/"
+SRC_URI="http://ankisrs.net/download/mirror/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex +recording +sound"
+
+RDEPEND="dev-python/PyQt4[X,svg,webkit]
+ >=dev-python/httplib2-0.7.4
+ dev-python/beautifulsoup:python-2
+ recording? ( media-sound/lame
+ >=dev-python/pyaudio-0.2.4 )
+ sound? ( media-video/mplayer )
+ latex? ( app-text/texlive
+ app-text/dvipng )"
+DEPEND=""
+
+S=${WORKDIR}/anki-2.0
+
+pkg_setup(){
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ rm -r libanki/thirdparty || die
+ python_convert_shebangs -r 2 .
+}
+
+# Nothing to configure or compile
+src_configure() {
+ true;
+}
+
+src_compile() {
+ true;
+}
+
+src_install() {
+ exeinto /usr/bin/
+ doexe anki
+
+ doicon ${PN}.png
+ domenu anki.desktop
+
+ doman anki.1
+
+ dodoc README README.development README.translating
+ insinto "$(python_get_sitedir)"
+ doins -r aqt libanki/anki
+}
+
+pkg_preinst() {
+ if has_version "<app-misc/anki-2" ; then
+ elog "Anki 2 is a rewrite of Anki with many new features and"
+ elog "a new database format. On the first run your decks are"
+ elog "converted to the new format and a backup of your Anki-1"
+ elog "decks is created. Please read the following:"
+ elog "http://ankisrs.net/anki2.html"
+ elog "The mobile clients for Anki 2 are still under development."
+ fi
+}