summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-04-26 18:34:14 +0000
committerAron Griffis <agriffis@gentoo.org>2002-04-26 18:34:14 +0000
commit1a6802f03777b748f86d29695b514997f65084d5 (patch)
treeb936726338df651f30a30949c8354c564afdfae5 /app-misc
parentAdded linux-identd. (diff)
downloadgentoo-2-1a6802f03777b748f86d29695b514997f65084d5.tar.gz
gentoo-2-1a6802f03777b748f86d29695b514997f65084d5.tar.bz2
gentoo-2-1a6802f03777b748f86d29695b514997f65084d5.zip
Fixed bug #2053
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/vlock/ChangeLog25
-rw-r--r--app-misc/vlock/files/digest-vlock-1.3-r11
-rw-r--r--app-misc/vlock/files/vlock.pamd1
-rw-r--r--app-misc/vlock/vlock-1.3-r1.ebuild29
4 files changed, 48 insertions, 8 deletions
diff --git a/app-misc/vlock/ChangeLog b/app-misc/vlock/ChangeLog
index 4b4a47bbc215..7e98d0b6025e 100644
--- a/app-misc/vlock/ChangeLog
+++ b/app-misc/vlock/ChangeLog
@@ -1,13 +1,22 @@
# ChangeLog for app-misc/vlock
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/vlock/ChangeLog,v 1.1 2002/02/01 21:53:08 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/vlock/ChangeLog,v 1.2 2002/04/26 18:34:14 agriffis Exp $
+
+*vlock-1.3-r1 (26 Apr 2002)
+
+ 26 Apr 2002; Aron Griffis <agriffis@gentoo.org> vlock-1.3-r1.ebuild files/vlock.pamd :
+
+ Fixed bug #2053: Install vlock entry in /etc/pam.d. Also make setuid root
+ so that root's password can be used to unlock a terminal (see the README
+ for more information).
*vlock-1.3 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/app-misc/vlock/files/digest-vlock-1.3-r1 b/app-misc/vlock/files/digest-vlock-1.3-r1
new file mode 100644
index 000000000000..4d8b06048c7d
--- /dev/null
+++ b/app-misc/vlock/files/digest-vlock-1.3-r1
@@ -0,0 +1 @@
+MD5 d04076f9c5f12aadc4d5fbbabf8a0c12 vlock-1.3.tar.gz 17188
diff --git a/app-misc/vlock/files/vlock.pamd b/app-misc/vlock/files/vlock.pamd
new file mode 100644
index 000000000000..48e7d87358fd
--- /dev/null
+++ b/app-misc/vlock/files/vlock.pamd
@@ -0,0 +1 @@
+auth required /lib/security/pam_stack.so service=system-auth
diff --git a/app-misc/vlock/vlock-1.3-r1.ebuild b/app-misc/vlock/vlock-1.3-r1.ebuild
new file mode 100644
index 000000000000..f6e496e16a04
--- /dev/null
+++ b/app-misc/vlock/vlock-1.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <alkaline@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/vlock/vlock-1.3-r1.ebuild,v 1.1 2002/04/26 18:34:14 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A console screen locker"
+
+SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/utils/console/vlock-1.3.tar.gz"
+HOMEPAGE="http://"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ emake RPM_OPT_FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ cd ${S}
+ dobin vlock
+ # Setuid root is required to unlock a screen with root's password.
+ # This is "safe" because vlock drops privs ASAP; read the README
+ # for more information.
+ fperms 4711 /usr/bin/vlock
+ doman vlock.1
+ dodoc COPYING README
+ insinto /etc/pam.d
+ newins ${FILESDIR}/vlock.pamd vlock
+}