summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-05-19 21:02:11 +0000
committerThilo Bangert <bangert@gentoo.org>2010-05-19 21:02:11 +0000
commit15b6fbc18d8d3b8103d0f1e59fe3c9291c371d48 (patch)
tree3f71e2df32529693e239a014d56c45d6a3096669 /app-misc
parentremoved needless empty line (diff)
downloadgentoo-2-15b6fbc18d8d3b8103d0f1e59fe3c9291c371d48.tar.gz
gentoo-2-15b6fbc18d8d3b8103d0f1e59fe3c9291c371d48.tar.bz2
gentoo-2-15b6fbc18d8d3b8103d0f1e59fe3c9291c371d48.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/yagtd/ChangeLog10
-rw-r--r--app-misc/yagtd/files/yagtd-0.3.2-fix-install-setup.py.diff12
-rw-r--r--app-misc/yagtd/yagtd-0.3.2.ebuild28
3 files changed, 48 insertions, 2 deletions
diff --git a/app-misc/yagtd/ChangeLog b/app-misc/yagtd/ChangeLog
index a62f6bb55748..464ff0d7d81e 100644
--- a/app-misc/yagtd/ChangeLog
+++ b/app-misc/yagtd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/yagtd
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/yagtd/ChangeLog,v 1.6 2009/12/02 20:41:05 bangert Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/yagtd/ChangeLog,v 1.7 2010/05/19 21:02:11 bangert Exp $
+
+*yagtd-0.3.2 (19 May 2010)
+
+ 19 May 2010; Thilo Bangert <bangert@gentoo.org> +yagtd-0.3.2.ebuild,
+ +files/yagtd-0.3.2-fix-install-setup.py.diff:
+ version bump
*yagtd-0.3.0 (02 Dec 2009)
diff --git a/app-misc/yagtd/files/yagtd-0.3.2-fix-install-setup.py.diff b/app-misc/yagtd/files/yagtd-0.3.2-fix-install-setup.py.diff
new file mode 100644
index 000000000000..7140c944ef53
--- /dev/null
+++ b/app-misc/yagtd/files/yagtd-0.3.2-fix-install-setup.py.diff
@@ -0,0 +1,12 @@
+--- setup.py.orig 2010-05-19 22:51:26.000000000 +0200
++++ setup.py 2010-05-19 22:54:31.000000000 +0200
+@@ -33,8 +33,7 @@
+ ('share/doc/yagtd-0.3.2/rest', ['doc/yagtd.rest', 'doc/yagtd.png',
+ 'doc/yagtd.html', 'doc/default.css']),
+ ('share/man/man1', ['doc/yagtd.1']),
+- ('share/doc/yagtd-0.3.2/tools', ['tools/yagtd-mode.el',
+- 'tools/yagtd-s60.py'])],
++ ('share/doc/yagtd-0.3.2/tools', ['tools/yagtd-mode.el'])],
+ scripts=['src/yagtd.py'],
+ classifiers = ['Development Status :: 4 - Beta',
+ 'Intended Audience :: End Users/Desktop',
diff --git a/app-misc/yagtd/yagtd-0.3.2.ebuild b/app-misc/yagtd/yagtd-0.3.2.ebuild
new file mode 100644
index 000000000000..28ef40f9807c
--- /dev/null
+++ b/app-misc/yagtd/yagtd-0.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/yagtd/yagtd-0.3.2.ebuild,v 1.1 2010/05/19 21:02:11 bangert Exp $
+
+EAPI="2"
+
+inherit distutils eutils
+
+DESCRIPTION="CLI todo list manager based on the 'Getting Things Done' philosophy."
+HOMEPAGE="https://gna.org/projects/yagtd/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ #fix doc install location
+ sed -i -e "s:\/doc\/yagtd:\/doc\/${P}:g" setup.py || die
+ #dont try to install missing file
+ epatch "${FILESDIR}"/${P}-fix-install-setup.py.diff
+}
+
+src_install() {
+ distutils_src_install
+ dosym /usr/bin/yagtd.py /usr/bin/yagtd
+}