summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2013-02-02 04:17:19 +0000
committerAlex Alexander <wired@gentoo.org>2013-02-02 04:17:19 +0000
commit14b4ea0fbb45b95c9286cba286610f8d1b1b3ae7 (patch)
treed30aaf890a3c1eecba95ce5cf44848bc8d931d7b /app-misc
parentfixed broken xosd-config, bug #286632 (diff)
downloadgentoo-2-14b4ea0fbb45b95c9286cba286610f8d1b1b3ae7.tar.gz
gentoo-2-14b4ea0fbb45b95c9286cba286610f8d1b1b3ae7.tar.bz2
gentoo-2-14b4ea0fbb45b95c9286cba286610f8d1b1b3ae7.zip
this version breaks with -Os, filter it - bug #438558
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tmux/ChangeLog7
-rw-r--r--app-misc/tmux/tmux-1.7-r2.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
index 34089822cce7..52195cf3a481 100644
--- a/app-misc/tmux/ChangeLog
+++ b/app-misc/tmux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/tmux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.88 2013/01/08 15:12:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.89 2013/02/02 04:17:19 wired Exp $
+
+*tmux-1.7-r2 (02 Feb 2013)
+
+ 02 Feb 2013; Alex Alexander <wired@gentoo.org> +tmux-1.7-r2.ebuild:
+ this version breaks with -Os, filter it - bug #438558
*tmux-1.7-r1 (08 Jan 2013)
diff --git a/app-misc/tmux/tmux-1.7-r2.ebuild b/app-misc/tmux/tmux-1.7-r2.ebuild
new file mode 100644
index 000000000000..b876069792c9
--- /dev/null
+++ b/app-misc/tmux/tmux-1.7-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.7-r2.ebuild,v 1.1 2013/02/02 04:17:19 wired Exp $
+
+EAPI=4
+
+inherit bash-completion-r1 flag-o-matic
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="vim-syntax"
+
+COMMON_DEPEND="
+ >=dev-libs/libevent-2.0.10
+ sys-libs/ncurses"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+
+DOCS=( CHANGES FAQ NOTES TODO )
+
+pkg_setup() {
+ if has_version "<app-misc/tmux-1.7"; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn
+ ewarn "WARNING: after updating to ${P} you will _not_ be able to connect to any"
+ ewarn "running 1.6 tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to tmux 1.6 to access them."
+ echo
+ fi
+}
+
+src_prepare() {
+ # look for config file in the prefix
+ sed -i -e '/SYSTEM_CFG/s:"/etc:"'"${EPREFIX}"'/etc:' tmux.h || die
+ # and don't just add some includes
+ sed -i -e 's:-I/usr/local/include::' Makefile.in || die
+
+ # bug 438558
+ # 1.7 segfaults when entering copy mode if compiled with -Os
+ replace-flags -Os -O2
+}
+
+src_install() {
+ default
+
+ newbashcomp examples/bash_completion_tmux.sh ${PN}
+
+ docinto examples
+ dodoc examples/*.conf
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim
+ fi
+}