summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 03:45:42 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 03:45:42 +0000
commit0f38da9ad341b1f6c277142878707ec947bb6057 (patch)
tree9f0bf0f9af3a168b4997181814d84c7ff7b09d18 /app-misc
parentQA - fix use invocation (Manifest recommit) (diff)
downloadgentoo-2-0f38da9ad341b1f6c277142878707ec947bb6057.tar.gz
gentoo-2-0f38da9ad341b1f6c277142878707ec947bb6057.tar.bz2
gentoo-2-0f38da9ad341b1f6c277142878707ec947bb6057.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/i810switch/i810switch-0.6.2.ebuild13
-rw-r--r--app-misc/ifp-line/ifp-line-0.2.3.ebuild16
-rw-r--r--app-misc/ithought/ithought-0.0.5-r1.ebuild13
-rw-r--r--app-misc/jail/jail-1.9-r1.ebuild12
-rw-r--r--app-misc/jbidwatcher/jbidwatcher-0.9.3_pre1.ebuild12
-rw-r--r--app-misc/jbidwatcher/jbidwatcher-0.9.3_pre2.ebuild12
-rw-r--r--app-misc/jive/jive-1.1.ebuild11
7 files changed, 42 insertions, 47 deletions
diff --git a/app-misc/i810switch/i810switch-0.6.2.ebuild b/app-misc/i810switch/i810switch-0.6.2.ebuild
index 138bf2733929..54ad01761271 100644
--- a/app-misc/i810switch/i810switch-0.6.2.ebuild
+++ b/app-misc/i810switch/i810switch-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/i810switch/i810switch-0.6.2.ebuild,v 1.4 2004/06/24 22:15:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/i810switch/i810switch-0.6.2.ebuild,v 1.5 2004/06/28 03:40:49 vapier Exp $
DESCRIPTION="A utility for switching the LCD and external VGA displays on and off"
HOMEPAGE="http://vorlon.ces.cwru.edu/~ames/i810switch/"
@@ -8,18 +8,17 @@ SRC_URI="http://vorlon.ces.cwru.edu/~ames/i810switch/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-alpha -hppa -mips -sparc x86"
+KEYWORDS="-* x86"
IUSE=""
-DEPEND="virtual/glibc"
+
+DEPEND="virtual/libc"
RDEPEND="sys-apps/pciutils"
-src_compile()
-{
+src_compile() {
emake || die "compile failed"
}
-src_install()
-{
+src_install() {
make DESTDIR=${D} install || die "install failed"
dodoc AUTHORS ChangeLog README TODO
}
diff --git a/app-misc/ifp-line/ifp-line-0.2.3.ebuild b/app-misc/ifp-line/ifp-line-0.2.3.ebuild
index 8c51c1a66650..20d8a3adfc8c 100644
--- a/app-misc/ifp-line/ifp-line-0.2.3.ebuild
+++ b/app-misc/ifp-line/ifp-line-0.2.3.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ifp-line/ifp-line-0.2.3.ebuild,v 1.4 2004/06/24 22:15:54 agriffis Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ifp-line/ifp-line-0.2.3.ebuild,v 1.5 2004/06/28 03:41:37 vapier Exp $
DESCRIPTION="iRiver iFP open-source driver"
HOMEPAGE="http://ifp-driver.sourceforge.net/"
SRC_URI="mirror://sourceforge/ifp-driver/${P}.tar.gz"
-RESTRICT="nomirror"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86" # User-submitted contained: "~sparc ~amd64 ~ppc"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
DEPEND="dev-libs/libusb"
@@ -20,13 +18,11 @@ src_compile() {
}
src_install() {
- dobin ifp
- dodoc COPYING NEWS README TIPS
+ dobin ifp || die
+ dodoc NEWS README TIPS
}
pkg_postinst() {
- ewarn
ewarn "to use ifp-line as non-root user, please follow"
ewarn "the instructions in /usr/share/doc/${P}/TIPS.gz"
- ewarn
}
diff --git a/app-misc/ithought/ithought-0.0.5-r1.ebuild b/app-misc/ithought/ithought-0.0.5-r1.ebuild
index 66c8b9f3f964..c43d306b4c25 100644
--- a/app-misc/ithought/ithought-0.0.5-r1.ebuild
+++ b/app-misc/ithought/ithought-0.0.5-r1.ebuild
@@ -1,29 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ithought/ithought-0.0.5-r1.ebuild,v 1.16 2004/06/24 22:16:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ithought/ithought-0.0.5-r1.ebuild,v 1.17 2004/06/28 03:42:29 vapier Exp $
#emerge doesn't yet support things like a5
MY_P=${P/0.0./a}
S=${WORKDIR}/${MY_P}
DESCRIPTION="An internet-aware personal thought manager"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
HOMEPAGE="http://ithought.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
IUSE=""
DEPEND="=x11-libs/gtk+-1.2*
dev-libs/libxml2"
-src_compile() {
- econf || die "econf failed"
- emake || die
-}
-
src_install() {
make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
}
diff --git a/app-misc/jail/jail-1.9-r1.ebuild b/app-misc/jail/jail-1.9-r1.ebuild
index 68c052afbd7d..2bde1ed4ded2 100644
--- a/app-misc/jail/jail-1.9-r1.ebuild
+++ b/app-misc/jail/jail-1.9-r1.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jail/jail-1.9-r1.ebuild,v 1.11 2004/06/24 22:16:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jail/jail-1.9-r1.ebuild,v 1.12 2004/06/28 03:43:18 vapier Exp $
inherit eutils
S="${WORKDIR}/${PN}_1-9_stable"
DESCRIPTION="Jail Chroot Project is a tool that builds a chrooted environment and automagically configures and builds all the required files, directories and libraries"
-SRC_URI="mirror://sourceforge/jail/${PN}_${PV}.tar.gz"
HOMEPAGE="http://www.jmcresearch.com/projects/jail/"
-RESTRICT="nomirror"
-IUSE=""
+SRC_URI="mirror://sourceforge/jail/${PN}_${PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 -ppc -sparc"
+KEYWORDS="x86"
+IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
RDEPEND="dev-lang/perl
dev-util/strace"
diff --git a/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre1.ebuild b/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre1.ebuild
index a1622aa0dfac..20a5d2e57c6a 100644
--- a/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre1.ebuild
+++ b/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre1.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre1.ebuild,v 1.3 2004/06/24 22:16:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre1.ebuild,v 1.4 2004/06/28 03:44:02 vapier Exp $
inherit java-pkg
DESCRIPTION="Ebay Bidder Tools for Sniping"
HOMEPAGE="http://jbidwatcher.sf.net/"
SRC_URI="mirror://sourceforge/jbidwatcher/${P/_/}.tar.gz"
+
LICENSE="LGPL-2.1"
-IUSE="jikes"
SLOT="0"
KEYWORDS="~x86"
+IUSE="jikes"
+
DEPEND=">=virtual/jdk-1.4
- dev-java/ant
- jikes? ( dev-java/jikes )"
+ dev-java/ant
+ jikes? ( dev-java/jikes )"
RDEPEND=">=virtual/jre-1.4"
S=${WORKDIR}/${P/_/}
-src_compile(){
+src_compile() {
sed -i 's:${user.home}/.jbidwatcher:.:' build.xml
sed -i 's:jikes:modern:' build.xml
diff --git a/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre2.ebuild b/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre2.ebuild
index 0b4bda87d1c8..549b8f4bbde0 100644
--- a/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre2.ebuild
+++ b/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre2.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre2.ebuild,v 1.2 2004/06/24 22:16:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jbidwatcher/jbidwatcher-0.9.3_pre2.ebuild,v 1.3 2004/06/28 03:44:02 vapier Exp $
inherit java-pkg
DESCRIPTION="Ebay Bidder Tools for Sniping"
HOMEPAGE="http://jbidwatcher.sf.net/"
SRC_URI="mirror://sourceforge/jbidwatcher/${P/_/}.tar.gz"
+
LICENSE="LGPL-2.1"
-IUSE="jikes"
SLOT="0"
KEYWORDS="~x86"
+IUSE="jikes"
+
DEPEND=">=virtual/jdk-1.4
- dev-java/ant
- jikes? ( dev-java/jikes )"
+ dev-java/ant
+ jikes? ( dev-java/jikes )"
RDEPEND=">=virtual/jre-1.4"
S=${WORKDIR}/${P/_/}
-src_compile(){
+src_compile() {
sed -i 's:${user.home}/.jbidwatcher:.:' build.xml
sed -i 's:jikes:modern:' build.xml
# Fix bad build.xml
diff --git a/app-misc/jive/jive-1.1.ebuild b/app-misc/jive/jive-1.1.ebuild
index c4828ec99057..d04e2c36d1e5 100644
--- a/app-misc/jive/jive-1.1.ebuild
+++ b/app-misc/jive/jive-1.1.ebuild
@@ -1,25 +1,26 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jive/jive-1.1.ebuild,v 1.6 2004/06/24 22:17:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jive/jive-1.1.ebuild,v 1.7 2004/06/28 03:45:42 vapier Exp $
DESCRIPTION="Filter that converts English text to Jive, by Adam Douglas"
HOMEPAGE="http://dev.gentoo.org/~brad/"
SRC_URI="http://dev.gentoo.org/~brad/${P}.tar.gz"
+
LICENSE="public-domain"
SLOT="0"
KEYWORDS="x86 ppc ~sparc"
IUSE=""
-DEPEND="virtual/glibc"
-#RDEPEND=""
+
+DEPEND="virtual/libc"
S=${WORKDIR}/${PN}
src_compile() {
- emake
+ emake || die
}
src_install() {
- dobin jive
+ dobin jive || die
doman jive.1
dodoc README POSTER
}