summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-11-28 23:45:06 +0000
committerHanno Böck <hanno@gentoo.org>2005-11-28 23:45:06 +0000
commit08f04363e197f4d8f5c0f01477621ea36ebb47d3 (patch)
tree5c716a4871ccdfa6bb26f9707338e20fda318571 /app-misc
parentNew Version bump, with fixes for bugs, 101948 110741 and 110234 (diff)
downloadgentoo-2-08f04363e197f4d8f5c0f01477621ea36ebb47d3.tar.gz
gentoo-2-08f04363e197f4d8f5c0f01477621ea36ebb47d3.tar.bz2
gentoo-2-08f04363e197f4d8f5c0f01477621ea36ebb47d3.zip
ktoblzcheck version bump and gcc41 fix
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ktoblzcheck/ChangeLog8
-rw-r--r--app-misc/ktoblzcheck/files/digest-ktoblzcheck-1.81
-rw-r--r--app-misc/ktoblzcheck/files/ktoblzcheck-1.8-gcc41.patch13
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.8.ebuild36
4 files changed, 57 insertions, 1 deletions
diff --git a/app-misc/ktoblzcheck/ChangeLog b/app-misc/ktoblzcheck/ChangeLog
index 18aba7214fd7..7164ce3ca21d 100644
--- a/app-misc/ktoblzcheck/ChangeLog
+++ b/app-misc/ktoblzcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/ktoblzcheck
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.27 2005/11/28 13:43:11 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.28 2005/11/28 23:45:06 hanno Exp $
+
+*ktoblzcheck-1.8 (28 Nov 2005)
+
+ 28 Nov 2005; Hanno Boeck <hanno@gentoo.org>
+ +files/ktoblzcheck-1.8-gcc41.patch, +ktoblzcheck-1.8.ebuild:
+ Version bump and fix for gcc 4.1.
28 Nov 2005; Gustavo Zacarias <gustavoz@gentoo.org>
ktoblzcheck-1.7.ebuild:
diff --git a/app-misc/ktoblzcheck/files/digest-ktoblzcheck-1.8 b/app-misc/ktoblzcheck/files/digest-ktoblzcheck-1.8
new file mode 100644
index 000000000000..54c8c2f4d1c1
--- /dev/null
+++ b/app-misc/ktoblzcheck/files/digest-ktoblzcheck-1.8
@@ -0,0 +1 @@
+MD5 5db25fb27011b94a697fef215632e6c4 ktoblzcheck-1.8.tar.gz 444335
diff --git a/app-misc/ktoblzcheck/files/ktoblzcheck-1.8-gcc41.patch b/app-misc/ktoblzcheck/files/ktoblzcheck-1.8-gcc41.patch
new file mode 100644
index 000000000000..c7a0c75ea464
--- /dev/null
+++ b/app-misc/ktoblzcheck/files/ktoblzcheck-1.8-gcc41.patch
@@ -0,0 +1,13 @@
+--- ktoblzcheck-1.7/src/include/iban.h 2005-05-24 10:04:21.000000000 +0200
++++ ktoblzcheck-1.7-gcc41/src/include/iban.h 2005-11-28 23:54:52.107511750 +0100
+@@ -219,8 +219,8 @@
+ bool readSpecTable(std::istream &fin, const std::string& stopcomment);
+ bool readCountryTable(std::istream &fin);
+ static int to_number(char c) { return c - 'A' + 10; }
+- static std::string IbanCheck::iban2number(const std::string& iban);
+- static int IbanCheck::modulo97(const std::string& number);
++ static std::string iban2number(const std::string& iban);
++ static int modulo97(const std::string& number);
+
+ specmap m_IbanSpec;
+ countrymap m_CountryMap;
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.8.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.8.ebuild
new file mode 100644
index 000000000000..5f408b271304
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.8.ebuild,v 1.1 2005/11/28 23:45:06 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ktoblzcheck/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ sys-apps/gawk
+ sys-apps/grep
+ sys-devel/libtool
+ sys-devel/gcc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/ktoblzcheck-1.8-gcc41.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall BANKDATA_PATH="${D}/usr/share/ktoblzcheck" || die
+}