summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-21 08:55:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-21 08:55:26 +0000
commit02c2195812a8c178da914a6c4737318932161c0b (patch)
tree3841a20cc2ca97b3605a964bfd6ea53ce46e915e /app-misc
parentRemove static linking, bug 273344 (diff)
downloadgentoo-2-02c2195812a8c178da914a6c4737318932161c0b.tar.gz
gentoo-2-02c2195812a8c178da914a6c4737318932161c0b.tar.bz2
gentoo-2-02c2195812a8c178da914a6c4737318932161c0b.zip
Version bump wrt #276470, thanks to Tobias Jakobi for reporting.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/emelfm2/ChangeLog7
-rw-r--r--app-misc/emelfm2/emelfm2-0.5.1.ebuild70
-rw-r--r--app-misc/emelfm2/emelfm2-0.6.2.ebuild58
-rw-r--r--app-misc/emelfm2/metadata.xml2
4 files changed, 65 insertions, 72 deletions
diff --git a/app-misc/emelfm2/ChangeLog b/app-misc/emelfm2/ChangeLog
index a0fbb5d365fc..fdf0f6b3e193 100644
--- a/app-misc/emelfm2/ChangeLog
+++ b/app-misc/emelfm2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/emelfm2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/emelfm2/ChangeLog,v 1.27 2009/04/20 20:34:38 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/emelfm2/ChangeLog,v 1.28 2009/07/21 08:55:26 ssuominen Exp $
+
+*emelfm2-0.6.2 (21 Jul 2009)
+
+ 21 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> +emelfm2-0.6.2.ebuild:
+ Version bump wrt #276470, thanks to Tobias Jakobi for reporting.
20 Apr 2009; Markus Meier <maekke@gentoo.org> emelfm2-0.4.1:
amd64 stable, bug #259212
diff --git a/app-misc/emelfm2/emelfm2-0.5.1.ebuild b/app-misc/emelfm2/emelfm2-0.5.1.ebuild
deleted file mode 100644
index 157126c2ab55..000000000000
--- a/app-misc/emelfm2/emelfm2-0.5.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/emelfm2/emelfm2-0.5.1.ebuild,v 1.1 2009/02/21 20:21:55 yngwin Exp $
-
-inherit eutils toolchain-funcs multilib
-
-DESCRIPTION="A file manager that implements the popular two-pane design"
-HOMEPAGE="http://emelfm2.net"
-SRC_URI="http://${PN}.net/rel/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="acl fam hal unicode"
-
-RESTRICT="test"
-
-RDEPEND=">=x11-libs/gtk+-2.12
- fam? ( virtual/fam )
- acl? ( sys-apps/acl )
- hal? ( sys-apps/hal
- sys-apps/dbus
- dev-libs/dbus-glib )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e "s:${PN}/${PN}_48.png:${PN}:" \
- docs/desktop_environment/${PN}.desktop || die "sed failed."
- sed -e "s:(PREFIX)/lib:(PREFIX)/$(get_libdir):" -e "s:strip:true:g" \
- -i Makefile || die "sed failed."
-}
-
-src_compile() {
- # These options need >=x11-libs/gtk-2.12 which we depend upon
- local myconf="USE_LATEST=1 WITH_TRANSPARENCY=1 PREFIX=/usr"
-
- if use acl; then
- myconf="${myconf} WITH_ACL=1"
- fi
-
- if use unicode; then
- myconf="${myconf} FILES_UTF8ONLY=1"
- fi
-
- if use fam; then
- if has_version "app-admin/gamin"; then
- myconf="${myconf} USE_GAMIN=1"
- else
- myconf="${myconf} USE_FAM=1"
- fi
- else
- myconf="${myconf} USE_FAM=0"
- fi
-
- if use hal; then
- myconf="${myconf} WITH_HAL=1"
- fi
-
- tc-export CC
- emake ICON_DIR="/usr/share/pixmaps/${PN}" ${myconf} || die "emake failed."
-}
-
-src_install() {
- emake PREFIX="${D}/usr" install || die "emake install failed."
- newicon icons/${PN}_48.png ${PN}.png
- prepalldocs
-}
diff --git a/app-misc/emelfm2/emelfm2-0.6.2.ebuild b/app-misc/emelfm2/emelfm2-0.6.2.ebuild
new file mode 100644
index 000000000000..7ca793b2a156
--- /dev/null
+++ b/app-misc/emelfm2/emelfm2-0.6.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/emelfm2/emelfm2-0.6.2.ebuild,v 1.1 2009/07/21 08:55:26 ssuominen Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A file manager that implements the popular two-pane design"
+HOMEPAGE="http://emelfm2.net"
+SRC_URI="http://${PN}.net/rel/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl fam gimp hal kernel_linux nls spell"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ acl? ( sys-apps/acl )
+ !kernel_linux? ( fam? ( virtual/fam ) )
+ gimp? ( media-gfx/gimp )
+ hal? ( sys-apps/hal
+ dev-libs/dbus-glib )
+ spell? ( app-text/gtkspell )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ myconf="DOCS_VERSION=1 WITH_TRANSPARENCY=1 USE_LATEST=1 STRIP=0"
+
+ use hal && myconf="${myconf} WITH_HAL=1"
+ use gimp && myconf="${myconf} WITH_THUMBS=1"
+ use acl && myconf="${myconf} WITH_ACL=1"
+ use kernel_linux && myconf="${myconf} WITH_KERNELFAM=1 USE_INOTIFY=1"
+ use spell && myconf="${myconf} EDITOR_SPELLCHECK=1"
+ use nls || myconf="${myconf} I18N=0"
+
+ if ! use kernel_linux && use fam; then
+ if has_version "app-admin/gamin"; then
+ myconf="${myconf} USE_GAMIN=1"
+ else
+ myconf="${myconf} USE_FAM=1"
+ fi
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake LIB_DIR="/usr/$(get_libdir)" PREFIX="/usr" \
+ ${myconf} || die "emake failed"
+}
+
+src_install() {
+ emake LIB_DIR="${D}/usr/$(get_libdir)" PREFIX="${D}/usr" \
+ ${myconf} install || die "emake install failed"
+ newicon icons/${PN}_48.png ${PN}.png
+ prepalldocs
+}
diff --git a/app-misc/emelfm2/metadata.xml b/app-misc/emelfm2/metadata.xml
index 540f810e069d..731225048652 100644
--- a/app-misc/emelfm2/metadata.xml
+++ b/app-misc/emelfm2/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>desktop-misc</herd>
+ <herd>desktop-misc</herd>
</pkgmetadata>