summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-21 08:46:15 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-21 08:46:15 +0000
commit0033ad752e2183fef2bb1c9c75bf2784e9e25c45 (patch)
treeb8f36689db5480d8f5f3983bbd3926571cb39a9b /app-misc
parentnew version (diff)
downloadgentoo-2-0033ad752e2183fef2bb1c9c75bf2784e9e25c45.tar.gz
gentoo-2-0033ad752e2183fef2bb1c9c75bf2784e9e25c45.tar.bz2
gentoo-2-0033ad752e2183fef2bb1c9c75bf2784e9e25c45.zip
Version bump
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/magicpoint/ChangeLog10
-rw-r--r--app-misc/magicpoint/files/digest-magicpoint-1.09a1
-rw-r--r--app-misc/magicpoint/magicpoint-1.09a.ebuild39
3 files changed, 49 insertions, 1 deletions
diff --git a/app-misc/magicpoint/ChangeLog b/app-misc/magicpoint/ChangeLog
index 14765d3d0a80..32afeb593ed9 100644
--- a/app-misc/magicpoint/ChangeLog
+++ b/app-misc/magicpoint/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/magicpoint
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/magicpoint/ChangeLog,v 1.1 2002/02/01 21:53:08 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/magicpoint/ChangeLog,v 1.2 2002/03/21 08:46:14 seemant Exp $
+
+*magicpoint-1.09a (21 Mar 2002)
+
+ 21 Mar 2002; Seemant Kulleen <seemant@gentoo.org> magicpoint-1.09a.ebuild :
+
+ Version upgrade -- copied the 1.07a ebuild over, and updated its syntax from
+ try to die and the copyright info. Thanks to Matthew Kennedy for the update
+ info.
*magicpoint-1.07a (1 Feb 2002)
diff --git a/app-misc/magicpoint/files/digest-magicpoint-1.09a b/app-misc/magicpoint/files/digest-magicpoint-1.09a
new file mode 100644
index 000000000000..4c185e51ef1f
--- /dev/null
+++ b/app-misc/magicpoint/files/digest-magicpoint-1.09a
@@ -0,0 +1 @@
+MD5 4fc48bd292a7c8b1aab656bf2f0af47d magicpoint-1.09a.tar.gz 816234
diff --git a/app-misc/magicpoint/magicpoint-1.09a.ebuild b/app-misc/magicpoint/magicpoint-1.09a.ebuild
new file mode 100644
index 000000000000..1f7195b278fe
--- /dev/null
+++ b/app-misc/magicpoint/magicpoint-1.09a.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author AJ Lewis <aj@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/magicpoint/magicpoint-1.09a.ebuild,v 1.1 2002/03/21 08:46:14 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="an X11 based presentation tool"
+SRC_URI="ftp://ftp.mew.org/pub/MagicPoint/${P}.tar.gz"
+HOMEPAGE="http://www.mew.org/mgp/"
+
+DEPEND="virtual/glibc virtual/x11
+ ungif? ( >=media-libs/libungif-4.0.1 )
+ gif? ( >=media-libs/giflib-4.0.1 )"
+
+src_compile() {
+
+ export LIBS="-L/usr/lib/ -L/usr/X11R6/lib/ -lX11"
+ if [ "`use gif`" ] && [ "`use ungif`" ] ; then
+ GIF_FLAG="--enable-gif";
+ else
+ GIF_FLAG="--disable-gif";
+ fi
+
+ ./configure --with-x ${GIF_FLAG} || die
+ xmkmf || die
+ make Makefiles || die
+ make clean || die
+ make ${MAKEOPTS} || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} DOCHTMLDIR=/usr/share/doc/${P} \
+ MANPATH=/usr/share/man MANSUFFIX=1 install.man || die
+
+ dodoc COPYRIGHT* FAQ README* RELNOTES SYNTAX TODO* USAGE*
+}
+
+