summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-05-16 20:49:40 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-05-16 20:49:40 +0000
commit6c97ed790b9fc74d40433da51dce80ac9f7e4f72 (patch)
tree380882b59c8030e34f2763f86bbc782c0b4b52c5 /app-misc/usbirboy
parentblock a couple more of dev-tex packages we are providing, thanks again to Hor... (diff)
downloadgentoo-2-6c97ed790b9fc74d40433da51dce80ac9f7e4f72.tar.gz
gentoo-2-6c97ed790b9fc74d40433da51dce80ac9f7e4f72.tar.bz2
gentoo-2-6c97ed790b9fc74d40433da51dce80ac9f7e4f72.zip
Version bumped, Bug #190732.
(Portage version: 2.1.5)
Diffstat (limited to 'app-misc/usbirboy')
-rw-r--r--app-misc/usbirboy/ChangeLog10
-rw-r--r--app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild10
-rw-r--r--app-misc/usbirboy/usbirboy-0.3.1.ebuild57
3 files changed, 70 insertions, 7 deletions
diff --git a/app-misc/usbirboy/ChangeLog b/app-misc/usbirboy/ChangeLog
index 7569267e9d15..840bcb9000fb 100644
--- a/app-misc/usbirboy/ChangeLog
+++ b/app-misc/usbirboy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/usbirboy
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/ChangeLog,v 1.17 2007/05/18 20:59:09 zzam Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/ChangeLog,v 1.18 2008/05/16 20:49:40 zzam Exp $
+
+*usbirboy-0.3.1 (16 May 2008)
+
+ 16 May 2008; Matthias Schwarzott <zzam@gentoo.org>
+ usbirboy-0.2.1-r1.ebuild, +usbirboy-0.3.1.ebuild:
+ Version bumped, Bug #190732.
18 May 2007; Matthias Schwarzott <zzam@gentoo.org> metadata.xml:
Assigned to herd media-tv.
diff --git a/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild b/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild
index 53efc97578d0..de5bdf5d1501 100644
--- a/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild
+++ b/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild,v 1.14 2007/07/12 03:35:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild,v 1.15 2008/05/16 20:49:40 zzam Exp $
inherit linux-mod eutils
@@ -37,9 +37,9 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-kernel-2.6.16.diff
- epatch ${FILESDIR}/${P}-module_param.diff
- epatch ${FILESDIR}/${P}-nice-kernel-msgs.diff
+ epatch "${FILESDIR}/${P}-kernel-2.6.16.diff"
+ epatch "${FILESDIR}/${P}-module_param.diff"
+ epatch "${FILESDIR}/${P}-nice-kernel-msgs.diff"
}
src_install() {
diff --git a/app-misc/usbirboy/usbirboy-0.3.1.ebuild b/app-misc/usbirboy/usbirboy-0.3.1.ebuild
new file mode 100644
index 000000000000..020e285380a3
--- /dev/null
+++ b/app-misc/usbirboy/usbirboy-0.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/usbirboy-0.3.1.ebuild,v 1.1 2008/05/16 20:49:40 zzam Exp $
+
+inherit linux-mod eutils
+
+DESCRIPTION="Use home made infrared receiver connected via USB"
+HOMEPAGE="http://usbirboy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${P}/usbirboykmod"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ if ! linux_chkconfig_present USB; then
+ die "You need a kernel with enabled USB support!"
+ fi
+
+ MODULE_NAMES="usbirboy(misc:${S})"
+ BUILD_PARAMS="INCLUDE=${KV_DIR}"
+ BUILD_TARGETS="clean all"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+ newdoc ../usbirboymcu/README README.mcu
+
+ insinto /usr/share/${PN}
+ doins ../mcubin/usbirboy.s19
+
+ # Add configuration for udev
+ dodir /etc/udev/rules.d
+ echo 'KERNEL=="usbirboy", NAME="%k", SYMLINK="lirc"' \
+ > "${D}etc/udev/rules.d/55-${PN}.rules"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ elog
+ elog "Firmware file has been installed to /usr/share/${PN}"
+ elog
+}