summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-24 16:54:56 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-24 16:54:56 +0000
commit8e6bad13bb40459892f6ff75b0dd9b1a641ddda4 (patch)
tree8e4cfe459a13e6f76c4a449d7b6b02f563d1b370 /app-misc/tmux
parentalpha/ia64/sparc stable wrt #328125 (diff)
downloadgentoo-2-8e6bad13bb40459892f6ff75b0dd9b1a641ddda4.tar.gz
gentoo-2-8e6bad13bb40459892f6ff75b0dd9b1a641ddda4.tar.bz2
gentoo-2-8e6bad13bb40459892f6ff75b0dd9b1a641ddda4.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/tmux')
-rw-r--r--app-misc/tmux/ChangeLog7
-rw-r--r--app-misc/tmux/tmux-1.1.ebuild18
-rw-r--r--app-misc/tmux/tmux-1.2.ebuild17
-rw-r--r--app-misc/tmux/tmux-1.3.ebuild45
4 files changed, 53 insertions, 34 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
index 652d2cb7d5d1..fd178f139f6b 100644
--- a/app-misc/tmux/ChangeLog
+++ b/app-misc/tmux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/tmux
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.44 2010/07/02 12:22:11 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.45 2010/07/24 16:54:56 jlec Exp $
+
+*tmux-1.3 (24 Jul 2010)
+
+ 24 Jul 2010; Justin Lecher <jlec@gentoo.org> +tmux-1.3.ebuild:
+ Version Bump, #328963
02 Jul 2010; Fabian Groffen <grobian@gentoo.org> tmux-1.2.ebuild:
Marked ~x64-macos, bug #326157
diff --git a/app-misc/tmux/tmux-1.1.ebuild b/app-misc/tmux/tmux-1.1.ebuild
index 654a1c6063ac..e2509ecbae6d 100644
--- a/app-misc/tmux/tmux-1.1.ebuild
+++ b/app-misc/tmux/tmux-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.1.ebuild,v 1.6 2010/02/03 11:36:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.1.ebuild,v 1.7 2010/07/24 16:54:56 jlec Exp $
inherit toolchain-funcs
@@ -41,19 +41,3 @@ src_install() {
doins "${FILESDIR}"/tmux.vim || die "doins ftdetect failed"
fi
}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-1.1"
- PREVIOUS_LESS_THAN_1_1=$?
-}
-
-pkg_postinst() {
- if [[ ${PREVIOUS_LESS_THAN_1_1} -eq 0 ]]; then
- ewarn "The 1.1 release replaced the internal locking mechanism by"
- ewarn "executing an external command (you might want to install"
- ewarn "app-misc/vlock and set the lock-command session option"
- ewarn "accordingly), so the set-password command, and the -U command"
- ewarn "line flag were removed, as well as -d, since tmux will now"
- ewarn "automatically detect default colours."
- fi
-}
diff --git a/app-misc/tmux/tmux-1.2.ebuild b/app-misc/tmux/tmux-1.2.ebuild
index 4eb9310a04cf..310cf1b57145 100644
--- a/app-misc/tmux/tmux-1.2.ebuild
+++ b/app-misc/tmux/tmux-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.2.ebuild,v 1.9 2010/07/02 12:22:11 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.2.ebuild,v 1.10 2010/07/24 16:54:56 jlec Exp $
inherit eutils toolchain-funcs
@@ -49,18 +49,3 @@ src_install() {
doins "${FILESDIR}"/tmux.vim || die "doins ftdetect failed"
fi
}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-1.1"
- PREVIOUS_LESS_THAN_1_1=$?
-}
-
-pkg_postinst() {
- if [[ ${PREVIOUS_LESS_THAN_1_1} -eq 0 ]]; then
- ewarn "The 1.1 release replaced the internal locking mechanism"
- ewarn "by executing a shell command (such as app-misc/vlock),"
- ewarn "thus the set-password command, and the -U command line"
- ewarn "flag were removed, as well as -d, since tmux will now"
- ewarn "automatically detect default colours."
- fi
-}
diff --git a/app-misc/tmux/tmux-1.3.ebuild b/app-misc/tmux/tmux-1.3.ebuild
new file mode 100644
index 000000000000..69cb94beb55d
--- /dev/null
+++ b/app-misc/tmux/tmux-1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.3.ebuild,v 1.1 2010/07/24 16:54:56 jlec Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="vim-syntax"
+
+DEPEND="dev-libs/libevent
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+
+src_compile() {
+ # The configure script isn't created by GNU autotools.
+ ./configure || die "configure failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin tmux || die "dobin failed"
+
+ dodoc CHANGES FAQ NOTES TODO || die "dodoc failed"
+ docinto examples
+ dodoc examples/*.conf || die "dodoc examples failed"
+
+ doman tmux.1 || die "doman failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim || die "doins syntax failed"
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim || die "doins ftdetect failed"
+ fi
+}