summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-20 02:14:30 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-20 02:14:30 +0000
commitf48ae276bc808761217f109a46abe85f464c4802 (patch)
treea13b744854236bfaa1a465070259e2ca949f8b96 /app-misc/symlinks
parentFix compiler warnings. Set RDEPEND. Respect LDFLAGS (bug #338157), CC, CFLAGS. (diff)
downloadgentoo-2-f48ae276bc808761217f109a46abe85f464c4802.tar.gz
gentoo-2-f48ae276bc808761217f109a46abe85f464c4802.tar.bz2
gentoo-2-f48ae276bc808761217f109a46abe85f464c4802.zip
Version bump.
(Portage version: 2.2_rc98/cvs/Linux i686)
Diffstat (limited to 'app-misc/symlinks')
-rw-r--r--app-misc/symlinks/ChangeLog7
-rw-r--r--app-misc/symlinks/symlinks-1.4.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/app-misc/symlinks/ChangeLog b/app-misc/symlinks/ChangeLog
index c57f647f6b64..eaee3eca9c9a 100644
--- a/app-misc/symlinks/ChangeLog
+++ b/app-misc/symlinks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/symlinks
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/ChangeLog,v 1.24 2010/05/19 12:08:12 dagger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/ChangeLog,v 1.25 2010/10/20 02:14:30 jer Exp $
+
+*symlinks-1.4 (20 Oct 2010)
+
+ 20 Oct 2010; Jeroen Roovers <jer@gentoo.org> +symlinks-1.4.ebuild:
+ Version bump.
19 May 2010; Robert Piasek <dagger@gentoo.org> symlinks-1.2-r2.ebuild:
corrected alphabetic order of keywords
diff --git a/app-misc/symlinks/symlinks-1.4.ebuild b/app-misc/symlinks/symlinks-1.4.ebuild
new file mode 100644
index 000000000000..b8a638ca3236
--- /dev/null
+++ b/app-misc/symlinks/symlinks-1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/symlinks-1.4.ebuild,v 1.1 2010/10/20 02:14:30 jer Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Symlinks scans for and fixes broken or messy symlinks"
+HOMEPAGE="http://www.ibiblio.org/pub/linux/utils/file/"
+SRC_URI="http://www.ibiblio.org/pub/linux/utils/file/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+src_compile() {
+ # could be useful if being used to repair
+ # symlinks that are preventing shared libraries from
+ # functioning.
+ use static && append-flags -static
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS} ${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin symlinks || die
+ doman symlinks.8
+ dodoc symlinks.lsm
+}