summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-12-23 16:57:35 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-12-23 16:57:35 +0000
commit9b56fef6d99c325d90c8f9b0b1fb991709da80a3 (patch)
tree33b7e50dd46fc766b5eeb18f574ad77cf704a881 /app-misc/subsurface
parentAdd patch to fix CVE-2013-6395 (#492580). (diff)
downloadgentoo-2-9b56fef6d99c325d90c8f9b0b1fb991709da80a3.tar.gz
gentoo-2-9b56fef6d99c325d90c8f9b0b1fb991709da80a3.tar.bz2
gentoo-2-9b56fef6d99c325d90c8f9b0b1fb991709da80a3.zip
Version bump to 4.0, uses Qt 4 now; fixes bug #495098, proxied commit by Martin Gysel (bearsh).
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-misc/subsurface')
-rw-r--r--app-misc/subsurface/ChangeLog9
-rw-r--r--app-misc/subsurface/subsurface-4.0.ebuild74
-rw-r--r--app-misc/subsurface/subsurface-9999.ebuild45
3 files changed, 106 insertions, 22 deletions
diff --git a/app-misc/subsurface/ChangeLog b/app-misc/subsurface/ChangeLog
index acef3013927c..6a941be5dcfb 100644
--- a/app-misc/subsurface/ChangeLog
+++ b/app-misc/subsurface/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/subsurface
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/subsurface/ChangeLog,v 1.6 2013/11/16 15:15:16 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/subsurface/ChangeLog,v 1.7 2013/12/23 16:57:35 tomwij Exp $
+
+*subsurface-4.0 (23 Dec 2013)
+
+ 23 Dec 2013; Tom Wijsman <TomWij@gentoo.org> +subsurface-4.0.ebuild,
+ subsurface-9999.ebuild:
+ Version bump to 4.0, uses Qt 4 now; fixes bug #495098, proxied commit by
+ Martin Gysel (bearsh).
*subsurface-3.1.1 (16 Nov 2013)
diff --git a/app-misc/subsurface/subsurface-4.0.ebuild b/app-misc/subsurface/subsurface-4.0.ebuild
new file mode 100644
index 000000000000..2c8112e5c3bc
--- /dev/null
+++ b/app-misc/subsurface/subsurface-4.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/subsurface/subsurface-4.0.ebuild,v 1.1 2013/12/23 16:57:35 tomwij Exp $
+
+EAPI="5"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://subsurface.hohndel.org/subsurface.git"
+ GIT_ECLASS="git-2"
+ KEYWORDS=""
+ SRC_URI=""
+ LIBDC_V="0.4.1"
+else
+ MY_P=${P/s/S}
+ SRC_URI="http://subsurface.hohndel.org/downloads/${MY_P}.tgz https://bitbucket.org/bearsh/bearshlay/downloads/${MY_P}.tgz"
+ KEYWORDS="~amd64 ~x86"
+ LIBDC_V="0.4.1"
+fi
+
+PLOCALES="bg_BG da_DK de_CH de_DE es_ES et_EE fi_FI fr_FR he it_IT nb_NO nl_NL
+ pl_PL pt_BR pt_PT ru_RU sk_SK sv_SE zh_TW"
+
+inherit eutils l10n qt4-r2 ${GIT_ECLASS}
+
+DESCRIPTION="An open source dive log program"
+HOMEPAGE="http://subsurface.hohndel.org"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug doc usb"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/libzip
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ dev-qt/qtwebkit:4
+ kde-base/marble
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/libdivecomputer-${LIBDC_V}[static-libs,usb?]
+ virtual/pkgconfig
+ doc? ( app-text/asciidoc )
+"
+
+DOCS="README"
+
+src_unpack() {
+ if [[ ${PV} = *9999* ]]; then
+ git-2_src_unpack
+ else
+ unpack ${A}
+ mv ${MY_P}* ${P} || die "failed to mv the files to ${P}"
+ fi
+}
+
+rm_trans() {
+ rm "${ED}/usr/share/${PN}/translations/${PN}_${1}.qm" || die "rm ${PN}_${1}.qm failed"
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ l10n_for_each_disabled_locale_do rm_trans
+
+ # this is not a translation but present (no need to die if not present)
+ rm "${ED}/usr/share/${PN}/translations/${PN}_source.qm"
+
+ if ! use doc; then
+ rm -R "${ED}/usr/share/${PN}/Documentation"* || die "rm doc failed"
+ fi
+}
diff --git a/app-misc/subsurface/subsurface-9999.ebuild b/app-misc/subsurface/subsurface-9999.ebuild
index 69d713373b8b..98ba505828ff 100644
--- a/app-misc/subsurface/subsurface-9999.ebuild
+++ b/app-misc/subsurface/subsurface-9999.ebuild
@@ -1,41 +1,43 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/subsurface/subsurface-9999.ebuild,v 1.3 2013/11/16 15:15:16 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/subsurface/subsurface-9999.ebuild,v 1.4 2013/12/23 16:57:35 tomwij Exp $
EAPI="5"
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://subsurface.hohndel.org/subsurface.git"
GIT_ECLASS="git-2"
+ KEYWORDS=""
+ SRC_URI=""
LIBDC_V="0.4.1"
else
- SRC_URI="http://subsurface.hohndel.org/downloads/Subsurface-${PV}.tgz -> ${P}.tar.gz"
+ MY_P=${P/s/S}
+ SRC_URI="http://subsurface.hohndel.org/downloads/${MY_P}.tgz https://bitbucket.org/bearsh/bearshlay/downloads/${MY_P}.tgz"
KEYWORDS="~amd64 ~x86"
LIBDC_V="0.4.1"
- S="${WORKDIR}/${P/s/S}"
fi
-inherit eutils qt4-r2 ${GIT_ECLASS}
+PLOCALES="bg_BG da_DK de_CH de_DE es_ES et_EE fi_FI fr_FR he it_IT nb_NO nl_NL
+ pl_PL pt_BR pt_PT ru_RU sk_SK sv_SE zh_TW"
+
+inherit eutils l10n qt4-r2 ${GIT_ECLASS}
DESCRIPTION="An open source dive log program"
HOMEPAGE="http://subsurface.hohndel.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="doc usb"
-for LINGUA in ${LINGUAS}; do
- IUSE+=" linguas_${LINGUA}"
-done
+IUSE="debug doc usb"
RDEPEND="dev-db/sqlite:3
dev-libs/glib:2
- dev-libs/libxml2:2
- dev-libs/libxslt:0
- dev-libs/libzip:0
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/libzip
dev-qt/qtcore:4
dev-qt/qtgui:4
dev-qt/qtsvg:4
dev-qt/qtwebkit:4
- kde-base/marble:4
+ kde-base/marble
"
DEPEND="${RDEPEND}
>=dev-libs/libdivecomputer-${LIBDC_V}[static-libs,usb?]
@@ -50,22 +52,23 @@ src_unpack() {
git-2_src_unpack
else
unpack ${A}
+ mv ${MY_P}* ${P} || die "failed to mv the files to ${P}"
fi
}
-src_compile() {
- emake CC="$(tc-getCC)"
-
- if use doc; then
- cd "Documentation" && emake user-manual.xhtml
- fi
+rm_trans() {
+ rm "${ED}/usr/share/${PN}/translations/${PN}_${1}.qm" || die "rm ${PN}_${1}.qm failed"
}
src_install() {
qt4-r2_src_install
- if use doc; then
- mv "${ED}/usr/share/doc/${PN}/"* "${ED}/usr/share/doc/${PF}/". || die "doc mv failed"
+ l10n_for_each_disabled_locale_do rm_trans
+
+ # this is not a translation but present (no need to die if not present)
+ rm "${ED}/usr/share/${PN}/translations/${PN}_source.qm"
+
+ if ! use doc; then
+ rm -R "${ED}/usr/share/${PN}/Documentation"* || die "rm doc failed"
fi
- rm -Rf "${ED}/usr/share/doc/${PN}"
}