summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-02-18 15:10:53 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-02-18 15:10:53 +0000
commitbdf2edd305ca46c1ef5b28be2426049a07c7c7de (patch)
tree53ad8f670e11d74f3b310feecc6a1cc3617e6071 /app-misc/sphinx
parentalpha/ia64/sparc stable wrt #209915 (diff)
downloadgentoo-2-bdf2edd305ca46c1ef5b28be2426049a07c7c7de.tar.gz
gentoo-2-bdf2edd305ca46c1ef5b28be2426049a07c7c7de.tar.bz2
gentoo-2-bdf2edd305ca46c1ef5b28be2426049a07c7c7de.zip
bump to latest version, and fix postgres support
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/ChangeLog7
-rw-r--r--app-misc/sphinx/sphinx-0.9.8_pre1112.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index 9c0171973c21..c289dfcea9d2 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/sphinx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.1 2008/01/24 00:05:47 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.2 2008/02/18 15:10:53 caleb Exp $
+
+*sphinx-0.9.8_pre1112 (18 Feb 2008)
+
+ 18 Feb 2008; Caleb Tennis <caleb@gentoo.org> +sphinx-0.9.8_pre1112.ebuild:
+ bump, and fix postgres support (bug #209929)
*sphinx-0.9.8_pre1065 (23 Jan 2008)
*sphinx-0.9.7 (23 Jan 2008)
diff --git a/app-misc/sphinx/sphinx-0.9.8_pre1112.ebuild b/app-misc/sphinx/sphinx-0.9.8_pre1112.ebuild
new file mode 100644
index 000000000000..f46dd3016bd0
--- /dev/null
+++ b/app-misc/sphinx/sphinx-0.9.8_pre1112.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.8_pre1112.ebuild,v 1.1 2008/02/18 15:10:53 caleb Exp $
+
+inherit eutils autotools
+
+MY_P=${P/_pre/-svn-r}
+
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/downloads/${MY_P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="mysql postgres debug"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+# epatch "${FILESDIR}"/${P}-fix-sandbox.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with debug) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc doc/* example.sql
+ dodir /etc/sphinx
+ insinto /etc/sphinx
+ doins sphinx.conf.dist
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+ dodir /var/run/sphinx
+}