summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-21 13:02:45 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-21 13:02:45 +0000
commit488e6b76d021a7893a4fcbd508c28eb83b53f4f0 (patch)
tree6f25c544ffbce9b2235b22cc169eedebba380d01 /app-misc/sphinx
parentstable x86, bug 327053 (diff)
downloadgentoo-2-488e6b76d021a7893a4fcbd508c28eb83b53f4f0.tar.gz
gentoo-2-488e6b76d021a7893a4fcbd508c28eb83b53f4f0.tar.bz2
gentoo-2-488e6b76d021a7893a4fcbd508c28eb83b53f4f0.zip
Version bump with many new features, including real-time indexing. See http://sphinxsearch.com/docs/current.html#rel110
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/ChangeLog8
-rw-r--r--app-misc/sphinx/sphinx-1.10_beta.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index 5054269df944..b885e05602db 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/sphinx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.28 2010/07/11 12:01:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.29 2010/07/21 13:02:45 graaff Exp $
+
+*sphinx-1.10_beta (21 Jul 2010)
+
+ 21 Jul 2010; Hans de Graaff <graaff@gentoo.org> +sphinx-1.10_beta.ebuild:
+ Version bump with many new features, including real-time indexing. See
+ http://sphinxsearch.com/docs/current.html#rel110
11 Jul 2010; Markus Meier <maekke@gentoo.org> sphinx-0.9.9.ebuild:
x86 stable, bug #322751
diff --git a/app-misc/sphinx/sphinx-1.10_beta.ebuild b/app-misc/sphinx/sphinx-1.10_beta.ebuild
new file mode 100644
index 000000000000..e5eb0bb0ebf6
--- /dev/null
+++ b/app-misc/sphinx/sphinx-1.10_beta.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-1.10_beta.ebuild,v 1.1 2010/07/21 13:02:45 graaff Exp $
+
+EAPI=2
+inherit eutils autotools
+
+MY_P=${P/_/-}
+
+# This has been added by Gentoo, to explicitly version libstemmer.
+# It is the date that http://snowball.tartarus.org/dist/libstemmer_c.tgz was
+# fetched.
+STEMMER_PV="20091122"
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/downloads/${MY_P}.tar.gz
+ stemmer? ( mirror://gentoo/libstemmer_c-${STEMMER_PV}.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug id64 mysql odbc postgres stemmer test"
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+ test? ( dev-lang/php )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if use stemmer; then
+ cd "${S}"
+ unpack libstemmer_c-${STEMMER_PV}.tgz
+ fi
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="/etc/${PN}" \
+ $(use_enable id64) \
+ $(use_with debug) \
+ $(use_with mysql) \
+ $(use_with odbc unixodbc) \
+ $(use_with postgres pgsql) \
+ $(use_with stemmer libstemmer)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_test() {
+ elog "Tests require access to a live MySQL database and may require configuration."
+ elog "You will find them in /usr/share/${PN}/test and they require dev-lang/php"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc doc/*
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+ dodir /var/run/sphinx
+
+ newinitd "${FILESDIR}"/searchd.rc searchd
+
+ if use test; then
+ insinto /usr/share/${PN}
+ doins -r test || die "install of test files failed."
+ fi
+}