summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-01 05:22:28 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-01 05:22:28 +0000
commit50863c663e233e9fb5cfc63665480cfcf5bc4df7 (patch)
tree9edb9144aee3e825c3724dea7de240f82ad3ce39 /app-misc/roadnav
parentVersion bump for bug #208412. Remove old. (diff)
downloadgentoo-2-50863c663e233e9fb5cfc63665480cfcf5bc4df7.tar.gz
gentoo-2-50863c663e233e9fb5cfc63665480cfcf5bc4df7.tar.bz2
gentoo-2-50863c663e233e9fb5cfc63665480cfcf5bc4df7.zip
Version bump for bug #208412. Remove old.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/roadnav')
-rw-r--r--app-misc/roadnav/ChangeLog10
-rw-r--r--app-misc/roadnav/roadnav-0.16.ebuild39
-rw-r--r--app-misc/roadnav/roadnav-0.19.ebuild61
3 files changed, 69 insertions, 41 deletions
diff --git a/app-misc/roadnav/ChangeLog b/app-misc/roadnav/ChangeLog
index 80f3ed1400d0..b89da3bba547 100644
--- a/app-misc/roadnav/ChangeLog
+++ b/app-misc/roadnav/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/roadnav
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/roadnav/ChangeLog,v 1.8 2008/07/31 16:52:38 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/roadnav/ChangeLog,v 1.9 2009/07/01 05:22:28 dirtyepic Exp $
+
+*roadnav-0.19 (01 Jul 2009)
+
+ 01 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> -roadnav-0.16.ebuild,
+ +roadnav-0.19.ebuild:
+ Version bump for bug #208412. Remove old.
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-misc/roadnav/roadnav-0.16.ebuild b/app-misc/roadnav/roadnav-0.16.ebuild
deleted file mode 100644
index 2d2c999070f3..000000000000
--- a/app-misc/roadnav/roadnav-0.16.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/roadnav/roadnav-0.16.ebuild,v 1.2 2007/06/16 00:57:46 dirtyepic Exp $
-
-inherit wxwidgets
-
-DESCRIPTION="Roadnav is a street map application with routing and GPS support"
-HOMEPAGE="http://roadnav.sourceforge.net"
-SRC_URI="mirror://sourceforge/roadnav/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="gps festival openstreetmap scripting"
-
-DEPEND="=x11-libs/wxGTK-2.6*
- =dev-libs/libroadnav-${PV}
- gps? ( sci-geosciences/gpsd )
- festival? ( app-accessibility/festival )"
-RDEPEND="=x11-libs/wxGTK-2.6*
- gps? ( sci-geosciences/gpsd )
- festival? ( app-accessibility/festival )"
-
-src_compile() {
- WX_GTK_VER=2.6
- need-wxwidgets gtk2
-
- econf \
- --with-wx-config=${WX_CONFIG} \
- $(use_enable gps gpsd) \
- $(use_enable openstreetmap) \
- $(use_enable scripting) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
-}
diff --git a/app-misc/roadnav/roadnav-0.19.ebuild b/app-misc/roadnav/roadnav-0.19.ebuild
new file mode 100644
index 000000000000..5223d93cbaec
--- /dev/null
+++ b/app-misc/roadnav/roadnav-0.19.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/roadnav/roadnav-0.19.ebuild,v 1.1 2009/07/01 05:22:28 dirtyepic Exp $
+
+EAPI=2
+
+inherit wxwidgets
+
+DESCRIPTION="Roadnav is a street map application with routing and GPS support"
+HOMEPAGE="http://roadnav.sourceforge.net"
+SRC_URI="mirror://sourceforge/roadnav/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="gps festival flite openstreetmap scripting"
+
+DEPEND="x11-libs/wxGTK:2.8[X]
+ ~dev-libs/libroadnav-${PV}
+ festival? ( app-accessibility/festival )
+ flite? ( app-accessibility/flite )
+ gps? ( sci-geosciences/gpsd )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ WX_GTK_VER=2.8
+ need-wxwidgets gtk2
+}
+
+src_configure() {
+ econf \
+ $(use_enable festival) \
+ $(use_enable flite) \
+ $(use_enable gps gpsd) \
+ $(use_enable openstreetmap) \
+ $(use_enable scripting) \
+ --with-wx-config=${WX_CONFIG} \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ # generic or empty
+ for f in NEWS COPYING INSTALL; do
+ rm -f "${D}"/usr/share/doc/${PN}/${f}
+ done
+
+ # --docdir is broken and hardcoded to ${PN}
+ mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${P}
+
+ insinto /usr/share/applications
+ doins "${S}"/roadnav.desktop
+}
+
+pkg_postinst() {
+ echo
+ elog "After upgrading to ${P} you will need to recompile your maps."
+ echo
+}