summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-07-19 01:56:30 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-07-19 01:56:30 +0000
commit0cb773b57969bb700a52c778c7452130b0f76eed (patch)
treefb0f87561d0a1f25bfb542eef23f2193c1995844 /app-misc/rio/rio-1.0.7.ebuild
parentNew package. Closes #9451. (diff)
downloadgentoo-2-0cb773b57969bb700a52c778c7452130b0f76eed.tar.gz
gentoo-2-0cb773b57969bb700a52c778c7452130b0f76eed.tar.bz2
gentoo-2-0cb773b57969bb700a52c778c7452130b0f76eed.zip
New package. Closes #9451.
Diffstat (limited to 'app-misc/rio/rio-1.0.7.ebuild')
-rw-r--r--app-misc/rio/rio-1.0.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/rio/rio-1.0.7.ebuild b/app-misc/rio/rio-1.0.7.ebuild
new file mode 100644
index 000000000000..1cf237a965f1
--- /dev/null
+++ b/app-misc/rio/rio-1.0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+DESCRIPTION="Utility for the Diamond Rio 300 portable MP3 player"
+SRC_URI="http://www.world.co.uk/sba/${PN}007.tgz"
+HOMEPAGE="http://www.world.co.uk/sba/rio.html"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+RDEPEND=""
+
+UNPACKDIR=rio107
+
+S=${WORKDIR}/${UNPACKDIR}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dobin rio
+ dodoc CREDITS README gpl.txt playlist.txt rio.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Warning! The /usr/bin/rio binary is installed SUID/GUID root."
+ einfo
+}