summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-20 12:23:18 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-20 12:23:18 +0000
commit2dbfa0448356ff70c628eb3e3769f409226799d7 (patch)
treef159a27345273f60a3dd498d6c53735736d9e136 /app-misc/regex-markup
parent0.8.2 works on ppc64 stable too, so stabilise. (diff)
downloadgentoo-2-2dbfa0448356ff70c628eb3e3769f409226799d7.tar.gz
gentoo-2-2dbfa0448356ff70c628eb3e3769f409226799d7.tar.bz2
gentoo-2-2dbfa0448356ff70c628eb3e3769f409226799d7.zip
app-misc/regex-markup: Fix missing declerations, #240044; bump EAPI=4; add missing configure options
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/regex-markup')
-rw-r--r--app-misc/regex-markup/ChangeLog8
-rw-r--r--app-misc/regex-markup/files/regex-markup-0.10.0-locale.patch29
-rw-r--r--app-misc/regex-markup/regex-markup-0.10.0.ebuild26
3 files changed, 53 insertions, 10 deletions
diff --git a/app-misc/regex-markup/ChangeLog b/app-misc/regex-markup/ChangeLog
index 2e1ceb5d76ef..40d2428da798 100644
--- a/app-misc/regex-markup/ChangeLog
+++ b/app-misc/regex-markup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/regex-markup
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/regex-markup/ChangeLog,v 1.14 2008/05/11 14:01:15 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/regex-markup/ChangeLog,v 1.15 2012/06/20 12:23:18 jlec Exp $
+
+ 20 Jun 2012; Justin Lecher <jlec@gentoo.org> regex-markup-0.10.0.ebuild,
+ +files/regex-markup-0.10.0-locale.patch:
+ Fix missing declerations, #240044; bump EAPI=4; add missing configure options
11 May 2008; Markus Meier <maekke@gentoo.org> -regex-markup-0.9.0.ebuild:
old
diff --git a/app-misc/regex-markup/files/regex-markup-0.10.0-locale.patch b/app-misc/regex-markup/files/regex-markup-0.10.0-locale.patch
new file mode 100644
index 000000000000..be9c74a66ceb
--- /dev/null
+++ b/app-misc/regex-markup/files/regex-markup-0.10.0-locale.patch
@@ -0,0 +1,29 @@
+ src/cacheline.c | 2 ++
+ src/remark.c | 1 +
+ 2 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/src/cacheline.c b/src/cacheline.c
+index 8c6f97b..f395c60 100644
+--- a/src/cacheline.c
++++ b/src/cacheline.c
+@@ -27,6 +27,8 @@
+ #include "getline.h" /* Gnulib/GNU Libc */
+ #include "version-etc.h" /* Gnulib */
+
++#include <locale.h>
++
+ enum {
+ HELP_OPT = 256,
+ VERSION_OPT
+diff --git a/src/remark.c b/src/remark.c
+index dcf8327..8998112 100644
+--- a/src/remark.c
++++ b/src/remark.c
+@@ -44,6 +44,7 @@
+ #include "common/intutil.h"
+ /* regex-markup */
+ #include "remark.h"
++#include <locale.h>
+
+ #define PROGRAM "remark"
+
diff --git a/app-misc/regex-markup/regex-markup-0.10.0.ebuild b/app-misc/regex-markup/regex-markup-0.10.0.ebuild
index 7d187578ad6b..0c6f5bdf4df2 100644
--- a/app-misc/regex-markup/regex-markup-0.10.0.ebuild
+++ b/app-misc/regex-markup/regex-markup-0.10.0.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/regex-markup/regex-markup-0.10.0.ebuild,v 1.3 2008/05/11 14:00:00 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/regex-markup/regex-markup-0.10.0.ebuild,v 1.4 2012/06/20 12:23:18 jlec Exp $
+
+EAPI=4
+
+inherit eutils
DESCRIPTION="A tool to color syslog files as well"
HOMEPAGE="http://www.nongnu.org/regex-markup/"
@@ -9,16 +13,22 @@ SRC_URI="http://savannah.nongnu.org/download/regex-markup/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="examples"
+IUSE="examples nls"
-DEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-locale.patch
+}
+
+src_configure() {
+ econf \
+ --enable-largefile \
+ $(use_enable nls)
+}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ default
if use examples; then
cd examples
- make -f Makefile
- cd ..
+ emake -f Makefile
fi
- dodoc AUTHORS ChangeLog NEWS README TODO
}