summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-07 20:33:14 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-07 20:33:14 +0000
commitd5c6afbc2329103f04a1015f4ba63eb24a864ac7 (patch)
tree5dde61c7de98fd4af58cf7160be35438d8f36ee7 /app-misc/realpath
parentRemove old version (diff)
downloadgentoo-2-d5c6afbc2329103f04a1015f4ba63eb24a864ac7.tar.gz
gentoo-2-d5c6afbc2329103f04a1015f4ba63eb24a864ac7.tar.bz2
gentoo-2-d5c6afbc2329103f04a1015f4ba63eb24a864ac7.zip
dropped old
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/realpath')
-rw-r--r--app-misc/realpath/ChangeLog7
-rw-r--r--app-misc/realpath/files/realpath-1.14-build.patch26
-rw-r--r--app-misc/realpath/files/realpath-1.15-nonls.patch25
-rw-r--r--app-misc/realpath/realpath-1.15-r1.ebuild61
-rw-r--r--app-misc/realpath/realpath-1.15-r3.ebuild74
5 files changed, 6 insertions, 187 deletions
diff --git a/app-misc/realpath/ChangeLog b/app-misc/realpath/ChangeLog
index 9eb0e4d2c53b..70f66cc3e350 100644
--- a/app-misc/realpath/ChangeLog
+++ b/app-misc/realpath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/realpath
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.23 2012/02/07 15:25:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.24 2012/02/07 20:33:14 jlec Exp $
+
+ 07 Feb 2012; Justin Lecher <jlec@gentoo.org>
+ -files/realpath-1.14-build.patch, -realpath-1.15-r1.ebuild,
+ -realpath-1.15-r3.ebuild, -files/realpath-1.15-nonls.patch:
+ dropped old
07 Feb 2012; Jeroen Roovers <jer@gentoo.org> realpath-1.16.ebuild:
Stable for HPPA (bug #401089).
diff --git a/app-misc/realpath/files/realpath-1.14-build.patch b/app-misc/realpath/files/realpath-1.14-build.patch
deleted file mode 100644
index baba53f36130..000000000000
--- a/app-misc/realpath/files/realpath-1.14-build.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -ur realpath-1.14.orig/common.mk realpath-1.14/common.mk
---- realpath-1.14.orig/common.mk 2009-02-22 11:58:00.000000000 +0000
-+++ realpath-1.14/common.mk 2009-04-30 16:12:29.000000000 +0000
-@@ -34,9 +34,9 @@
- applicationsdir := $(prefix)/share/applications
-
- PERL := /usr/bin/perl
--CC := gcc
--CFLAGS = -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Werror -g -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
--LDFLAGS :=
-+CC ?= gcc
-+CFLAGS += -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
-+LDFLAGS +=
- LIBS :=
-
- ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-@@ -60,9 +60,6 @@
- unexport CDPATH ENV
-
- ifdef DESTDIR
-- ifneq ($(DESTDIR),$(abspath $(DESTDIR)))
-- $(error DESTDIR "$(DESTDIR)" is not an absolute path)
-- endif
- override ddirshort := DESTDIR
- export ddirshort
- endif
diff --git a/app-misc/realpath/files/realpath-1.15-nonls.patch b/app-misc/realpath/files/realpath-1.15-nonls.patch
deleted file mode 100644
index 1a6c0d6d376c..000000000000
--- a/app-misc/realpath/files/realpath-1.15-nonls.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- realpath-1.15/src/realpath.c.orig 2010-01-12 03:20:42 +0000
-+++ realpath-1.15/src/realpath.c 2010-01-12 03:20:59 +0000
-@@ -23,9 +23,8 @@
- #include <errno.h>
- #include <getopt.h>
- #include <stdarg.h>
--#include <libintl.h>
-
--#define _(String) gettext (String)
-+#define _(String) (String)
-
- static char *stripdir(char * dir, char *buf, int maxlen);
-
-@@ -115,11 +114,6 @@
-
- myname = ( p = strchr(argv[0], '/') ) ? p+1 : argv[0];
-
-- setlocale(LC_ALL, "");
-- bindtextdomain(PACKAGE, LOCALEDIR);
-- textdomain(PACKAGE);
--
--
- parse_options(argc, argv);
-
- while (optind < argc) {
diff --git a/app-misc/realpath/realpath-1.15-r1.ebuild b/app-misc/realpath/realpath-1.15-r1.ebuild
deleted file mode 100644
index 8480b92ba279..000000000000
--- a/app-misc/realpath/realpath-1.15-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/realpath-1.15-r1.ebuild,v 1.9 2011/10/19 03:53:28 radhermit Exp $
-
-EAPI=2
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Return the canonicalized absolute pathname"
-HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
-SRC_URI="mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz
- nls? ( mirror://debian/pool/main/r/${PN}/${PN}_${PV}_i386.deb )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls"
-
-DEPEND="nls? ( sys-devel/gettext )"
-RDEPEND="!sys-freebsd/freebsd-bin"
-
-src_unpack() {
- unpack ${PN}_${PV}.tar.gz
-
- if use nls; then
- # Unpack the .deb file, in order to get the preprocessed man page
- # translations. This way we avoid a dependency on app-text/po4a.
- mkdir deb
- cd deb
- unpack ${PN}_${PV}_i386.deb
- unpack ./data.tar.gz
- gunzip -r usr/share/man || die "gunzip failed"
- else
- epatch "${FILESDIR}"/${PN}-1.15-nonls.patch
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.14-build.patch
- epatch "${FILESDIR}"/${PN}-1.14-no-po4a.patch
-}
-
-src_compile() {
- tc-export CC
- emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" \
- || die "emake failed"
-}
-
-src_install() {
- emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" \
- DESTDIR="${D}" install || die "emake install failed"
- newdoc debian/changelog ChangeLog.debian
-
- if use nls; then
- local dir
- for dir in "${WORKDIR}"/deb/usr/share/man/*; do
- [ -f "${dir}"/man1/realpath.1 ] || continue
- newman "${dir}"/man1/realpath.1 realpath.${dir##*/}.1 \
- || die "newman failed"
- done
- fi
-}
diff --git a/app-misc/realpath/realpath-1.15-r3.ebuild b/app-misc/realpath/realpath-1.15-r3.ebuild
deleted file mode 100644
index 69c637b29144..000000000000
--- a/app-misc/realpath/realpath-1.15-r3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/realpath-1.15-r3.ebuild,v 1.4 2011/12/19 17:52:53 grobian Exp $
-
-EAPI="3"
-inherit eutils toolchain-funcs flag-o-matic prefix
-
-DESCRIPTION="Return the canonicalized absolute pathname"
-HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
-SRC_URI="mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz
- nls? ( mirror://debian/pool/main/r/${PN}/${PN}_${PV}_i386.deb )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls"
-
-RDEPEND="!sys-freebsd/freebsd-bin
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- x86-interix? ( dev-libs/gnulib )
- elibc_mintlib? ( virtual/libiconv )"
-
-src_unpack() {
- unpack ${PN}_${PV}.tar.gz
-
- if use nls; then
- # Unpack the .deb file, in order to get the preprocessed man page
- # translations. This way we avoid a dependency on app-text/po4a.
- mkdir deb
- cd deb
- unpack ${PN}_${PV}_i386.deb
- unpack ./data.tar.gz
- gunzip -r usr/share/man || die "gunzip failed"
- fi
-}
-
-src_prepare() {
- use nls || epatch "${FILESDIR}"/${P}-nonls.patch
- epatch "${FILESDIR}"/${P}-build.patch
- epatch "${FILESDIR}"/${PN}-1.14-no-po4a.patch
- epatch "${FILESDIR}"/${P}-prefix.patch
- eprefixify common.mk
-}
-
-src_compile() {
- tc-export CC
- use !elibc_glibc && append-libs -lintl
- [[ ${CHOST} == *-mint* ]] && append-libs "-liconv"
- if [[ ${CHOST} == *-irix* || ${CHOST} == *-interix[35]* ]] ; then
- append-flags -I"${EPREFIX}"/usr/$(get_libdir)/gnulib/include
- append-ldflags -L"${EPREFIX}"/usr/$(get_libdir)/gnulib/$(get_libdir)
- append-libs -lgnu
- fi
-
- emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" \
- || die "emake failed"
-}
-
-src_install() {
- emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" \
- DESTDIR="${D}" install || die "emake install failed"
- newdoc debian/changelog ChangeLog.debian || die
-
- if use nls; then
- local dir
- for dir in "${WORKDIR}"/deb/usr/share/man/*; do
- [ -f "${dir}"/man1/realpath.1 ] || continue
- newman "${dir}"/man1/realpath.1 realpath.${dir##*/}.1 \
- || die "newman failed"
- done
- fi
-}