summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-28 15:02:15 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-28 15:02:15 +0000
commit736d9fef54c2dea7543fed0506e391a49eeb31f1 (patch)
tree9936f69fcfff538c573b6fbdb0a9d4fd8aaabef5 /app-misc/realpath
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-736d9fef54c2dea7543fed0506e391a49eeb31f1.tar.gz
gentoo-2-736d9fef54c2dea7543fed0506e391a49eeb31f1.tar.bz2
gentoo-2-736d9fef54c2dea7543fed0506e391a49eeb31f1.zip
Resepct optimization level in *FLAGS, #338407
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/realpath')
-rw-r--r--app-misc/realpath/ChangeLog8
-rw-r--r--app-misc/realpath/files/realpath-1.15-build.patch34
-rw-r--r--app-misc/realpath/realpath-1.15-r3.ebuild74
3 files changed, 115 insertions, 1 deletions
diff --git a/app-misc/realpath/ChangeLog b/app-misc/realpath/ChangeLog
index 447ed66ec0a0..aa5d18e1dce8 100644
--- a/app-misc/realpath/ChangeLog
+++ b/app-misc/realpath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/realpath
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.10 2010/07/18 13:14:54 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.11 2010/11/28 15:02:15 jlec Exp $
+
+*realpath-1.15-r3 (28 Nov 2010)
+
+ 28 Nov 2010; Justin Lecher <jlec@gentoo.org> +realpath-1.15-r3.ebuild,
+ +files/realpath-1.15-build.patch:
+ Resepct optimization level in *FLAGS, #338407
18 Jul 2010; <nixnut@gentoo.org> realpath-1.15-r1.ebuild:
ppc stable #322919
diff --git a/app-misc/realpath/files/realpath-1.15-build.patch b/app-misc/realpath/files/realpath-1.15-build.patch
new file mode 100644
index 000000000000..eb3defaea1b6
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.15-build.patch
@@ -0,0 +1,34 @@
+diff --git a/common.mk b/common.mk
+index 18f539c..142f7e6 100644
+--- a/common.mk
++++ b/common.mk
+@@ -34,16 +34,11 @@ webcgidir := $(prefix)/lib/cgi-bin
+ applicationsdir := $(prefix)/share/applications
+
+ PERL := /usr/bin/perl
+-CC := gcc
+-CFLAGS = -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Werror -g -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
+-LDFLAGS :=
++CC ?= gcc
++CFLAGS += -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
++LDFLAGS +=
+ LIBS :=
+
+-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -O0
+-else
+- CFLAGS += -O2
+-endif
+
+
+ # determine our version number
+@@ -60,9 +55,6 @@ ifndef VERSION
+ unexport CDPATH ENV
+
+ ifdef DESTDIR
+- ifneq ($(DESTDIR),$(abspath $(DESTDIR)))
+- $(error DESTDIR "$(DESTDIR)" is not an absolute path)
+- endif
+ override ddirshort := DESTDIR
+ export ddirshort
+ endif
diff --git a/app-misc/realpath/realpath-1.15-r3.ebuild b/app-misc/realpath/realpath-1.15-r3.ebuild
new file mode 100644
index 000000000000..75c2a9ccc861
--- /dev/null
+++ b/app-misc/realpath/realpath-1.15-r3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/realpath-1.15-r3.ebuild,v 1.1 2010/11/28 15:02:15 jlec Exp $
+
+EAPI="3"
+inherit eutils toolchain-funcs flag-o-matic prefix
+
+DESCRIPTION="Return the canonicalized absolute pathname"
+HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
+SRC_URI="mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz
+ nls? ( mirror://debian/pool/main/r/${PN}/${PN}_${PV}_i386.deb )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="!sys-freebsd/freebsd-bin"
+DEPEND="${RDEPEND}
+ elibc_IRIX? ( dev-libs/gnulib )
+ x86-interix? ( dev-libs/gnulib )
+ virtual/libintl
+ elibc_mintlib? ( virtual/libiconv )"
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+
+ if use nls; then
+ # Unpack the .deb file, in order to get the preprocessed man page
+ # translations. This way we avoid a dependency on app-text/po4a.
+ mkdir deb
+ cd deb
+ unpack ${PN}_${PV}_i386.deb
+ unpack ./data.tar.gz
+ gunzip -r usr/share/man || die "gunzip failed"
+ fi
+}
+
+src_prepare() {
+ use nls || epatch "${FILESDIR}"/${P}-nonls.patch
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${PN}-1.14-no-po4a.patch
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ eprefixify common.mk
+}
+
+src_compile() {
+ tc-export CC
+ use !elibc_glibc && append-libs -lintl
+ [[ ${CHOST} == *-mint* ]] && append-libs "-liconv"
+ if [[ ${CHOST} == *-irix* || ${CHOST} == *-interix[35]* ]] ; then
+ append-flags -I"${EPREFIX}"/usr/$(get_libdir)/gnulib/include
+ append-ldflags -L"${EPREFIX}"/usr/$(get_libdir)/gnulib/$(get_libdir)
+ append-libs -lgnu
+ fi
+
+ emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" \
+ DESTDIR="${D}" install || die "emake install failed"
+ newdoc debian/changelog ChangeLog.debian || die
+
+ if use nls; then
+ local dir
+ for dir in "${WORKDIR}"/deb/usr/share/man/*; do
+ [ -f "${dir}"/man1/realpath.1 ] || continue
+ newman "${dir}"/man1/realpath.1 realpath.${dir##*/}.1 \
+ || die "newman failed"
+ done
+ fi
+}