summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-10-17 19:52:56 +0000
committerJustin Lecher <jlec@gentoo.org>2011-10-17 19:52:56 +0000
commit2cce1fe15923bf40726edd83f667b55aefa0633f (patch)
tree238f50928119b42051ec418c935e5a2a90014ea3 /app-misc/realpath
parentversion bump (bug #386927) (diff)
downloadgentoo-2-2cce1fe15923bf40726edd83f667b55aefa0633f.tar.gz
gentoo-2-2cce1fe15923bf40726edd83f667b55aefa0633f.tar.bz2
gentoo-2-2cce1fe15923bf40726edd83f667b55aefa0633f.zip
Add missing nls patch
(Portage version: 2.2.0_alpha68/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/realpath')
-rw-r--r--app-misc/realpath/ChangeLog6
-rw-r--r--app-misc/realpath/files/realpath-1.16-nonls.patch29
-rw-r--r--app-misc/realpath/realpath-1.16.ebuild5
3 files changed, 37 insertions, 3 deletions
diff --git a/app-misc/realpath/ChangeLog b/app-misc/realpath/ChangeLog
index 7d8430ba34b2..2f361403776b 100644
--- a/app-misc/realpath/ChangeLog
+++ b/app-misc/realpath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/realpath
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.16 2011/10/17 14:54:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.17 2011/10/17 19:52:56 jlec Exp $
+
+ 17 Oct 2011; Justin Lecher <jlec@gentoo.org> +files/realpath-1.16-nonls.patch,
+ metadata.xml, realpath-1.16.ebuild:
+ Add missing nls patch
*realpath-1.16 (17 Oct 2011)
diff --git a/app-misc/realpath/files/realpath-1.16-nonls.patch b/app-misc/realpath/files/realpath-1.16-nonls.patch
new file mode 100644
index 000000000000..d758d03ff89b
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.16-nonls.patch
@@ -0,0 +1,29 @@
+ src/realpath.c | 6 +-----
+ 1 files changed, 1 insertions(+), 5 deletions(-)
+
+diff --git a/src/realpath.c b/src/realpath.c
+index 76fc909..e2cf86f 100644
+--- a/src/realpath.c
++++ b/src/realpath.c
+@@ -23,10 +23,9 @@
+ #include <errno.h>
+ #include <getopt.h>
+ #include <stdarg.h>
+-#include <libintl.h>
+ #include <locale.h>
+
+-#define _(String) gettext (String)
++#define _(String) (String)
+
+ static char *stripdir(char * dir, char *buf, int maxlen);
+
+@@ -116,9 +115,6 @@ int main(int argc, char **argv) {
+
+ myname = ( p = strchr(argv[0], '/') ) ? p+1 : argv[0];
+
+- setlocale(LC_ALL, "");
+- bindtextdomain(PACKAGE, LOCALEDIR);
+- textdomain(PACKAGE);
+
+
+ parse_options(argc, argv);
diff --git a/app-misc/realpath/realpath-1.16.ebuild b/app-misc/realpath/realpath-1.16.ebuild
index d7e65815d98a..7acb7d609f72 100644
--- a/app-misc/realpath/realpath-1.16.ebuild
+++ b/app-misc/realpath/realpath-1.16.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/realpath-1.16.ebuild,v 1.1 2011/10/17 14:54:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/realpath-1.16.ebuild,v 1.2 2011/10/17 19:52:56 jlec Exp $
EAPI="3"
inherit eutils toolchain-funcs flag-o-matic prefix
DESCRIPTION="Return the canonicalized absolute pathname"
HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
-SRC_URI="mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz
+SRC_URI="
+ mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz
nls? ( mirror://debian/pool/main/r/${PN}/${PN}_${PV}_i386.deb )"
LICENSE="GPL-2"