summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2006-12-13 00:03:19 +0000
committerNed Ludd <solar@gentoo.org>2006-12-13 00:03:19 +0000
commitf9aa91839ac5c672752391876d37db19059a4e3d (patch)
tree489ef00079c10d92e3f3e69891bc16cd560c6a56 /app-misc/pax-utils
parentUpdate Manifest to reflect upstream's wonderful method of fixing bugs without... (diff)
downloadgentoo-2-f9aa91839ac5c672752391876d37db19059a4e3d.tar.gz
gentoo-2-f9aa91839ac5c672752391876d37db19059a4e3d.tar.bz2
gentoo-2-f9aa91839ac5c672752391876d37db19059a4e3d.zip
Removed *macho* from release files.
Lots of minor whitespace and style updates. List known pkg maintainers for other distributions that carry the pax-utils. scanelf: Improved return values of many functions to be ints vs voids. Support added for displaying em_machine via %a format flag. Make scanelf_file_bind() not output anything if quiet mode and the ELF is static or not setuid. pspax: Support added for -u,--user <user/uid> Support added for -g,--group <group/gid> (Portage version: 2.1.2_pre1)
Diffstat (limited to 'app-misc/pax-utils')
-rw-r--r--app-misc/pax-utils/ChangeLog17
-rw-r--r--app-misc/pax-utils/files/digest-pax-utils-0.1.153
-rw-r--r--app-misc/pax-utils/pax-utils-0.1.15.ebuild26
3 files changed, 45 insertions, 1 deletions
diff --git a/app-misc/pax-utils/ChangeLog b/app-misc/pax-utils/ChangeLog
index 98f45007747f..29c1f2e313fb 100644
--- a/app-misc/pax-utils/ChangeLog
+++ b/app-misc/pax-utils/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for app-misc/pax-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.79 2006/10/17 07:03:58 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.80 2006/12/13 00:03:19 solar Exp $
+
+*pax-utils-0.1.15 (13 Dec 2006)
+
+ 13 Dec 2006; <solar@gentoo.org> +pax-utils-0.1.15.ebuild:
+ Removed *macho* from release files. Lots of minor whitespace and style
+ updates. List known pkg maintainers for other distributions that carry the
+ pax-utils.
+
+ scanelf: Improved return values of many functions to be ints vs voids.
+ Support added for displaying em_machine via %a format flag. Make
+ scanelf_file_bind() not output anything if quiet mode and the ELF is static
+ or not setuid.
+
+ pspax: Support added for -u,--user <user/uid> Support added for -g,--group
+ <group/gid>
17 Oct 2006; Roy Marples <uberlord@gentoo.org> pax-utils-0.1.14.ebuild:
Added ~sparc-fbsd keyword.
diff --git a/app-misc/pax-utils/files/digest-pax-utils-0.1.15 b/app-misc/pax-utils/files/digest-pax-utils-0.1.15
new file mode 100644
index 000000000000..8c719053d743
--- /dev/null
+++ b/app-misc/pax-utils/files/digest-pax-utils-0.1.15
@@ -0,0 +1,3 @@
+MD5 acf0e368cb33bc2f6a335ba3f5e4fd2b pax-utils-0.1.15.tar.bz2 53850
+RMD160 f0744724b286be2b6d9a37980504d3b4a7dcb695 pax-utils-0.1.15.tar.bz2 53850
+SHA256 e20f47cd64f2749cfee5b313b7a0439d8ad5df921c66a1b8384140e5e76fc055 pax-utils-0.1.15.tar.bz2 53850
diff --git a/app-misc/pax-utils/pax-utils-0.1.15.ebuild b/app-misc/pax-utils/pax-utils-0.1.15.ebuild
new file mode 100644
index 000000000000..ab78198eb22a
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.1.15.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.1.15.ebuild,v 1.1 2006/12/13 00:03:19 solar Exp $
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="Various ELF related utils for ELF32, ELF64 binaries useful tools that can check files for security relevant properties"
+HOMEPAGE="http://hardened.gentoo.org/pax-utils.xml"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="caps"
+
+DEPEND="caps? ( sys-libs/libcap )"
+
+src_compile() {
+ emake CC=$(tc-getCC) USE_CAP=$(use caps && echo yes) || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+}