summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-13 17:52:43 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-13 17:52:43 +0000
commitc8088c5f21d5e862ae6de8e1102f10a765cfe17f (patch)
tree866446a32adda5ca0039a9d55eefeceefec4344c /app-misc/nut
parentstable ppc, bug 341295 (diff)
downloadgentoo-2-c8088c5f21d5e862ae6de8e1102f10a765cfe17f.tar.gz
gentoo-2-c8088c5f21d5e862ae6de8e1102f10a765cfe17f.tar.bz2
gentoo-2-c8088c5f21d5e862ae6de8e1102f10a765cfe17f.zip
Version Bump
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/nut')
-rw-r--r--app-misc/nut/ChangeLog9
-rw-r--r--app-misc/nut/files/nut-16.5-build-fixes.patch23
-rw-r--r--app-misc/nut/nut-10.15.ebuild15
-rw-r--r--app-misc/nut/nut-12.2.ebuild29
-rw-r--r--app-misc/nut/nut-12.7.ebuild36
-rw-r--r--app-misc/nut/nut-14.1.ebuild12
-rw-r--r--app-misc/nut/nut-16.5.ebuild37
7 files changed, 79 insertions, 82 deletions
diff --git a/app-misc/nut/ChangeLog b/app-misc/nut/ChangeLog
index 7e809c7f3fa5..df929f4293a1 100644
--- a/app-misc/nut/ChangeLog
+++ b/app-misc/nut/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/nut
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.13 2011/01/13 14:35:12 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.14 2011/01/13 17:52:43 jlec Exp $
+
+*nut-16.5 (13 Jan 2011)
+
+ 13 Jan 2011; Justin Lecher <jlec@gentoo.org> nut-10.15.ebuild,
+ -nut-12.2.ebuild, -nut-12.7.ebuild, nut-14.1.ebuild, +nut-16.5.ebuild,
+ +files/nut-16.5-build-fixes.patch:
+ Version Bump
13 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> nut-14.1.ebuild:
ppc stable wrt #351547
diff --git a/app-misc/nut/files/nut-16.5-build-fixes.patch b/app-misc/nut/files/nut-16.5-build-fixes.patch
new file mode 100644
index 000000000000..c2b918da0c37
--- /dev/null
+++ b/app-misc/nut/files/nut-16.5-build-fixes.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile b/Makefile
+index 1b8b705..dc2a08b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,16 +3,14 @@ FOODDIR := \"/usr/local/lib/nut\"
+ EXECUTABLE := nut
+ LIBS := -lm
+
+-CFLAGS := -Wall -O3 -fno-inline -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR) -ansi -pedantic
+-
+-CXXFLAGS := $(CFLAGS)
++CFLAGS += -Wall -fno-inline -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR) -ansi -pedantic
+
+ SOURCE := $(wildcard *.c) $(wildcard *.cc)
+ OBJS := $(patsubst %.c,%.o,$(patsubst %.cc,%.o,$(SOURCE)))
+ CPPFLAGS +=
+
+ nut: $(OBJS)
+- $(CC) -s -o $(EXECUTABLE) $(OBJS) $(LIBS)
++ $(CC) $(LDFLAGS) -o $(EXECUTABLE) $(OBJS) $(LIBS)
+
+
+ deps:
diff --git a/app-misc/nut/nut-10.15.ebuild b/app-misc/nut/nut-10.15.ebuild
index d4ea1aee3e0b..bf27822dee6a 100644
--- a/app-misc/nut/nut-10.15.ebuild
+++ b/app-misc/nut/nut-10.15.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-10.15.ebuild,v 1.4 2007/09/09 12:41:20 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-10.15.ebuild,v 1.5 2011/01/13 17:52:43 jlec Exp $
inherit flag-o-matic
-DESCRIPTION="record what you eat and analyze your nutrient levels"
+DESCRIPTION="Record what you eat and analyze your nutrient levels"
HOMEPAGE="http://nut.sourceforge.net/"
SRC_URI="http://www.lafn.org/~av832/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc x86"
IUSE=""
-DEPEND=""
src_compile() {
append-flags '-DNUTDIR=\".nutdb\" -DFOODDIR=\"/usr/share/nut\"'
@@ -19,9 +19,8 @@ src_compile() {
}
src_install() {
- dodir /usr/share/nut
insinto /usr/share/nut
- doins raw.data/*
- dobin nut
- doman nut.1
+ doins raw.data/* || die
+ dobin nut || die
+ doman nut.1 || die
}
diff --git a/app-misc/nut/nut-12.2.ebuild b/app-misc/nut/nut-12.2.ebuild
deleted file mode 100644
index fb8946c8e720..000000000000
--- a/app-misc/nut/nut-12.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-12.2.ebuild,v 1.2 2007/09/09 12:41:20 coldwind Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="Record what you eat and analyze your nutrient levels"
-HOMEPAGE="http://nut.sourceforge.net/"
-SRC_URI="http://www.lafn.org/~av832/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=""
-
-src_compile() {
- append-flags '-DNUTDIR=\".nutdb\" -DFOODDIR=\"/usr/share/nut\"'
- emake CFLAGS="${CFLAGS}" || die "emake failed"
-}
-
-src_install() {
- dodir /usr/share/nut
- insinto /usr/share/nut
- doins raw.data/*
- dobin nut
- doman nut.1
-}
diff --git a/app-misc/nut/nut-12.7.ebuild b/app-misc/nut/nut-12.7.ebuild
deleted file mode 100644
index e0a98731af32..000000000000
--- a/app-misc/nut/nut-12.7.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-12.7.ebuild,v 1.2 2008/05/11 20:53:32 solar Exp $
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Record what you eat and analyze your nutrient levels"
-HOMEPAGE="http://nut.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~arm ~alpha ~amd64 ~ppc ~x86 ~amd64"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e s/'gcc '/'$(CC) '/ Makefile || ewarn "It might of been fixed"
-}
-
-src_compile() {
- append-flags '-DNUTDIR=\".nutdb\" -DFOODDIR=\"/usr/share/nut\"'
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
-}
-
-src_install() {
- dodir /usr/share/nut
- insinto /usr/share/nut
- doins raw.data/*
- dobin nut
- doman nut.1
-}
diff --git a/app-misc/nut/nut-14.1.ebuild b/app-misc/nut/nut-14.1.ebuild
index 7d47d0efc7f7..fd657b406cda 100644
--- a/app-misc/nut/nut-14.1.ebuild
+++ b/app-misc/nut/nut-14.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-14.1.ebuild,v 1.3 2011/01/13 14:35:12 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-14.1.ebuild,v 1.4 2011/01/13 17:52:43 jlec Exp $
EAPI=2
@@ -15,9 +15,6 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~amd64 ~arm ppc ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
-
src_prepare() {
epatch "${FILESDIR}"/${P}-build-fixes.patch
}
@@ -28,9 +25,8 @@ src_compile() {
}
src_install() {
- dodir /usr/share/nut
insinto /usr/share/nut
- doins raw.data/*
- dobin nut
- doman nut.1
+ doins raw.data/* || die
+ dobin nut || die
+ doman nut.1 || die
}
diff --git a/app-misc/nut/nut-16.5.ebuild b/app-misc/nut/nut-16.5.ebuild
new file mode 100644
index 000000000000..da9d26f78e79
--- /dev/null
+++ b/app-misc/nut/nut-16.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-16.5.ebuild,v 1.1 2011/01/13 17:52:43 jlec Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Record what you eat and analyze your nutrient levels"
+HOMEPAGE="http://nut.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~alpha ~amd64 ~ppc ~x86 ~amd64"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build-fixes.patch
+ tc-export CC
+}
+
+src_compile() {
+ emake || die
+# need fltk-1.3
+# if use X; then
+# cd fltk
+# emake || die
+# fi
+}
+
+src_install() {
+ insinto /usr/share/nut
+ doins raw.data/* || die
+ dobin nut || die
+ doman nut.1 || die
+}