summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-08-06 10:11:04 +0000
committerAlex Alexander <wired@gentoo.org>2010-08-06 10:11:04 +0000
commit4fc8555c76a5c7f5715da8d472bbaf4520be1375 (patch)
tree88556b82c11df94dc79ce1f1b1d0c7fea470704d /app-misc/mc
parentversion bump (diff)
downloadgentoo-2-4fc8555c76a5c7f5715da8d472bbaf4520be1375.tar.gz
gentoo-2-4fc8555c76a5c7f5715da8d472bbaf4520be1375.tar.bz2
gentoo-2-4fc8555c76a5c7f5715da8d472bbaf4520be1375.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/ChangeLog7
-rw-r--r--app-misc/mc/mc-4.7.0.8.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 72c82059ac47..e27085adb940 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/mc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.203 2010/07/19 18:43:08 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.204 2010/08/06 10:11:04 wired Exp $
+
+*mc-4.7.0.8 (06 Aug 2010)
+
+ 06 Aug 2010; Alex Alexander <wired@gentoo.org> +mc-4.7.0.8.ebuild:
+ version bump
*mc-4.7.3-r2 (19 Jul 2010)
diff --git a/app-misc/mc/mc-4.7.0.8.ebuild b/app-misc/mc/mc-4.7.0.8.ebuild
new file mode 100644
index 000000000000..68cbf97e4303
--- /dev/null
+++ b/app-misc/mc/mc-4.7.0.8.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.7.0.8.ebuild,v 1.1 2010/08/06 10:11:04 wired Exp $
+
+EAPI=3
+
+inherit base
+
+MY_P=${P/_/-}
+
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="http://www.midnight-commander.org"
+SRC_URI="http://www.midnight-commander.org/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+edit gpm nls samba slang X"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs )
+ samba? ( net-fs/samba )
+ slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses )
+ X? ( x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myscreen=ncurses
+ use slang && myscreen=slang
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ --enable-vfs \
+ $(use_enable kernel_linux vfs-undelfs) \
+ --enable-charset \
+ $(use_with X x) \
+ $(use_with samba) \
+ --with-configdir="${EPREFIX}"/etc/samba \
+ --with-codepagedir="${EPREFIX}"/var/lib/samba/codepages \
+ $(use_with gpm gpm-mouse) \
+ --with-screen=${myscreen} \
+ $(use_with edit)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}