summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSascha Schwabbauer <cybersystem@gentoo.org>2002-08-21 10:46:20 +0000
committerSascha Schwabbauer <cybersystem@gentoo.org>2002-08-21 10:46:20 +0000
commit88ff35784a967817e2358e85e6b16545ccd29607 (patch)
tree3259ea50dc16694ec1e3d2e5ef7baca355a8886d /app-misc/lxsplit/lxsplit-0.1.1.ebuild
parentremove unnecessary SLOT='0', the eclases do that (diff)
downloadgentoo-2-88ff35784a967817e2358e85e6b16545ccd29607.tar.gz
gentoo-2-88ff35784a967817e2358e85e6b16545ccd29607.tar.bz2
gentoo-2-88ff35784a967817e2358e85e6b16545ccd29607.zip
added new ebuild, lxsplit
Diffstat (limited to 'app-misc/lxsplit/lxsplit-0.1.1.ebuild')
-rw-r--r--app-misc/lxsplit/lxsplit-0.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/lxsplit/lxsplit-0.1.1.ebuild b/app-misc/lxsplit/lxsplit-0.1.1.ebuild
new file mode 100644
index 000000000000..011709d21ecf
--- /dev/null
+++ b/app-misc/lxsplit/lxsplit-0.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lxsplit/lxsplit-0.1.1.ebuild,v 1.1 2002/08/21 10:46:20 cybersystem Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Command-line file splitter/joiner for Linux."
+SRC_URI="http://www.freebyte.com/download/lxsplit.tar.gz"
+HOMEPAGE="http://remenic.2y.net/lxsplit/"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_compile() {
+ sed "s/^\(CFLAGS[[:space:]]=[[:space:]]\)\(.*\)$/\1${CFLAGS}/" Makefile > Makefile.new
+ mv --force Makefile.new Makefile
+ emake || die
+}
+
+src_install () {
+
+ dobin lxsplit
+
+ # Install documentation.
+ dodoc ChangeLog README
+}