summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-01-07 19:39:40 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-01-07 19:39:40 +0000
commit6bb02883fcaedeae3ee534d57c2966599879c202 (patch)
tree8d7a858a643e80ac5cde6bb40516b28cdd3bf3df /app-misc/lirc
parentUSE -music now works, #160509 thanks to Richard Freeman. (diff)
downloadgentoo-2-6bb02883fcaedeae3ee534d57c2966599879c202.tar.gz
gentoo-2-6bb02883fcaedeae3ee534d57c2966599879c202.tar.bz2
gentoo-2-6bb02883fcaedeae3ee534d57c2966599879c202.zip
Version bumped.
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'app-misc/lirc')
-rw-r--r--app-misc/lirc/ChangeLog7
-rw-r--r--app-misc/lirc/files/digest-lirc-0.8.13
-rw-r--r--app-misc/lirc/lirc-0.8.1.ebuild300
3 files changed, 309 insertions, 1 deletions
diff --git a/app-misc/lirc/ChangeLog b/app-misc/lirc/ChangeLog
index 64795253c1d6..0b38fac218df 100644
--- a/app-misc/lirc/ChangeLog
+++ b/app-misc/lirc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/lirc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.127 2007/01/06 16:15:57 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.128 2007/01/07 19:39:40 zzam Exp $
+
+*lirc-0.8.1 (07 Jan 2007)
+
+ 07 Jan 2007; Matthias Schwarzott <zzam@gentoo.org> +lirc-0.8.1.ebuild:
+ Version bumped.
06 Jan 2007; Bryan Østergaard <kloeri@gentoo.org> lirc-0.8.0-r8.ebuild,
lirc-0.8.1_pre5.ebuild:
diff --git a/app-misc/lirc/files/digest-lirc-0.8.1 b/app-misc/lirc/files/digest-lirc-0.8.1
new file mode 100644
index 000000000000..66f85ad69377
--- /dev/null
+++ b/app-misc/lirc/files/digest-lirc-0.8.1
@@ -0,0 +1,3 @@
+MD5 3a42083fc6c54797351e52c77537c586 lirc-0.8.1.tar.bz2 604524
+RMD160 effba27a6aaa4a39d206d9d9e7cccc72edcd5fb5 lirc-0.8.1.tar.bz2 604524
+SHA256 86ea19a768e8b8a9ac19daf403ac8b017f7a20d2764e6e78267099094e4f9a1b lirc-0.8.1.tar.bz2 604524
diff --git a/app-misc/lirc/lirc-0.8.1.ebuild b/app-misc/lirc/lirc-0.8.1.ebuild
new file mode 100644
index 000000000000..8eeb562ec6ad
--- /dev/null
+++ b/app-misc/lirc/lirc-0.8.1.ebuild
@@ -0,0 +1,300 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.1.ebuild,v 1.1 2007/01/07 19:39:40 zzam Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit eutils linux-mod flag-o-matic autotools
+
+DESCRIPTION="LIRC is a package that allows you to decode and send infra-red \
+ signals of many (but not all) commonly used remote controls."
+HOMEPAGE="http://www.lirc.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="debug doc X hardware-carrier transmitter"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+SRC_URI="mirror://sourceforge/lirc/${P/_pre/pre}.tar.bz2"
+
+S=${WORKDIR}/${P/_pre/pre}
+
+
+IUSE_LIRC_DEVICES_DIRECT="
+ all userspace act200l act220l
+ adaptec alsa_usb animax atilibusb
+ atiusb audio audio_alsa avermedia avermedia_vdomate
+ avermedia98 bestbuy bestbuy2 breakoutbox
+ bte bw6130 caraca chronos cmdir com1 com2 com3 com4
+ cph06x creative creative_infracd
+ devinput digimatrix dsp dvico ea65
+ exaudio flyvideo gvbctv5pci hauppauge
+ hauppauge_dvb hercules_smarttv_stereo
+ igorplugusb imon imon_pad imon_rsc
+ irdeo irdeo_remote irman irreal it87
+ knc_one kworld leadtek_0007 leadtek_0010
+ leadtek_pvr2000 livedrive_midi
+ livedrive_seq logitech lpt1 lpt2 mceusb
+ mceusb2 mediafocusI mouseremote
+ mouseremote_ps2 mp3anywhere nslu2
+ packard_bell parallel pcmak pcmak_usb
+ pctv pixelview_bt878 pixelview_pak
+ pixelview_pro provideo realmagic
+ remotemaster sa1100 sasem serial
+ silitek sir slinke streamzap tekram
+ tekram_bt829 tira tvbox udp uirt2
+ uirt2_raw"
+
+IUSE_LIRC_DEVICES_SPECIAL="
+ imon_pad2keys serial_igor_cesko
+ remote_wonder_plus xboxusb usbirboy inputlirc"
+
+IUSE_LIRC_DEVICES="${IUSE_LIRC_DEVICES_DIRECT} ${IUSE_LIRC_DEVICES_SPECIAL}"
+
+
+
+RDEPEND="virtual/libc
+ sys-apps/coreutils
+ X? ( || ( ( x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE )
+ virtual/x11 ) )
+ lirc_devices_alsa_usb? ( media-libs/alsa-lib )
+ lirc_devices_audio? ( media-libs/portaudio )
+ lirc_devices_irman? ( media-libs/libirman )"
+
+
+#device-driver which use libusb
+LIBUSB_USED_BY_DEV="
+ all atiusb sasem igorplugusb imon imon_pad imon_pad2keys
+ imon_rsc streamzap mceusb mceusb2 xboxusb"
+
+for dev in ${LIBUSB_USED_BY_DEV}; do
+ RDEPEND="${RDEPEND} lirc_devices_${dev}? ( dev-libs/libusb )"
+done
+
+# adding only compile-time depends
+DEPEND="${RDEPEND}
+ virtual/linux-sources"
+
+
+# adding only run-time depends
+RDEPEND="${RDEPEND}
+ lirc_devices_usbirboy? ( app-misc/usbirboy )
+ lirc_devices_inputlirc? ( app-misc/inputlircd )"
+
+
+
+# add all devices to IUSE
+for dev in ${IUSE_LIRC_DEVICES}; do
+ IUSE="${IUSE} lirc_devices_${dev}"
+done
+
+
+add_device() {
+ : $(( lirc_device_count++ ))
+
+ if [[ ${lirc_device_count} -eq 2 ]]; then
+ ewarn
+ ewarn "When selecting multiple devices for lirc to be supported,"
+ ewarn "it can not be garanteed that the drivers play nice together."
+ ewarn
+ ewarn "If this is not intended, then abort emerge now with Ctrl-C,"
+ ewarn "Set LIRC_DEVICES and restart emerge."
+ ewarn
+ epause
+ fi
+
+
+ local dev="${1}"
+ local desc="device ${dev}"
+ if [[ -n "${2}" ]]; then
+ desc="${2}"
+ fi
+
+ elog "Compiling support for ${desc}"
+ MY_OPTS="${MY_OPTS} --with-driver=${dev}"
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ # set default configure options
+ MY_OPTS=""
+ lirc_driver_count=0
+
+ LIRC_DRIVER_DEVICE="/dev/lirc/0"
+
+ local dev
+
+ if use lirc_devices_all; then
+ # compile in drivers for a lot of devices
+ add_device all "a lot of devices"
+ else
+ # compile in only requested drivers
+ for dev in ${IUSE_LIRC_DEVICES_DIRECT}; do
+ if use lirc_devices_${dev}; then
+ add_device ${dev}
+ fi
+ done
+
+ if use lirc_devices_remote_wonder_plus; then
+ add_device atiusb "device Remote Wonder Plus (atiusb-based)"
+ fi
+
+ if use lirc_devices_serial_igor_cesko; then
+ add_device serial "serial with Igor Cesko design"
+ MY_OPTS="${MY_OPTS} --with-igor"
+ fi
+
+ if use lirc_devices_imon_pad2keys; then
+ add_device imon_pad "device imon_pad (with converting pad input to keyspresses)"
+ fi
+
+ if use lirc_devices_xboxusb; then
+ add_device atiusb "device xboxusb"
+ fi
+
+ if use lirc_devices_usbirboy; then
+ add_device userspace "device usbirboy"
+ LIRC_DRIVER_DEVICE="/dev/usbirboy"
+ fi
+
+ if [[ "${MY_OPTS}" == "" ]]; then
+ if [[ "${PROFILE_ARCH}" == "xbox" ]]; then
+ # on xbox: use special driver
+ add_device atiusb "device xboxusb"
+ else
+ # no driver requested
+ elog
+ elog "Compiling only the lirc-applications, but no drivers."
+ elog "Enable drivers with LIRC_DEVICES if you need them."
+ MY_OPTS="--with-driver=userspace"
+ fi
+ fi
+ fi
+
+ use hardware-carrier && MY_OPTS="${MY_OPTS} --without-soft-carrier"
+ use transmitter && MY_OPTS="${MY_OPTS} --with-transmitter"
+
+
+ if [[ -n "${LIRC_OPTS}" ]] ; then
+ ewarn
+ ewarn "LIRC_OPTS is deprecated from lirc-0.8.0-r1 on."
+ ewarn
+ ewarn "Please use LIRC_DEVICES from now on."
+ ewarn "e.g. LIRC_DEVICES=\"serial sir\""
+ ewarn
+ ewarn "Flags are now set per use-flags."
+ ewarn "e.g. transmitter, hardware-carrier"
+
+ local opt
+ local unsupported_opts=""
+
+ # test for allowed options for LIRC_OPTS
+ for opt in ${LIRC_OPTS}; do
+ case ${opt} in
+ --with-port=*|--with-irq=*|--with-timer=*|--with-tty=*)
+ MY_OPTS="${MY_OPTS} ${opt}"
+ ;;
+ *)
+ unsupported_opts="${unsupported_opts} ${opt}"
+ ;;
+ esac
+ done
+ if [[ -n ${unsupported_opts} ]]; then
+ ewarn "These options are no longer allowed to be set"
+ ewarn "with LIRC_OPTS: ${unsupported_opts}"
+ die "LIRC_OPTS is no longer recommended."
+ fi
+ fi
+
+
+ # Setup parameter for linux-mod.eclass
+ MODULE_NAMES="lirc(misc:${S})"
+ BUILD_TARGETS="all"
+
+ ECONF_PARAMS=" --localstatedir=/var
+ --with-syslog=LOG_DAEMON
+ --enable-sandboxed
+ --with-kerneldir=${KV_DIR}
+ --with-moduledir=/lib/modules/${KV_FULL}/misc
+ $(use_enable debug)
+ $(use_with X)
+ ${MY_OPTS}"
+
+ einfo
+ einfo "lirc-configure-opts: ${MY_OPTS}"
+ elog "Setting default lirc-device to ${LIRC_DRIVER_DEVICE}"
+
+ filter-flags -Wl,-O1
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix a sandbox violation while checking which cc to use for Kernel 2.6.19
+ # and newer
+ epatch ${FILESDIR}/${PN}-0.8.0-sandbox-fix.diff
+
+ # Rip out dos CRLF
+ edos2unix contrib/lirc.rules
+
+ # Apply patches needed for some special device-types
+ epatch ${FILESDIR}/lirc-0.8.1-atiusb-xbox.diff
+ use lirc_devices_imon_pad2keys && epatch ${FILESDIR}/${PN}-0.8.1-imon-pad2keys.patch
+ use lirc_devices_remote_wonder_plus && epatch ${FILESDIR}/lirc-remotewonderplus.patch
+
+ # remove parallel driver on SMP systems
+ if linux_chkconfig_present SMP ; then
+ sed -i -e "s:lirc_parallel::" drivers/Makefile.in
+ fi
+
+ # respect CFLAGS
+ sed -i -e 's:CFLAGS="-O2:CFLAGS=""\n#CFLAGS="-O2:' configure.in
+
+ # setting default device-node
+ sed -i -e '/#define LIRC_DRIVER_DEVICE/d' acconfig.h
+ echo "#define LIRC_DRIVER_DEVICE \"${LIRC_DRIVER_DEVICE}\"" >> acconfig.h
+
+ eautoreconf || die "autoreconf failed"
+}
+
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ newinitd ${FILESDIR}/lircd lircd
+ newinitd ${FILESDIR}/lircmd lircmd
+ newconfd ${FILESDIR}/lircd.conf lircd
+
+ insinto /etc/modules.d/
+ newins ${FILESDIR}/modulesd.lirc lirc
+
+ newinitd ${FILESDIR}/irexec-initd irexec
+ newconfd ${FILESDIR}/irexec-confd irexec
+
+ insinto /etc/udev/rules.d/;
+ newins ${S}/contrib/lirc.rules 10-lirc.rules
+
+ if use doc ; then
+ dohtml doc/html/*.html
+ insinto /usr/share/doc/${PF}/images
+ doins doc/images/*
+ fi
+}
+
+pkg_preinst() {
+ linux-mod_pkg_preinst
+ [[ -f "${ROOT}/etc/lircd.conf" ]] && cp ${ROOT}/etc/lircd.conf ${IMAGE}/etc
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ echo
+ elog "The lirc Linux Infrared Remote Control Package has been"
+ elog "merged, please read the documentation at http://www.lirc.org"
+ echo
+}
+