summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2010-02-08 11:50:11 +0000
committerMichael Januszewski <spock@gentoo.org>2010-02-08 11:50:11 +0000
commit62c760134432794a37161c3d12a353a669596786 (patch)
treebd451e5a07f8bce555f0f601a3559c7e4b6db3ed /app-misc/linux-logo/linux-logo-5.07.ebuild
parentFix patch path. (diff)
downloadgentoo-2-62c760134432794a37161c3d12a353a669596786.tar.gz
gentoo-2-62c760134432794a37161c3d12a353a669596786.tar.bz2
gentoo-2-62c760134432794a37161c3d12a353a669596786.zip
Version bump.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/linux-logo/linux-logo-5.07.ebuild')
-rw-r--r--app-misc/linux-logo/linux-logo-5.07.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-misc/linux-logo/linux-logo-5.07.ebuild b/app-misc/linux-logo/linux-logo-5.07.ebuild
new file mode 100644
index 000000000000..12d8492d8ecb
--- /dev/null
+++ b/app-misc/linux-logo/linux-logo-5.07.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/linux-logo/linux-logo-5.07.ebuild,v 1.1 2010/02/08 11:50:11 spock Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN/-/_}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A utility that displays an ANSI/ASCII logo and some system information"
+HOMEPAGE="http://www.deater.net/weave/vmwprod/linux_logo/"
+SRC_URI="http://www.deater.net/weave/vmwprod/linux_logo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo "./logos/gentoo.logo" >> logo_config
+ echo "./logos/gentoo2.logo" >> logo_config
+ echo "./logos/banner-simplified.logo" >> logo_config
+ echo "./logos/banner.logo" >> logo_config
+ echo "./logos/classic-no_periods.logo" >> logo_config
+ echo "./logos/classic-no_periods_or_chars.logo" >> logo_config
+ echo "./logos/classic.logo" >> logo_config
+ cp "${FILESDIR}"/gentoo{,2}.logo "${S}"/logos/
+ echo "NAME gentoo" >> "${S}"/logos/gentoo.logo
+}
+
+src_compile() {
+ ARCH="" ./configure --prefix="${D}"/usr || die
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ make install || die
+
+ dodoc BUGS README README.CUSTOM_LOGOS TODO USAGE LINUX_LOGO.FAQ
+
+ cp "${FILESDIR}"/${PN}.conf "${WORKDIR}"
+ sed -i -e 's/-L 4 -f -u/-f -u/' "${WORKDIR}"/${PN}.conf
+
+ newinitd "${FILESDIR}"/${PN}.initscript ${PN}
+ newconfd "${WORKDIR}"/${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "Linux_logo ebuild for Gentoo comes with two Gentoo logos."
+ elog ""
+ elog "To display the first Gentoo logo type: linux_logo -L gentoo"
+ elog "To display the second Gentoo logo type: linux_logo -L gentoo-alt"
+ elog "To display all the logos available type: linux_logo -L list."
+ elog ""
+ elog "To start linux_logo on boot, please type:"
+ elog " rc-update add linux-logo default"
+ elog "which uses the settings found in"
+ elog " /etc/conf.d/linux-logo"
+ echo
+}