summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-23 18:54:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-23 18:54:50 +0000
commitb86bf328bf760df4d53cf8b7038ac6f3b5d92e03 (patch)
tree76f8b200d5bdec5bb7442da198b4019cd1994072 /app-misc/ledit
parentBump patchset to fix building with nss-3.12 (diff)
downloadgentoo-2-b86bf328bf760df4d53cf8b7038ac6f3b5d92e03.tar.gz
gentoo-2-b86bf328bf760df4d53cf8b7038ac6f3b5d92e03.tar.bz2
gentoo-2-b86bf328bf760df4d53cf8b7038ac6f3b5d92e03.zip
version bump
(Portage version: 2.1.4)
Diffstat (limited to 'app-misc/ledit')
-rw-r--r--app-misc/ledit/ChangeLog7
-rw-r--r--app-misc/ledit/files/digest-ledit-2.003
-rw-r--r--app-misc/ledit/ledit-2.00.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/app-misc/ledit/ChangeLog b/app-misc/ledit/ChangeLog
index 3cf75905b625..5222a773cc1b 100644
--- a/app-misc/ledit/ChangeLog
+++ b/app-misc/ledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/ledit
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.18 2008/01/16 10:11:59 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.19 2008/01/23 18:54:49 aballier Exp $
+
+*ledit-2.00 (23 Jan 2008)
+
+ 23 Jan 2008; Alexis Ballier <aballier@gentoo.org> +ledit-2.00.ebuild:
+ version bump
*ledit-1.17 (16 Jan 2008)
diff --git a/app-misc/ledit/files/digest-ledit-2.00 b/app-misc/ledit/files/digest-ledit-2.00
new file mode 100644
index 000000000000..bb640c7ce79c
--- /dev/null
+++ b/app-misc/ledit/files/digest-ledit-2.00
@@ -0,0 +1,3 @@
+MD5 d5c21dc734e20ce13aa7b995621b1c9a ledit-2.00.tgz 22598
+RMD160 b852f8266acc81eb97fa481f737dd0623eedc340 ledit-2.00.tgz 22598
+SHA256 e6432682b8aa17d93c7c3be2316937e3ba48c9b6ca0789c47f864ee34d10a2fc ledit-2.00.tgz 22598
diff --git a/app-misc/ledit/ledit-2.00.ebuild b/app-misc/ledit/ledit-2.00.ebuild
new file mode 100644
index 000000000000..ffea6f1096d8
--- /dev/null
+++ b/app-misc/ledit/ledit-2.00.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ledit-2.00.ebuild,v 1.1 2008/01/23 18:54:49 aballier Exp $
+
+inherit eutils
+
+EAPI="1"
+
+RESTRICT="installsources"
+IUSE="+ocamlopt"
+
+DESCRIPTION="A line editor to be used with interactive commands."
+SRC_URI="http://pauillac.inria.fr/~ddr/ledit/distrib/src/${P}.tgz"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/ledit/"
+
+DEPEND=">=dev-lang/ocaml-3.09 dev-ml/camlp5"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile()
+{
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 ledit.opt || die "make failed"
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install()
+{
+ if use ocamlopt; then
+ newbin ledit.opt ledit
+ else
+ newbin ledit.out ledit
+ fi
+ doman ledit.1
+ dodoc CHANGES README
+}