summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2012-06-03 17:48:45 +0000
committerHanno Böck <hanno@gentoo.org>2012-06-03 17:48:45 +0000
commitbcbb4512de58ade54089c3108e6d733bbbfe984d (patch)
tree19fb6f336e075150b6c128a4e0ff8711f58822b0 /app-misc/ktoblzcheck
parentCleanup (diff)
downloadgentoo-2-bcbb4512de58ade54089c3108e6d733bbbfe984d.tar.gz
gentoo-2-bcbb4512de58ade54089c3108e6d733bbbfe984d.tar.bz2
gentoo-2-bcbb4512de58ade54089c3108e6d733bbbfe984d.zip
ktoblzcheck bump
(Portage version: 2.1.10.64/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/ktoblzcheck')
-rw-r--r--app-misc/ktoblzcheck/ChangeLog7
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.39.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-misc/ktoblzcheck/ChangeLog b/app-misc/ktoblzcheck/ChangeLog
index 7161056d08f1..bb4d4f7d4e62 100644
--- a/app-misc/ktoblzcheck/ChangeLog
+++ b/app-misc/ktoblzcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/ktoblzcheck
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.80 2012/05/10 10:13:40 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.81 2012/06/03 17:48:45 hanno Exp $
+
+*ktoblzcheck-1.39 (03 Jun 2012)
+
+ 03 Jun 2012; Hanno Boeck <hanno@gentoo.org> +ktoblzcheck-1.39.ebuild:
+ Version bump.
*ktoblzcheck-1.38 (10 May 2012)
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.39.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.39.ebuild
new file mode 100644
index 000000000000..14fcf521ae4c
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.39.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.39.ebuild,v 1.1 2012/06/03 17:48:45 hanno Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.6"
+inherit python
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+RDEPEND="app-text/recode
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/sed
+ || ( net-misc/wget www-client/lynx )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.6b"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ >py-compile
+}
+
+src_configure() {
+ econf $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ktoblzcheck.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ktoblzcheck.py
+}