summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-27 15:50:20 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-27 15:50:20 +0000
commit82f25d72906de9d735c0263969a43841d037474b (patch)
tree8625dd30cede3b3df69cb67b01a861de5818fa34 /app-misc/ktoblzcheck
parentRename jabber USE flag to xmpp, bug #216300. (diff)
downloadgentoo-2-82f25d72906de9d735c0263969a43841d037474b.tar.gz
gentoo-2-82f25d72906de9d735c0263969a43841d037474b.tar.bz2
gentoo-2-82f25d72906de9d735c0263969a43841d037474b.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-misc/ktoblzcheck')
-rw-r--r--app-misc/ktoblzcheck/ChangeLog5
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild29
2 files changed, 12 insertions, 22 deletions
diff --git a/app-misc/ktoblzcheck/ChangeLog b/app-misc/ktoblzcheck/ChangeLog
index 0b0adee329dc..e37f5a9afd68 100644
--- a/app-misc/ktoblzcheck/ChangeLog
+++ b/app-misc/ktoblzcheck/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/ktoblzcheck
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.87 2014/03/22 17:39:46 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.88 2014/12/27 15:50:20 mgorny Exp $
+
+ 27 Dec 2014; Michał Górny <mgorny@gentoo.org> ktoblzcheck-1.45.ebuild:
+ Convert to python-single-r1.
*ktoblzcheck-1.45 (22 Mar 2014)
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild
index 403e7cc489dc..d53a8324e97a 100644
--- a/app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild,v 1.1 2014/03/22 17:39:47 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild,v 1.2 2014/12/27 15:50:20 mgorny Exp $
-EAPI=4
-PYTHON_DEPEND="python? 2:2.6"
-inherit python
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
DESCRIPTION="Library to check account numbers and bank codes of German banks"
HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
@@ -19,21 +19,16 @@ RDEPEND="app-text/recode
virtual/awk
sys-apps/grep
sys-apps/sed
- || ( net-misc/wget www-client/lynx )"
+ || ( net-misc/wget www-client/lynx )
+ python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
>=sys-devel/libtool-2.2.6b"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
DOCS="AUTHORS ChangeLog NEWS README"
pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- >py-compile
+ use python && python-single-r1_pkg_setup
}
src_configure() {
@@ -44,11 +39,3 @@ src_install() {
default
find "${ED}" -name '*.la' -exec rm -f {} +
}
-
-pkg_postinst() {
- use python && python_mod_optimize ktoblzcheck.py
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup ktoblzcheck.py
-}