summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-28 20:49:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-28 20:49:56 +0000
commit349c5bc3f70182e3399325bcbdc689e21f8da1ce (patch)
tree8670cff4ffc07340ddb10c3f3993e106d7e27e7f /app-misc/ktoblzcheck
parentAdded manpages (diff)
downloadgentoo-2-349c5bc3f70182e3399325bcbdc689e21f8da1ce.tar.gz
gentoo-2-349c5bc3f70182e3399325bcbdc689e21f8da1ce.tar.bz2
gentoo-2-349c5bc3f70182e3399325bcbdc689e21f8da1ce.zip
Version bump.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/ktoblzcheck')
-rw-r--r--app-misc/ktoblzcheck/ChangeLog7
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.31.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/app-misc/ktoblzcheck/ChangeLog b/app-misc/ktoblzcheck/ChangeLog
index f7c0c69dc228..5db3b0344763 100644
--- a/app-misc/ktoblzcheck/ChangeLog
+++ b/app-misc/ktoblzcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/ktoblzcheck
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.70 2011/02/26 11:23:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.71 2011/02/28 20:49:56 ssuominen Exp $
+
+*ktoblzcheck-1.31 (28 Feb 2011)
+
+ 28 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> +ktoblzcheck-1.31.ebuild:
+ Version bump.
26 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> ktoblzcheck-1.28.ebuild:
amd64 stable wrt #355077
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.31.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.31.ebuild
new file mode 100644
index 000000000000..431bae909d28
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.31.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.31.ebuild,v 1.1 2011/02/28 20:49:56 ssuominen Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit python
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+RDEPEND="app-text/recode
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/sed
+ || ( net-misc/wget www-client/lynx )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ rm -f py-compile
+ ln -s $(type -P true) py-compile || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable python)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ktoblzcheck.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ktoblzcheck.py
+}