summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 03:52:07 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 03:52:07 +0000
commit006a74bca9e3838b375dff922238960dc31ccc77 (patch)
tree26dc2282aaf612c7e017a6c23c27e7a731d15a61 /app-misc/ktoblzcheck
parentchange glibc to libc and clean up other horribly ugly ebuilds (Manifest recom... (diff)
downloadgentoo-2-006a74bca9e3838b375dff922238960dc31ccc77.tar.gz
gentoo-2-006a74bca9e3838b375dff922238960dc31ccc77.tar.bz2
gentoo-2-006a74bca9e3838b375dff922238960dc31ccc77.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc/ktoblzcheck')
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild13
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild8
2 files changed, 10 insertions, 11 deletions
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild
index 0a99f7b74387..f55177dcc43c 100644
--- a/app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild
+++ b/app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild
@@ -1,31 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild,v 1.1 2004/06/24 22:51:54 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild,v 1.2 2004/06/28 03:51:07 vapier Exp $
DESCRIPTION="Library to check account numbers and bank codes of German banks"
HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
SRC_URI="mirror://sourceforge/ktoblzcheck/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
-RDEPEND="virtual/glibc"
+
+RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
sys-apps/gawk
sys-apps/grep
sys-devel/libtool
sys-devel/gcc"
-src_compile() {
- econf || die
- emake || die
-}
-
src_install() {
einstall BANKDATA_PATH="${D}/usr/share/ktoblzcheck" || die
}
src_test() {
- cd ${S}/src/bin/
+ cd src/bin
./check_ktoblzcheck || die "self check of accounts failed"
}
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild
index cbad0014d222..bb992bd0b93f 100644
--- a/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild
+++ b/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild,v 1.6 2004/06/24 22:20:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild,v 1.7 2004/06/28 03:51:07 vapier Exp $
DESCRIPTION="Library to check account numbers and bank codes of German banks"
HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
SRC_URI="mirror://sourceforge/ktoblzcheck/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
-RDEPEND="virtual/glibc"
+
+RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
sys-apps/gawk
sys-apps/grep
@@ -21,6 +23,6 @@ src_install() {
}
src_test() {
- cd ${S}/src/bin/
+ cd src/bin
./check_ktoblzcheck || die "self check of accounts failed"
}