summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-04-07 04:10:41 +0000
committerMike Frysinger <vapier@gentoo.org>2015-04-07 04:10:41 +0000
commit8a6807381ccd5b99b880c4de9f156123341d2840 (patch)
treeef3c593ec78d9371570d1201b06c14899f7570e1 /app-misc/jq
parentFix -9999 ebuild to not build docs and manpages as this doesn't work, upstrea... (diff)
downloadgentoo-2-8a6807381ccd5b99b880c4de9f156123341d2840.tar.gz
gentoo-2-8a6807381ccd5b99b880c4de9f156123341d2840.tar.bz2
gentoo-2-8a6807381ccd5b99b880c4de9f156123341d2840.zip
Add USE=static-libs and fix linking of jq against the dynamic lib; fixes from Chromium OS.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-misc/jq')
-rw-r--r--app-misc/jq/ChangeLog11
-rw-r--r--app-misc/jq/files/jq-1.4-dynamic-link.patch12
-rw-r--r--app-misc/jq/jq-1.4-r1.ebuild40
3 files changed, 61 insertions, 2 deletions
diff --git a/app-misc/jq/ChangeLog b/app-misc/jq/ChangeLog
index a6791d1f9408..3e24ed8db37a 100644
--- a/app-misc/jq/ChangeLog
+++ b/app-misc/jq/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/jq
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jq/ChangeLog,v 1.15 2014/12/11 07:33:30 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jq/ChangeLog,v 1.16 2015/04/07 04:10:41 vapier Exp $
+
+*jq-1.4-r1 (07 Apr 2015)
+
+ 07 Apr 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/jq-1.4-dynamic-link.patch, +jq-1.4-r1.ebuild:
+ Add USE=static-libs and fix linking of jq against the dynamic lib; fixes from
+ Chromium OS.
11 Dec 2014; Tim Harder <radhermit@gentoo.org> -jq-1.3.ebuild,
-files/jq-1.3-automake-1.14.patch:
diff --git a/app-misc/jq/files/jq-1.4-dynamic-link.patch b/app-misc/jq/files/jq-1.4-dynamic-link.patch
new file mode 100644
index 000000000000..b958a1556125
--- /dev/null
+++ b/app-misc/jq/files/jq-1.4-dynamic-link.patch
@@ -0,0 +1,12 @@
+do not statically link libjq since we install it
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -53,7 +53,6 @@
+
+ bin_PROGRAMS = jq
+ jq_SOURCES = main.c
+-jq_LDFLAGS = -static-libtool-libs
+ jq_LDADD = libjq.la -lm
+
+ ### Tests (make check)
diff --git a/app-misc/jq/jq-1.4-r1.ebuild b/app-misc/jq/jq-1.4-r1.ebuild
new file mode 100644
index 000000000000..404b07be4c35
--- /dev/null
+++ b/app-misc/jq/jq-1.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jq/jq-1.4-r1.ebuild,v 1.1 2015/04/07 04:10:41 vapier Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A lightweight and flexible command-line JSON processor"
+HOMEPAGE="http://stedolan.github.com/jq/"
+SRC_URI="http://stedolan.github.io/jq/download/source/${P}.tar.gz"
+
+LICENSE="MIT CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ test? ( dev-util/valgrind )"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ epatch "${FILESDIR}"/${PN}-1.4-dynamic-link.patch
+ eautoreconf
+}
+
+src_configure() {
+ # don't try to rebuild docs
+ econf \
+ --disable-docs \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name libjq.la -delete
+}