summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-07 15:14:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-07 15:14:39 +0000
commitcba9974ba52ac1f20e3237ad2404fd3b11d527f4 (patch)
tree6128872b4ff1993ccae4662ba2e4b01c35095dc0 /app-misc/iguanaIR
parentAdjust dependencies for fixed dev-libs/icu (bug #410777 by biohazrd). Thanks ... (diff)
downloadgentoo-2-cba9974ba52ac1f20e3237ad2404fd3b11d527f4.tar.gz
gentoo-2-cba9974ba52ac1f20e3237ad2404fd3b11d527f4.tar.bz2
gentoo-2-cba9974ba52ac1f20e3237ad2404fd3b11d527f4.zip
Version bump wrt #308921 by Derek Adams and Clement Siuchung Cheung. This version will respect LDFLAGS wrt #337354 and missing -lpthread wrt #367643 by Diego Elio Pettenò. Workaround broken SWIG version check and missing dependency wrt #398877 by "digital.or".
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/iguanaIR')
-rw-r--r--app-misc/iguanaIR/ChangeLog10
-rw-r--r--app-misc/iguanaIR/iguanaIR-1.0.1.ebuild45
2 files changed, 54 insertions, 1 deletions
diff --git a/app-misc/iguanaIR/ChangeLog b/app-misc/iguanaIR/ChangeLog
index b5b74bbb3bf0..00860022b900 100644
--- a/app-misc/iguanaIR/ChangeLog
+++ b/app-misc/iguanaIR/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/iguanaIR
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/iguanaIR/ChangeLog,v 1.8 2012/05/07 14:38:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/iguanaIR/ChangeLog,v 1.9 2012/05/07 15:14:39 ssuominen Exp $
+
+*iguanaIR-1.0.1 (07 May 2012)
+
+ 07 May 2012; Samuli Suominen <ssuominen@gentoo.org> +iguanaIR-1.0.1.ebuild:
+ Version bump wrt #308921 by Derek Adams and Clement Siuchung Cheung. This
+ version will respect LDFLAGS wrt #337354 and missing -lpthread wrt #367643 by
+ Diego Elio Pettenò. Workaround broken SWIG version check and missing
+ dependency wrt #398877 by "digital.or".
07 May 2012; Samuli Suominen <ssuominen@gentoo.org> iguanaIR-0.93.ebuild:
Missing virtual/libusb:0 dependency wrt #336511 by Clement Siuchung Cheung.
diff --git a/app-misc/iguanaIR/iguanaIR-1.0.1.ebuild b/app-misc/iguanaIR/iguanaIR-1.0.1.ebuild
new file mode 100644
index 000000000000..04384d6701de
--- /dev/null
+++ b/app-misc/iguanaIR/iguanaIR-1.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/iguanaIR/iguanaIR-1.0.1.ebuild,v 1.1 2012/05/07 15:14:39 ssuominen Exp $
+
+EAPI=4
+inherit python user
+
+DESCRIPTION="library for Irman control of Unix software"
+HOMEPAGE="http://iguanaworks.net/index.php"
+SRC_URI="http://iguanaworks.net/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# sys-apps/lsb-release is used by the init script for detecting Gentoo
+RDEPEND="dev-libs/popt
+ sys-apps/lsb-release
+ virtual/libusb:0"
+DEPEND="${RDEPEND}
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ >=dev-lang/swig-2.0.0"
+
+pkg_setup() {
+ enewgroup iguanair
+ enewuser iguanair -1 -1 -1 'iguanair,usb'
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Working around bug in SWIG version checking
+ sed -i -e 's:1.3.31:2.0.0:g' configure || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS README.txt WHY notes.txt protocols.txt
+
+ rm -f docs/{Makefile,pullDocs}
+ dodoc -r docs
+}