summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-12-01 17:26:53 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-12-01 17:26:53 +0000
commita1129476ac83d3a9c8692b22661c76bedc374020 (patch)
tree38592990e66ff38710367da9ae7fddcbc4864991 /app-misc/hivex
parentStable for HPPA (bug #391517). (diff)
downloadgentoo-2-a1129476ac83d3a9c8692b22661c76bedc374020.tar.gz
gentoo-2-a1129476ac83d3a9c8692b22661c76bedc374020.tar.bz2
gentoo-2-a1129476ac83d3a9c8692b22661c76bedc374020.zip
Fix usage of autotools-utils.eclass, bug 392087. Thanks to mgorny and slepnoga
(Portage version: 2.1.10.33/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/ChangeLog8
-rw-r--r--app-misc/hivex/hivex-1.3.2-r1.ebuild81
2 files changed, 88 insertions, 1 deletions
diff --git a/app-misc/hivex/ChangeLog b/app-misc/hivex/ChangeLog
index eab23ab0c07d..eca2989b292b 100644
--- a/app-misc/hivex/ChangeLog
+++ b/app-misc/hivex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/hivex
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.10 2011/11/10 12:53:10 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.11 2011/12/01 17:26:53 maksbotan Exp $
+
+*hivex-1.3.2-r1 (01 Dec 2011)
+
+ 01 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> +hivex-1.3.2-r1.ebuild:
+ Fix usage of autotools-utils.eclass, bug 392087. Thanks to mgorny and
+ slepnoga
10 Nov 2011; Maxim Koltsov <maksbotan@gentoo.org> hivex-1.3.2.ebuild:
Fix pkg_setup to call python_pkg_setup, bug #389691. Thanks to Arfrever.
diff --git a/app-misc/hivex/hivex-1.3.2-r1.ebuild b/app-misc/hivex/hivex-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..1b56b5461c24
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.2-r1.ebuild,v 1.1 2011/12/01 17:26:53 maksbotan Exp $
+
+EAPI=4
+
+WANT_AUTOMAKE="1.11"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PYTHON_DEPEND="python? 2:2.6"
+inherit base autotools-utils perl-app python
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline perl python test static-libs ruby"
+
+RDEPEND="virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline )
+ perl? ( dev-perl/IO-stringy )
+ "
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage ) )
+ ruby? ( dev-ruby/rake )
+ "
+PATCHES=("${FILESDIR}"/autoconf_fix-${PV}.patch
+"${FILESDIR}"/python-test-fix-${PV}.patch)
+DOCS=(README)
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ python_need_rebuild
+ fi
+}
+
+src_prepare() {
+ autotools-utils_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ $(use_enable python)
+ $(use_enable ruby)
+ --disable-rpath )
+
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_compile check
+}
+
+src_install() {
+ strip-linguas -i po
+
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ if use perl; then
+ fixlocalpod
+ fi
+}