summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-09-26 13:59:42 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-09-26 13:59:42 +0000
commitee63544afad7e2124038606d343c830d052efbe4 (patch)
tree42220db19ce670845708384a31c424ed38a16e8f /app-misc/gtypist
parentRekeyword on ppc now that xvid USE is masked on powerpc profile and there is ... (diff)
downloadgentoo-2-ee63544afad7e2124038606d343c830d052efbe4.tar.gz
gentoo-2-ee63544afad7e2124038606d343c830d052efbe4.tar.bz2
gentoo-2-ee63544afad7e2124038606d343c830d052efbe4.zip
style changes, add Gentoo Prefix support
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'app-misc/gtypist')
-rw-r--r--app-misc/gtypist/ChangeLog5
-rw-r--r--app-misc/gtypist/gtypist-2.8.5-r1.ebuild20
2 files changed, 16 insertions, 9 deletions
diff --git a/app-misc/gtypist/ChangeLog b/app-misc/gtypist/ChangeLog
index 9df543100451..c7ef34a8cc4d 100644
--- a/app-misc/gtypist/ChangeLog
+++ b/app-misc/gtypist/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/gtypist
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/ChangeLog,v 1.28 2011/09/24 20:53:13 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/ChangeLog,v 1.29 2011/09/26 13:59:42 darkside Exp $
+
+ 26 Sep 2011; Jeremy Olexa <darkside@gentoo.org> gtypist-2.8.5-r1.ebuild:
+ style changes, add Gentoo Prefix support
*gtypist-2.8.5-r1 (24 Sep 2011)
diff --git a/app-misc/gtypist/gtypist-2.8.5-r1.ebuild b/app-misc/gtypist/gtypist-2.8.5-r1.ebuild
index 8702d1aa91fa..b16277ca46bc 100644
--- a/app-misc/gtypist/gtypist-2.8.5-r1.ebuild
+++ b/app-misc/gtypist/gtypist-2.8.5-r1.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.8.5-r1.ebuild,v 1.1 2011/09/24 20:53:13 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.8.5-r1.ebuild,v 1.2 2011/09/26 13:59:42 darkside Exp $
-EAPI=2
+EAPI=4
inherit eutils elisp-common
DESCRIPTION="Universal typing tutor"
HOMEPAGE="http://www.gnu.org/software/gtypist/"
SRC_URI="mirror://gnu/gtypist/${P}.tar.gz
- mirror://gentoo/colemak.typ.gz"
+ http://colemak.com/pub/learn/colemak.typ"
LICENSE="GPL-2 public-domain"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
IUSE="nls emacs xemacs"
DEPEND=">=sys-libs/ncurses-5.2
@@ -24,6 +24,10 @@ RDEPEND="${DEPEND}"
SITEFILE=50${PN}-gentoo.el
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-2.8.3-xemacs-compat.patch
}
@@ -34,7 +38,7 @@ src_configure() {
lispdir="${SITELISP}/${PN}"
einfo "Configuring to build with GNU Emacs support"
elif use xemacs; then
- lispdir="/usr/lib/xemacs/site-packages/lisp/${PN}"
+ lispdir="${EPREFIX}/usr/lib/xemacs/site-packages/lisp/${PN}"
einfo "Configuring to build with XEmacs support"
fi
@@ -44,11 +48,11 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
insinto /usr/share/gtypist
- doins "${WORKDIR}"/colemak.typ
+ doins ${DISTDIR}/colemak.typ
if use emacs; then
elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die