summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-03-29 20:15:15 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-03-29 20:15:15 +0000
commit19799cf38f0ddfd6f142c65514e1989a984b1668 (patch)
tree3b15037a3b880f65e58e0859a4285f39dd3d514d /app-misc/gramps
parentclean up (diff)
downloadgentoo-2-19799cf38f0ddfd6f142c65514e1989a984b1668.tar.gz
gentoo-2-19799cf38f0ddfd6f142c65514e1989a984b1668.tar.bz2
gentoo-2-19799cf38f0ddfd6f142c65514e1989a984b1668.zip
Fix bug 262644: Dustin Polke <gentoobugzilla DOT 20 DOT dsurawicz AT spamgourmet DOT com> reported a problem with .pyo and .pyc being installed under /usr/share, which is a QA violation. This should have been fixed with bug 215944, but the fix there was just a workaround to quiten Portage QA warnings without solving the problem. Dustin provided a patch for all this.
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'app-misc/gramps')
-rw-r--r--app-misc/gramps/ChangeLog10
-rw-r--r--app-misc/gramps/gramps-3.1.1.ebuild29
2 files changed, 35 insertions, 4 deletions
diff --git a/app-misc/gramps/ChangeLog b/app-misc/gramps/ChangeLog
index e4296b2ce2f6..e61025ebf3b3 100644
--- a/app-misc/gramps/ChangeLog
+++ b/app-misc/gramps/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/gramps
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/ChangeLog,v 1.100 2009/03/19 17:07:01 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/ChangeLog,v 1.101 2009/03/29 20:15:15 fauli Exp $
+
+ 29 Mar 2009; Christian Faulhammer <fauli@gentoo.org> gramps-3.1.1.ebuild:
+ Fix bug 262644: Dustin Polke <gentoobugzilla DOT 20 DOT dsurawicz AT
+ spamgourmet DOT com> reported a problem with .pyo and .pyc being installed
+ under /usr/share, which is a QA violation. This should have been fixed
+ with bug 215944, but the fix there was just a workaround to quiten Portage
+ QA warnings without solving the problem. Dustin provided a patch for all
+ this.
19 Mar 2009; Joseph Jezak <josejx@gentoo.org> gramps-3.1.1.ebuild:
Marked ~ppc for bug #261672.
diff --git a/app-misc/gramps/gramps-3.1.1.ebuild b/app-misc/gramps/gramps-3.1.1.ebuild
index ca3f45c99207..bb768113fa8a 100644
--- a/app-misc/gramps/gramps-3.1.1.ebuild
+++ b/app-misc/gramps/gramps-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/gramps-3.1.1.ebuild,v 1.3 2009/03/19 17:07:01 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/gramps-3.1.1.ebuild,v 1.4 2009/03/29 20:15:15 fauli Exp $
EAPI=2
NEED_PYTHON="2.5"
@@ -47,6 +47,27 @@ src_unpack() {
# file system
mv "${S}"/py-compile "${S}"/py-compile.orig
ln -s $(type -P true) "${S}"/py-compile
+
+ python_version
+
+ # Fix install path.
+ einfo "Fix installation path"
+ find . -iname 'Makefile.in' | xargs \
+ sed "s;\(pkgdatadir = \)\(\$(datadir)\);\1$(python_get_sitedir);" -i \
+ || die
+
+ sed "s;\$(prefix)/share/gramps;/$(python_get_sitedir)/@PACKAGE@;" \
+ -i src/Makefile.in || die
+
+ sed "s;\$(prefix)/share/gramps;/$(python_get_sitedir)/@PACKAGE@;" \
+ -i src/docgen/Makefile.in || die
+
+ einfo "Fix wrapper script"
+ sed "s;@datadir@;$(python_get_sitedir);" \
+ -i gramps.sh.in || die
+
+ einfo "Fix icon location"
+ sed "s;gramps/;pixmap/;g" -i data/gramps.keys.in || die
}
src_install() {
@@ -56,10 +77,12 @@ src_install() {
pkg_postinst() {
gnome2_pkg_postinst
- python_mod_optimize /usr/share/${PN}
+ python_version
+ python_mod_optimize $(python_get_sitedir)/${PN}
}
pkg_postrm() {
gnome2_pkg_postrm
- python_mod_cleanup /usr/share/${PN}
+ python_version
+ python_mod_cleanup $(python_get_sitedir)/${PN}
}