summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-01-13 21:58:24 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-01-13 21:58:24 +0000
commit11e1f7c549b1e6e2c40ef9f0eeda769dedf903b0 (patch)
tree8699085625a5a9fb7ef1b8da0edaaa37ee4cec89 /app-misc/gramps
parentversion bump (diff)
downloadgentoo-2-11e1f7c549b1e6e2c40ef9f0eeda769dedf903b0.tar.gz
gentoo-2-11e1f7c549b1e6e2c40ef9f0eeda769dedf903b0.tar.bz2
gentoo-2-11e1f7c549b1e6e2c40ef9f0eeda769dedf903b0.zip
install mo files, as reported by Sven Wehner <sven AT atelophobia DOT de> on bug 300293
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-misc/gramps')
-rw-r--r--app-misc/gramps/ChangeLog11
-rw-r--r--app-misc/gramps/files/gramps-3.1.3-fix_mo_install.patch11
-rw-r--r--app-misc/gramps/gramps-3.1.3-r1.ebuild95
3 files changed, 115 insertions, 2 deletions
diff --git a/app-misc/gramps/ChangeLog b/app-misc/gramps/ChangeLog
index ebfe559ce405..b58de0ec3d61 100644
--- a/app-misc/gramps/ChangeLog
+++ b/app-misc/gramps/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/gramps
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/ChangeLog,v 1.114 2009/12/25 00:07:00 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/ChangeLog,v 1.115 2010/01/13 21:58:23 fauli Exp $
+
+*gramps-3.1.3-r1 (13 Jan 2010)
+
+ 13 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
+ +gramps-3.1.3-r1.ebuild, +files/gramps-3.1.3-fix_mo_install.patch:
+ install mo files, as reported by Sven Wehner <sven AT atelophobia DOT de>
+ on bug 300293
25 Dec 2009; Christian Faulhammer <fauli@gentoo.org>
-gramps-3.1.1-r1.ebuild, -gramps-3.1.2.ebuild:
diff --git a/app-misc/gramps/files/gramps-3.1.3-fix_mo_install.patch b/app-misc/gramps/files/gramps-3.1.3-fix_mo_install.patch
new file mode 100644
index 000000000000..3b7978b633fc
--- /dev/null
+++ b/app-misc/gramps/files/gramps-3.1.3-fix_mo_install.patch
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in-orig 2010-01-13 22:50:46.471767466 +0100
++++ po/Makefile.in.in 2010-01-13 22:51:10.263766542 +0100
+@@ -56,7 +56,7 @@
+
+ PO_LINGUAS=$(shell if test -r $(srcdir)/LINGUAS; then grep -v "^\#" $(srcdir)/LINGUAS; else echo "$(ALL_LINGUAS)"; fi)
+
+-USER_LINGUAS=$(shell if test -n "$(LINGUAS)"; then LLINGUAS="$(LINGUAS)"; ALINGUAS="$(ALL_LINGUAS)"; for lang in $$LLINGUAS; do if test -n "`grep '^$$lang$$' $(srcdir)/LINGUAS 2>/dev/null`" -o -n "`echo $$ALINGUAS|tr ' ' '\n'|grep '^$$lang$$'`"; then printf "$$lang "; fi; done; fi)
++USER_LINGUAS=$(shell if test -n "$(LINGUAS)"; then LLINGUAS="$(LINGUAS)"; ALINGUAS="$(ALL_LINGUAS)"; for lang in $$LLINGUAS; do if test -n "`grep ^$$lang$$ $(srcdir)/LINGUAS 2>/dev/null`" -o -n "`echo $$ALINGUAS|tr ' ' '\n'|grep ^$$lang$$`"; then printf "$$lang "; fi; done; fi)
+
+ USE_LINGUAS=$(shell if test -n "$(USER_LINGUAS)" -o -n "$(LINGUAS)"; then LLINGUAS="$(USER_LINGUAS)"; else if test -n "$(PO_LINGUAS)"; then LLINGUAS="$(PO_LINGUAS)"; else LLINGUAS="$(ALL_LINGUAS)"; fi; fi; for lang in $$LLINGUAS; do printf "$$lang "; done)
+
diff --git a/app-misc/gramps/gramps-3.1.3-r1.ebuild b/app-misc/gramps/gramps-3.1.3-r1.ebuild
new file mode 100644
index 000000000000..73120feb21b4
--- /dev/null
+++ b/app-misc/gramps/gramps-3.1.3-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/gramps-3.1.3-r1.ebuild,v 1.1 2010/01/13 21:58:23 fauli Exp $
+
+EAPI=2
+
+inherit autotools eutils gnome2 python
+
+DESCRIPTION="Genealogical Research and Analysis Management Programming System"
+HOMEPAGE="http://www.gramps-project.org/"
+SRC_URI="mirror://sourceforge/gramps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gnome mozembed reports spell webkit"
+
+RDEPEND=">=dev-lang/python-2.5
+ dev-python/bsddb3
+ >=dev-python/pygtk-2.10.0
+ x11-misc/xdg-utils
+ gnome-base/librsvg:2
+ gnome? ( dev-python/libgnome-python
+ dev-python/gconf-python )
+ mozembed? ( dev-python/gtkmozembed-python )
+ spell? ( dev-python/gtkspell-python
+ dev-python/pyenchant )
+ reports? ( media-gfx/graphviz )
+ webkit? ( dev-python/pywebkitgtk )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/libiconv
+ dev-util/pkgconfig"
+
+DOCS="NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-mime-install"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # berkdb is deprecated, see bug 286496; fixed in development
+ # branch (3.2)
+ epatch "${FILESDIR}"/${PN}-3.1.2-use_bsddb3.patch
+
+ # .mo files are not installed, see bug 300293
+ epatch "${FILESDIR}"/${P}-fix_mo_install.patch
+
+ eautoreconf
+
+ # This is for bug 215944, so .pyo/.pyc files don't get into the
+ # file system
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+
+ python_version
+
+ # Fix install path.
+ einfo "Fix installation path"
+ find . -iname 'Makefile.in' | xargs \
+ sed "s;\(pkgdatadir = \)\(\$(datadir)\);\1$(python_get_sitedir);" -i \
+ || die
+
+ sed "s;\$(prefix)/share/gramps;/$(python_get_sitedir)/@PACKAGE@;" \
+ -i src/Makefile.in || die
+
+ sed "s;\$(prefix)/share/gramps;/$(python_get_sitedir)/@PACKAGE@;" \
+ -i src/docgen/Makefile.in || die
+
+ einfo "Fix wrapper script"
+ sed "s;@datadir@;$(python_get_sitedir);" \
+ -i gramps.sh.in || die
+
+ einfo "Fix icon location"
+ sed "s;gramps/;pixmap/;g" -i data/gramps.keys.in || die
+}
+
+src_install() {
+ python_need_rebuild
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize $(python_get_sitedir)/${PN}
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_version
+ python_mod_cleanup $(python_get_sitedir)/${PN}
+}