summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-02-20 05:29:41 +0000
committerJonathan Callen <abcd@gentoo.org>2010-02-20 05:29:41 +0000
commitfd125bdc29d01dd20f26c2ef8e7899fb487bbb56 (patch)
tree4f53408fe62a6fcccaf4b38a27d4c43a96bd4e10 /app-misc/getopt
parentFix bindist icon installationFix bindist icon installation (diff)
downloadgentoo-2-fd125bdc29d01dd20f26c2ef8e7899fb487bbb56.tar.gz
gentoo-2-fd125bdc29d01dd20f26c2ef8e7899fb487bbb56.tar.bz2
gentoo-2-fd125bdc29d01dd20f26c2ef8e7899fb487bbb56.zip
Add prefix herd to metadata; merge prefix support from overlay
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-misc/getopt')
-rw-r--r--app-misc/getopt/ChangeLog8
-rw-r--r--app-misc/getopt/files/getopt-1.1.4-irix.patch17
-rw-r--r--app-misc/getopt/getopt-1.1.4.ebuild25
-rw-r--r--app-misc/getopt/metadata.xml1
4 files changed, 40 insertions, 11 deletions
diff --git a/app-misc/getopt/ChangeLog b/app-misc/getopt/ChangeLog
index 2541f1928a5e..f7049e3f2072 100644
--- a/app-misc/getopt/ChangeLog
+++ b/app-misc/getopt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/getopt
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/getopt/ChangeLog,v 1.2 2007/07/11 20:38:10 uberlord Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/getopt/ChangeLog,v 1.3 2010/02/20 05:29:40 abcd Exp $
+
+ 20 Feb 2010; Jonathan Callen <abcd@gentoo.org> getopt-1.1.4.ebuild,
+ +files/getopt-1.1.4-irix.patch, metadata.xml:
+ Add prefix herd to metadata; merge prefix support from overlay
11 Jul 2007; Roy Marples <uberlord@gentoo.org> getopt-1.1.4.ebuild:
Keyworded ~sparc-fbsd.
diff --git a/app-misc/getopt/files/getopt-1.1.4-irix.patch b/app-misc/getopt/files/getopt-1.1.4-irix.patch
new file mode 100644
index 000000000000..0c344a80131a
--- /dev/null
+++ b/app-misc/getopt/files/getopt-1.1.4-irix.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/show_bug.cgi?id=211499
+
+--- gnu/getopt.c.dist
++++ gnu/getopt.c
+@@ -69,12 +69,7 @@
+ #include <unistd.h>
+ #endif /* GNU C library. */
+
+-#ifdef VMS
+-#include <unixlib.h>
+-#if HAVE_STRING_H - 0
+ #include <string.h>
+-#endif
+-#endif
+
+ #if defined (WIN32) && !defined (__CYGWIN32__)
+ /* It's not Unix, really. See? Capital letters. */
diff --git a/app-misc/getopt/getopt-1.1.4.ebuild b/app-misc/getopt/getopt-1.1.4.ebuild
index b9f43d8117a0..0af71b6b96af 100644
--- a/app-misc/getopt/getopt-1.1.4.ebuild
+++ b/app-misc/getopt/getopt-1.1.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/getopt/getopt-1.1.4.ebuild,v 1.2 2007/07/11 20:38:10 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/getopt/getopt-1.1.4.ebuild,v 1.3 2010/02/20 05:29:40 abcd Exp $
+
+EAPI=3
inherit toolchain-funcs eutils
@@ -10,37 +12,42 @@ SRC_URI="http://software.frodo.looijaard.name/getopt/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~sparc-fbsd ~x86-fbsd ~x86-interix ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="nls"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}/${P}-libintl.patch"
epatch "${FILESDIR}/${P}-longrename.patch"
+
+ # hopefully this is portable enough
+ epatch "${FILESDIR}"/${P}-irix.patch
}
src_compile() {
local nogettext="1"
local libintl=""
+ local libcgetopt=1
if use nls; then
nogettext=0
has_version sys-libs/glibc || libintl="-lintl"
fi
- emake CC="$(tc-getCC)" prefix="/usr" \
+ [[ ${CHOST} == *-irix* ]] && libcgetopt=0
+ [[ ${CHOST} == *-interix* ]] && libcgetopt=0
+
+ emake CC="$(tc-getCC)" prefix="${EPREFIX}/usr" \
+ LIBCGETOPT=${libcgetopt} \
WITHOUT_GETTEXT=${nogettext} LIBINTL=${libintl} \
CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {
- use nls && make prefix="/usr" DESTDIR="${D}" install_po
+ use nls && make prefix="${EPREFIX}/usr" DESTDIR="${D}" install_po
into /usr
newbin getopt getopt-long
diff --git a/app-misc/getopt/metadata.xml b/app-misc/getopt/metadata.xml
index ecedda4aa2cc..f4618b6e7fe3 100644
--- a/app-misc/getopt/metadata.xml
+++ b/app-misc/getopt/metadata.xml
@@ -2,4 +2,5 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>bsd</herd>
+<herd>prefix</herd>
</pkgmetadata>