summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-07 16:52:06 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-07 16:52:06 +0000
commit3735c9cf837e6d67453fd99be02b2af2ab481414 (patch)
tree74403490dd4c11d51070d1d2b52c6841560233c9 /app-misc/gentoo
parentuse die instead of try (diff)
downloadgentoo-2-3735c9cf837e6d67453fd99be02b2af2ab481414.tar.gz
gentoo-2-3735c9cf837e6d67453fd99be02b2af2ab481414.tar.bz2
gentoo-2-3735c9cf837e6d67453fd99be02b2af2ab481414.zip
updated
Diffstat (limited to 'app-misc/gentoo')
-rw-r--r--app-misc/gentoo/gentoo-0.11.16-r1.ebuild54
1 files changed, 30 insertions, 24 deletions
diff --git a/app-misc/gentoo/gentoo-0.11.16-r1.ebuild b/app-misc/gentoo/gentoo-0.11.16-r1.ebuild
index a784af816b74..394bf736514c 100644
--- a/app-misc/gentoo/gentoo-0.11.16-r1.ebuild
+++ b/app-misc/gentoo/gentoo-0.11.16-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gentoo/gentoo-0.11.16-r1.ebuild,v 1.1 2001/10/07 15:02:08 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gentoo/gentoo-0.11.16-r1.ebuild,v 1.2 2001/10/07 16:52:06 hallski Exp $
S=${WORKDIR}/${P}
@@ -12,34 +12,40 @@ HOMEPAGE="http://www.obsession.se/gentoo/"
DEPEND=">=gnome-base/gnome-core-1.4.0.4-r1"
src_compile() {
- cd src
- cp Makefile Makefile.orig
- sed -e "s:= /usr/local:= /usr:g" \
- -e "s:ICONS:ICONS= /usr/share/gentoo #:g" \
- -e 's:${prefix}/etc:/etc/gnome/gentoo:g' \
- -e 's:${exec_prefix}/lib/gentoo/icons:${exec_prefix}/share/gentoo/icons:g' Makefile.orig > Makefile
- rm Makefile.orig
- cd ..
- try make
+ cd src
+ cp Makefile Makefile.orig
+ sed -e "s:= /usr/local:= /usr:g" \
+ -e "s:ICONS:ICONS= /usr/share/gentoo #:g" \
+ -e 's:${prefix}/etc:/etc/gnome/gentoo:g' \
+ -e 's:${exec_prefix}/lib/gentoo/icons:${exec_prefix}/share/gentoo/icons:g' Makefile.orig > Makefile
+
+ rm Makefile.orig
+
+ cd ..
+
+ make || die
}
src_install() {
- cd src
- into /usr
- dobin gentoo
- cd ..
- dodir /usr/share
- dodir /usr/share/gentoo
- # Maybe fixed later
- cp -a icons ${D}/usr/share/gentoo
- chmod 755 ${D}/usr/share/gentoo/icons
-
- insinto /etc/gnome/gentoo
- doins gentoorc-example
-
- dodoc COPYING README TODO
+ cd src
+ into /usr
+ dobin gentoo
+
+ cd ..
+ dodir /usr/share
+ dodir /usr/share/gentoo
+
+ # Maybe fixed later
+ cp -a icons ${D}/usr/share/gentoo
+ chmod 755 ${D}/usr/share/gentoo/icons
+
+ insinto /etc/gnome/gentoo
+ doins gentoorc-example
+
+ dodoc COPYING README TODO
}
+